Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
Sign in using an external account
Register Forgot Password?

C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 08-25-2007, 06:47 PM   #51
Almost a Member!
 
Join Date: Jul 2007
Location: Nj
Posts: 42
Drives: c240
that did not work for me it says service is over due now
To remove this ad, register today or login if you already are registered!

fresh240 is offline   Reply With Quote
Old 11-19-2007, 08:39 PM   #52
Newbie
 
Join Date: Nov 2007
Posts: 10
Drives: 2003 C240
Send a message via AIM to NickMangus
Service light reset device

I am a newcomer to MB and this forum. I recently bought a 2003 C240. Being a DIYer on my Lotus, Porsche and other stuff, I wanted to be prepared so I purchased a simple device with a 38 PIN connector for resetting the service reminder and airbag light. Was this necessary? Do the dealers use something like this? Do any of you use something like this?
NickMangus is offline   Reply With Quote
Old 11-19-2007, 10:53 PM   #53
Super Moderator
 
drexappeal's Avatar
 
Join Date: Mar 2004
Location: West Los Angeles
Posts: 7,691
Drives: Midnight Blue 2004.5 C230 Kompressor Sport Sedan. 2002 w210 E320, 2009 w211 E350 Sport
Send a message via AIM to drexappeal
This has been added to the AFTERMARKET/DIY sticky for future reference.
drexappeal is offline   Reply With Quote
Old 11-25-2007, 12:29 PM   #54
MBWorld Fanatic!
 
benz_addict's Avatar
 
Join Date: Jan 2007
Location: Toronto
Posts: 1,934
Drives: V12TT
problem... this worked for me but I can't change the reminder to Service B... It said service B but I just did early oil change my self so when I reset it, it only goes to service A remind. How do I get the B reminder?
__________________
S600 V12TT - ECU/TCU remap, S65 AMG brake calipers, SL63 paddle shifters, S65 cluster, S65 exhaust tips, Brabus ABC ELM, CAT-LESS downpipes, 3" Full mandrel bent exhaust, custom rear apron, custom deep black suede headliner
CL55 AMG - 180mm pulley, 3" full header back exhaust EUROCHARGED BEAST!

Previous:
S500 4Matic- slammed on 19" Brabus wheels
CLS550
E430 4Matic
C230
benz_addict is online now   Reply With Quote
Old 11-25-2007, 01:46 PM   #55
Junior Member
 
Moon-Coupe's Avatar
 
Join Date: Jan 2007
Location: Northern CA
Posts: 49
Drives: '02 C230 Sport Coupe
Quote:
Originally Posted by benz_addict View Post
problem... this worked for me but I can't change the reminder to Service B... It said service B but I just did early oil change my self so when I reset it, it only goes to service A remind. How do I get the B reminder?
Just do it again.
Moon-Coupe is offline   Reply With Quote
Old 12-01-2007, 05:26 PM   #56
MBWorld Fanatic!
 
benz_addict's Avatar
 
Join Date: Jan 2007
Location: Toronto
Posts: 1,934
Drives: V12TT
doesn't work, I did it 30 times still shows service A

Can anyone guide me how to get the service B reminder?
__________________
S600 V12TT - ECU/TCU remap, S65 AMG brake calipers, SL63 paddle shifters, S65 cluster, S65 exhaust tips, Brabus ABC ELM, CAT-LESS downpipes, 3" Full mandrel bent exhaust, custom rear apron, custom deep black suede headliner
CL55 AMG - 180mm pulley, 3" full header back exhaust EUROCHARGED BEAST!

Previous:
S500 4Matic- slammed on 19" Brabus wheels
CLS550
E430 4Matic
C230
benz_addict is online now   Reply With Quote
Old 12-02-2007, 12:11 PM   #57
MBWorld Fanatic!
 
benz_addict's Avatar
 
Join Date: Jan 2007
Location: Toronto
Posts: 1,934
Drives: V12TT
bump
__________________
S600 V12TT - ECU/TCU remap, S65 AMG brake calipers, SL63 paddle shifters, S65 cluster, S65 exhaust tips, Brabus ABC ELM, CAT-LESS downpipes, 3" Full mandrel bent exhaust, custom rear apron, custom deep black suede headliner
CL55 AMG - 180mm pulley, 3" full header back exhaust EUROCHARGED BEAST!

Previous:
S500 4Matic- slammed on 19" Brabus wheels
CLS550
E430 4Matic
C230
benz_addict is online now   Reply With Quote
Old 12-03-2007, 05:08 PM   #58
Senior Member
 
Join Date: Jul 2003
Location: So Cal
Posts: 324
Drives: 2003 C230
Quote:
Originally Posted by wingless View Post
Ignition on, but not running.
Remaining miles to service displayed.
Press and hold the dash reset pushbutton.
This worked for my 03 C230K

ignition on, not running
Remaining miles to service displayed
Press and hold the dash reset pushbutton
(ask you do you want to reset)
Press and hold the dash reset pushbutton
DONE

Thank you.
__________________
2003 C230 Sedan, auto, cd, C2 Moonroof, C4 HID (6/18/03)
2010 Porsche Cayenne (5/14/10)
2011 E350 coupe, Designo, (12/29/12 bought used)
2013 VW Jetta TDI base (8/18/13)

SOLD - 2002 Acura MDX (7/1/02-5/10/10)
Taiwanese is offline   Reply With Quote
Old 12-03-2007, 08:23 PM   #59
Newbie
 
Join Date: Nov 2007
Posts: 10
Drives: 2003 C240
Send a message via AIM to NickMangus
hello

I purchased a simple device with a 38 PIN connector for resetting the service reminder and airbag light. Have any of you used one of these?
NickMangus is offline   Reply With Quote
Old 12-14-2007, 06:22 PM   #60
Newbie
 
Join Date: Dec 2007
Posts: 1
Drives: 2003 C240 4matic
Wink One More Thing

Quote:
Originally Posted by BIGjohnny View Post
Turn the key to on position (don't turn the engine on) and use your steering wheel buttons and click til you get A service or B service at XXXX miles. Then hold the reset button that is located on the instrument cluster, near the temperature gauge (should be on the left side). A note will appear and it'll inform you to hold the button again for another 3 seconds to reset the service mileage. Good luck.
It really works ( It works on mine 2003 C240 4MATIC) but the only thing is that the steering wheel buttons may not be working properly so you have to push it hard
At one point I think they didn't work but you have to push it hard.
also when you turn the key to on position you have to wait about 1 minute
Good Luck

Rickyc240 is offline   Reply With Quote
Old 04-07-2008, 03:19 AM   #61
MBWorld Fanatic!
 
C230 Sport Coup's Avatar
 
Join Date: Jun 2002
Location: Bay Area
Posts: 5,303
Drives: 2002 C230 & 2006 ML350
FSS Reset for 2005 +

Old thread, but noticed no one had posted the newer process.
Attached Files
File Type: pdf FSS reset 2005 +.pdf (110.6 KB, 1149 views)
__________________
2002 C230 Sport Coup
ASP Pulley-Supersprint Header-Remus Muffler-
TEIN SS Coilovers
AMG; Wheels, 22mm AMG Front sway bar, HR 19mm rear bar,
C32 Brakes
Tinted Windows- 2005 Tails, Grill & Blinkers-Clear Sides
Bi-Xenon Headlights!
Clear Fogs w/Philips Crystal Vision bulbs
Audio 10
Renntech style Spoiler
Supercharger Muffler Deleted!
"Aero Turbine" AR20 Rasp Eliminator (Resonator)
C230 Sport Coup is offline   Reply With Quote
Old 08-30-2008, 06:03 PM   #62
MBWorld Fanatic!
 
acr2001's Avatar
 
Join Date: Nov 2007
Location: NYC
Posts: 2,072
Drives: 2012 C300 4Matic
Quote:
Originally Posted by C230 Sport Coup View Post
Old thread, but noticed no one had posted the newer process.
Sorry to bring this thread back from the dead but its probably better than starting a new one.

I followed the directions in the PDF and it works great with one problem, when I get to the oil type menu it is set to "QF 1.0" and if I press the volume keys (or any others) they do not change that setting, the volume just changes... maybe my car only has one setting - "QF 1.0" ?

What is QF 1.0 ?

It's a 2005 C240 4-Matic
acr2001 is offline   Reply With Quote
Old 02-27-2009, 08:41 PM   #63
Junior Member
 
Join Date: Oct 2007
Posts: 34
Drives: 2007 C230
2007 C230 .. with 8,500 miles.

I also am having trouble right now with the Reset. I followed the directions in the PDF to a T and was able to remove the service B overdue message to service A in 13,000 miles. However, I started driving around and the 13,000 miles hasn't started ticking off. I have drove many miles and it keeps saying 13,000 miles. Additionally, I want it to say service B due again and not A. I tried repeating the steps to reset that I did in the first place and it keeps saying service A due in 13,000, not B. ANy ideas?
scottamc is offline   Reply With Quote
Old 08-14-2009, 05:40 AM   #64
Member
 
walee112's Avatar
 
Join Date: Jul 2009
Location: Bay Area
Posts: 129
Drives: 2005 C55
does this work for a 2005 C55?
__________________

'05 C55
walee112 is offline   Reply With Quote
Old 10-04-2009, 10:53 AM   #65
Newbie
 
Join Date: Oct 2009
Posts: 2
Drives: c320 wagon
I just reset my service display as described in several threads and now the engine will not start anymore, not even crank. All lights etc. still work. (2003 C320 wagon). Any ideas what happened or what I can do?
flodur is offline   Reply With Quote
Old 10-04-2009, 01:13 PM   #66
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 4,315
Drives: THE E320 Bluetec and THE C320
samaritrey
Quote:
Originally Posted by flodur View Post
I just reset my service display as described in several threads and now the engine will not start anymore, not even crank. All lights etc. still work. (2003 C320 wagon). Any ideas what happened or what I can do?
i guarantee you that resetting the service display had nothing to do with your car not starting. ok first off any error in the display? how old is your battery? have you ever replaced your cps? how many miles on the car? did you do anything else besides reset the service thing?
__________________
Trey's Car History
87 Suzuki Samurai Gone :(
99 KIA Sportage 2Door Sold July 20 2009
97 J30 given when 16 Has been passed down to sibling
01 C320 Got at 16 as of 9-10-13 has 200,500 miles with Eurocharged Tune, AMG Style Trunk Spoiler, BIX, NAV 2.0, Tein Springs with Front Renntech Shocks and Koni's in the Rear
08 E320 Bluetec Purchased 04-28-14

All About Trey and Cars Thread
Trey's 2008 E320 Bluetec


samaritrey is offline   Reply With Quote
Old 10-04-2009, 03:45 PM   #67
Newbie
 
Join Date: Oct 2009
Posts: 2
Drives: c320 wagon
I assume it is still the first battery. I bought the car in 2005 and have not replaced the battery. I have never replaced the cps either. The car has about 78k miles on it. After I covered the problem this morning I waited about an hour and tried to start it again. The engine cranked twice slowly but did not start. Now I thought it may be the battery and I connected a battery charger. When I tried to start the engine 1p minutes later it stared right away. So it seems to be the battery. The strange thing is (and that is why I did not think of the battery in the first place) I drove the car a short distance about 10 minutes before I did the display reset. And 10 minutes later it would not crank/start.
Thanks for your help anyway.
Final question: how often do you need to replace the cps?
flodur is offline   Reply With Quote
Old 10-04-2009, 04:21 PM   #68
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 4,315
Drives: THE E320 Bluetec and THE C320
samaritrey
Quote:
Originally Posted by flodur View Post
I assume it is still the first battery. I bought the car in 2005 and have not replaced the battery. I have never replaced the cps either. The car has about 78k miles on it. After I covered the problem this morning I waited about an hour and tried to start it again. The engine cranked twice slowly but did not start. Now I thought it may be the battery and I connected a battery charger. When I tried to start the engine 1p minutes later it stared right away. So it seems to be the battery. The strange thing is (and that is why I did not think of the battery in the first place) I drove the car a short distance about 10 minutes before I did the display reset. And 10 minutes later it would not crank/start.
Thanks for your help anyway.
Final question: how often do you need to replace the cps?
ok read this before you replace the battery http://www.mbworld.org/forums/c-clas...g-battery.html. i don't want to see you on here tomorrow with a blown sam. lol second i would replace with Mercedes battery because they last forever lol. alot of member on here have called roadside assistance and they will put the new battery in for the cost of the battery. you have to live near a dealer i guess though and i think not be able to start your car. but i don't really know if that is true or not. i would recommend that because if they mb guy blows the sam it is not your problem and the early Mercedes seem to love to do it. as for the cps i have no clue but if it hasn't been replaced yet i would order one online for like $50 and do it now so that you don't have the problems so many others have had. i think it was C230 Sport Coup that found the really cheap place to get it. i will be ordering one very soon for my c320 because it has 136,500 miles and it was done at about 85k last. hope this helps
__________________
Trey's Car History
87 Suzuki Samurai Gone :(
99 KIA Sportage 2Door Sold July 20 2009
97 J30 given when 16 Has been passed down to sibling
01 C320 Got at 16 as of 9-10-13 has 200,500 miles with Eurocharged Tune, AMG Style Trunk Spoiler, BIX, NAV 2.0, Tein Springs with Front Renntech Shocks and Koni's in the Rear
08 E320 Bluetec Purchased 04-28-14

All About Trey and Cars Thread
Trey's 2008 E320 Bluetec


samaritrey is offline   Reply With Quote
Old 10-22-2009, 09:51 AM   #69
Newbie
 
Join Date: Oct 2009
Posts: 1
Drives: 2008 ML 350
Need instructions for reseting service indicator light for 2008 ML 350.
Big "D"
tolar7177 is offline   Reply With Quote
Old 10-22-2009, 02:47 PM   #70
Super Moderator
 
drexappeal's Avatar
 
Join Date: Mar 2004
Location: West Los Angeles
Posts: 7,691
Drives: Midnight Blue 2004.5 C230 Kompressor Sport Sedan. 2002 w210 E320, 2009 w211 E350 Sport
Send a message via AIM to drexappeal
Quote:
Originally Posted by tolar7177 View Post
Need instructions for reseting service indicator light for 2008 ML 350.
Big "D"
Wrong forum. Pose your question in the ML forum. This forum is for w203 models (2001-2007).
drexappeal is offline   Reply With Quote
Old 10-23-2009, 10:15 PM   #71
Junior Member
 
Join Date: Apr 2005
Location: S. CA
Posts: 40
Drives: '05 C320
Quote:
Originally Posted by flodur View Post
Final question: how often do you need to replace the cps?
What is cps? Is it an acronym for a certain part?
__________________
'05 C320
'04 Porsche Cayenne Turbo
DUC916 is offline   Reply With Quote
Old 10-24-2009, 01:51 AM   #72
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 4,315
Drives: THE E320 Bluetec and THE C320
samaritrey
crank position sensor
__________________
Trey's Car History
87 Suzuki Samurai Gone :(
99 KIA Sportage 2Door Sold July 20 2009
97 J30 given when 16 Has been passed down to sibling
01 C320 Got at 16 as of 9-10-13 has 200,500 miles with Eurocharged Tune, AMG Style Trunk Spoiler, BIX, NAV 2.0, Tein Springs with Front Renntech Shocks and Koni's in the Rear
08 E320 Bluetec Purchased 04-28-14

All About Trey and Cars Thread
Trey's 2008 E320 Bluetec


samaritrey is offline   Reply With Quote
Old 08-04-2010, 02:53 PM   #73
Newbie
 
Join Date: Feb 2010
Posts: 4
Drives: 02 mb c240
1. Ignition key in position 2.
2. Use the page button to select odometer readout in cluster.
3. Use the scroll button to display FSS indicator.
4. Press 'R' button on cluster for approximately 2 seconds.
5. Display in cluster will advise "to reset service reminder - press 'R' button for approx. 3 seconds.
6. Press 'R' button on cluster for approximately 3 seconds.
7. Service reminder is reset.


This worked for me.....2002 C240 base sedan....I do my own stuff. I was like 10,000 on it...saying overdue but I had done it twice lol...now I know how.. thanks
jamesdeanvegas is offline   Reply With Quote
Old 08-04-2010, 03:44 PM   #74
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,267
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
http://www.mbworld.org/forums/c-clas...st-models.html
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 09-23-2011, 05:48 PM   #75
Super Member
 
Join Date: Jun 2008
Location: Las Vegas, NV
Posts: 924
Drives: I drive a Toyota Hybrid...
thanks!! works for me
__________________
kirax2 is offline   Reply With Quote
Old 09-23-2011, 05:48 PM
 
 
 
Reply

Tags
1998, 2001, 2005, by, c240, c320, e320, exceeded, fss, light, mbworld, mecedes, overdue, reset, service



Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 09:53 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details