Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
Sign in using an external account
Register Forgot Password?


C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 06-02-2011, 01:22 PM   #1
Newbie
 
Join Date: Jun 2011
Posts: 4
Drives: 2003 c230
2003 c230 Remote Key Fob Malfunction: No Lock or Unlock

I really need your feedback!

I have 2003 c230 coupe. The two keys do not work to lock or unlock the car though they can start the engine. I took the car to the dealer and after testing several things (including replacing the old batteries), they said I needed a new key, so I ordered one. It can start the engine but it still can't lock or unlock the car. In this case, should I reprogram or reset the new key? Or, what DIY ways are available before taking this to the dealer? It is very frustrating so I really appreciate your constructive feedback!
To remove this ad, register today or login if you already are registered!

unomaha is offline   Reply With Quote
Old 06-02-2011, 03:26 PM   #2
Out Of Control!!
 
e1000's Avatar
 
Join Date: Nov 2005
Location: OC
Posts: 18,683
Drives: a quarter mile at a time
Did you recently get your car tinted? It could be the RF reciever in the car that's malfunctioning.
__________________
e1000 is offline   Reply With Quote
Old 06-02-2011, 03:28 PM   #3
Newbie
 
Join Date: Jun 2011
Posts: 4
Drives: 2003 c230
Quote:
Originally Posted by e1000 View Post
Did you recently get your car tinted? It could be the RF reciever in the car that's malfunctioning.
Yes, I had windows tinted. Is it because of that? In this case, what should I do? I appreciate your reply!
unomaha is offline   Reply With Quote
Old 06-02-2011, 05:14 PM   #4
Out Of Control!!
 
e1000's Avatar
 
Join Date: Nov 2005
Location: OC
Posts: 18,683
Drives: a quarter mile at a time
http://www.mbworld.org/forums/c-clas...e-mystery.html
__________________
e1000 is offline   Reply With Quote
Old 06-02-2011, 07:15 PM   #5
Newbie
 
Join Date: Jun 2011
Posts: 4
Drives: 2003 c230
Quote:
Originally Posted by e1000 View Post

Many thanks! That link is very helpful. My radio does not receive the signal well after window tinting. I guess the window tinting guys used metallic film. I will go stop by the shop. Thanks again!
unomaha is offline   Reply With Quote
Old 06-02-2011, 07:59 PM   #6
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,306
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Again! - this comes up too often. These tinting guys really should know better with modern vehicles.
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 04-30-2014, 02:12 PM   #7
Newbie
 
Join Date: Nov 2003
Posts: 14
Post C230 W203 Key Remote stopped working

I swapped out the batteries, ignition starts, but cannot open lock doors using the key remote. Any ideas? Had tint for 10 years, so not tint.

What fuses should I check? There are a lot!

Thanks!
gallaghp2 is offline   Reply With Quote
Old 05-01-2014, 11:06 AM   #8
Newbie
 
Join Date: Nov 2003
Posts: 14
Thumbs down RE: Key fob not working for C230 K

Well it looks like it is the key fob that is the issue. With new batteries it didn't work any better. I switched to my spare key which is kind of beat up (plastic messed up) and the key fob works much better by opening and locking the doors remotely.

It still has the occasional glitch when I place in the ignition and the engine does not fire, so I have to turn the key to the left, start over and turn to the right again.

I guess I need a replacement key for the faulty one - since you can't reprogram the key yourself. The manual indicates if it stops working, just insert in the igintion and turn and the key resyncs...
gallaghp2 is offline   Reply With Quote
Old 05-01-2014, 12:28 PM   #9
MBWorld Fanatic!
 
tommy's Avatar
 
Join Date: Nov 2001
Location: Westwood, NJ
Posts: 9,650
Drives: 2002 C230
If you do end up having to buy a new key, try several local dealerships; prices are all over the place.
__________________
2002 Ccoupe, smurfalicious: OE chipped, RennTech pullied & rear spoiler, Carlsson lip, 18" OZ ultraleggera rims, RogueEngineering stud conversion, Eibach Pro springs/Koni Sport struts, Eibach swaybars, Supersprint headers, Eisenmann race exhaust, Magnaflow cat, Classic Soft Trim interior w/driver's Recaro Sport seat, clear OEM projector headlights, Sparco Racing shiftknob, Lightning Autosports alcantara shiftboot w/ Simoni gated shift surround
tommy is online now   Reply With Quote
Old 08-18-2014, 11:11 PM   #10
Junior Member
 
Join Date: Aug 2014
Posts: 25
Drives: 2002 C230 Coupe
I have a similar issue -- just bought the car and the remote does not operate the locks. Put a new battery into the remote, now the little light flashes on the remote but still no luck with the locks. Have driven the car a few times with the new battery in the key, shouldn't that be enough to initialize the key if needed?
Also noticed the light over the back seat is inoperative.
Tech told me the remote unlock receiver is near the back of the roof -- are the light and remote locking receiver fed by one wire harness, whose connector might have been missed during repairs? Noted the rear seat fold up cushions are installed incorrectly, so some semi-tech was into something back there...
KSKarl is offline   Reply With Quote
Old 08-19-2014, 10:43 AM   #11
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,306
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Lock unlock issue Help!
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 08-20-2014, 09:55 PM   #12
Junior Member
 
Join Date: Aug 2014
Posts: 25
Drives: 2002 C230 Coupe
Another win for the board...
The table of fuses you sent listed 6 affecting the locking system--three of those were missing, just empty slots. Plugged in fuses and all is working as advertised. That was easy, thanks
KSKarl is offline   Reply With Quote
Old 08-20-2014, 10:27 PM   #13
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,306
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Huh! That's great. Pleased it's fixed.
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 08-21-2014, 12:42 AM   #14
VVF
Super Member
 
VVF's Avatar
 
Join Date: Sep 2011
Location: CS, TX
Posts: 920
Drives: 2005 C230K Sport Sedan
I'd watch for the battery drain... Someone may have removed them for a reason
VVF is online now   Reply With Quote
Old 08-21-2014, 12:42 AM
 
 
 
Reply

Tags
2003, batteries, battery, benz, c230, changing, class, coupe, fob, key, keys, mercedes, remote, replacing, reset



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 05:36 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details