Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
Sign in using an external account
Register Forgot Password?


C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 01-20-2012, 07:11 PM   #1
Newbie
 
Join Date: Jan 2012
Posts: 4
Drives: c230
Radio reception and Keyless entry not working 2005 c230kompressor hatchback

Hi guys, I recently joined this forum since my gf purchased a 2005 c230kompressor coupe hatchback not too long ago.

Im hoping you guys can help me out with a problem which I have been scouring the forums and web in hopes of solving.Ive been getting more info and closer to a prognosis but am open to any additional help anyone can provide.

Recently my gf's car went in for tinting. I will first say that the tint is a non metallic based tint by Formula 1. What Im thinking is that the process of the install (whether it be moisture from applying the film or just simply disturbing the wires within the headliner or c-pillar where the antenna is) damaged the reception and keyless entry capabilities (since they are linked)? Ive read many threads but there seems to be limited info to pinpointing the actual problem.

My question is, since there seems to be several parts to the antenna in the rear windshield, is it possible to diagnose which component of the several is damaged? There seems to be about two main antennas and perhaps 1 or 2 connectors that are subject to damage.... I just need to narrow it down to which one?

I realize that I should check the fuse (which I did in the trunk) and several other common things to consider first before diving deeper into the problem. At this point I'm stuck since electronics are tricky.

Im hoping some of you have info on the fix since it seems to be a problem several people have experienced?

I appreciate any of your help and if people would prefer to private message me please do. Thanks again.
To remove this ad, register today or login if you already are registered!

Dinan is offline   Reply With Quote
Old 01-21-2012, 07:45 AM   #2
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,443
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
See post number 45

http://mbworld.org/forums/c-class-w2...ock-coupe.html
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 01-21-2012, 12:24 PM   #3
Newbie
 
Join Date: Jan 2012
Posts: 4
Drives: c230
Thanks alot Glyn M Ruck,
The thing with the coupe though is Im not sure based on that description which antenna it is. according to some schematics on the web, it seems to indicate that there are 2 antennas (both of which cost several hundred of dollars each) where one is mounted along the top of the rear windshield and the other somewhere in the c-pillar on the driver side. Both seem to be accessible by moisture in the tinting process since the rear film seems to go to all corners of the rear windshield compromising both those areas. Do you suspect which one is more likely the culprit and is there any electronics test to test which amplifier is not working..... the problem im just tackling is that id hate to replace one and it be the other if you know what I mean.

Thanks again for your help.... that thread did improve my understanding but im still trying to figure which antenna it is.
Dinan is offline   Reply With Quote
Old 01-21-2012, 04:09 PM   #4
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,443
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
You are confusing Coupe with Sedan antenna amplifiers? The antenna itself is in the glass of the rear window. The sedan has the amplifier behind the LHS rear C pillar cover.
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 01-21-2012, 09:06 PM   #5
Newbie
 
Join Date: Jan 2012
Posts: 4
Drives: c230
Quote:
Originally Posted by Glyn M Ruck View Post
You are confusing Coupe with Sedan antenna amplifiers? The antenna itself is in the glass of the rear window. The sedan has the amplifier behind the LHS rear C pillar cover.
I realize there is an antenna that spans the upper part of the rear windshield but are there not 2ndary antennas that run from those ones in the rear windshield and down the c-pillar as well?

Are you saying that is the only amplifier antenna on that car?
Thanks again
Dinan is offline   Reply With Quote
Old 01-22-2012, 07:16 AM   #6
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,443
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Yes - there is only one RF antenna amp - you need to find out which one because they have been updated a couple of times. If the amp is blown then make sure you take your VIN to the dealer so that they can get the correct replacement.
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 01-22-2012, 07:19 AM   #7
MBWorld Fanatic!
 
Join Date: Jul 2005
Location: Sydney, Australia
Posts: 3,221
Drives: W203 slightly modified
Send a message via MSN to benzmodz Send a message via Skype™ to benzmodz
Quote:
Originally Posted by Dinan View Post
I realize there is an antenna that spans the upper part of the rear windshield but are there not 2ndary antennas that run from those ones in the rear windshield and down the c-pillar as well?

Are you saying that is the only amplifier antenna on that car?
Thanks again
The sedan has a strip across the rear window at the top. The coupe may have an additional amplifier which the sedan does not have.
__________________
Modify your car and enjoy the benefits !
benzmodz is offline   Reply With Quote
Old 01-22-2012, 08:55 AM   #8
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,443
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
EPC does not show 2 amps mounted at the same time. But hey - who knows
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 01-22-2012, 12:16 PM   #9
Newbie
 
Join Date: Jan 2012
Posts: 4
Drives: c230
Quote:
Originally Posted by Glyn M Ruck View Post
EPC does not show 2 amps mounted at the same time. But hey - who knows
Hmmmm.... so the coupe may have several rf amps> Glyn... do you have a website on parts where I can punch in a mercedes oem vin and then it returns a database on every part for that car?

Thanks guys for your help.
Dinan is offline   Reply With Quote
Old 01-22-2012, 05:28 PM   #10
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,443
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
I have no access to such sites.

I don't believe it has 2 amps. I fail to see how they would work. The sedan definitely has one amp. I believe the Coupe will be the same for standard RF. i.e. Radio & Key.
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 01-22-2012, 05:28 PM
 
 
 
Reply

Tags
amplifier, antenna, c320, car, disconnect, entry, formula, key, keyless, mercedes, problem, remote, sedan, tint, unlocking, w203, window



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 01:03 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details