Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
Sign in using an external account
Register Forgot Password?


C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 05-03-2012, 08:54 PM   #1
Newbie
 
Join Date: May 2012
Posts: 3
Drives: Mercedes C230 K
2003 C230 Kompressor Coupe ABS, BAS ESP Malfunction Message

New to the forum . Just bought a 2003 C230 Kompressor Coupe . Although the car has only 50,000 kilometers I am experiencing problems with fault messages appearing on screen indicating ABS , BAS and ESP malfunction. I have taken it to dealer who changed RR wheel speed sensor and cleaned up contacts at a cost of $800.00 , thankfully at the previous owners expense.
After one week the same messages have re appeared the dealer has agreed to replace the sensor again if it is defective. I have read that the brake light switch may be the cause but lights work fine. Any suggestions on how to resolve. The car is in otherwise pristine condition but I am concerned this might be a money pit with all the electronics . I have a 1983 300 Turbo diesel which has been extremely reliable therefore my expectations may be a bit high. I assume the car could be driven safely with the knowledge that the ABS , traction control is not functional.

Thanks
To remove this ad, register today or login if you already are registered!

Duke1959 is offline   Reply With Quote
Old 05-04-2012, 10:04 AM   #2
MBWorld Fanatic!
 
Join Date: Jul 2008
Posts: 6,387
Drives: 2009 E350 Sport
It could be driven, sure. I wouldn't.. not just because I like the safety net, but also because I cannot STAND a warning on the dash. It drives me nuts.

If the car has been barely and gently driven, I'd be more concerned with the M271 engine. The 2003s are notorious for head problems. The brake switch can be malfunctioning and the lights still work, so don't discredit that.
LILBENZ230 is offline   Reply With Quote
Old 05-04-2012, 10:16 AM   #3
Newbie
 
Join Date: May 2012
Posts: 3
Drives: Mercedes C230 K
Thanks for the info... the only previous owner was a 55 yr old school teacher who drove it less than 15 KMs per day so I hope my problems remain electronic in nature . Do you if these a cars are prone to rust ?
Duke1959 is offline   Reply With Quote
Old 05-04-2012, 10:37 AM   #4
MBWorld Fanatic!
 
Join Date: Jul 2008
Posts: 6,387
Drives: 2009 E350 Sport
Quote:
Originally Posted by Duke1959 View Post
Thanks for the info... the only previous owner was a 55 yr old school teacher who drove it less than 15 KMs per day so I hope my problems remain electronic in nature . Do you if these a cars are prone to rust ?
Oh fail. That type of driving, short trips and by someone who was gentle all the time is the worst possible thing for the engine in your car. We recommend people not buy these type examples. I suggest you promptly start ringing it out. Add some techron in the fuel, as well.

The 2003s will rust, yes.
LILBENZ230 is offline   Reply With Quote
Old 05-04-2012, 11:25 AM   #5
Super Member
 
Join Date: May 2009
Location: Toronto, Ontario, Canada, eh!
Posts: 779
Drives: 2003 C230 Sports Coupe, Paprika Metallic Red, Auto, Pano, Leather
Yes, these cars need to be driven on the highway once in a while.

Rust on 2003,.... Actually it depends,... so I would say its more of a "yes and no" answer. Check your production date on data card.

For 2003 models, they used galvanized steel panels from Second Quarter 2003 onward. The galvanized steel panels were gradually introduced during the previous 2 quarters (First quarter 2003 and last quarter of 2002), thus cars made in those time periods are hit and miss.

Anyways, if you drive in snow-belt area, wash the car once a week especially in the winter and make sure to spray rust prone areas like the lips of the wheel well where water absorbing dirt accumulate.

My 2003 coupe doesn't have any rust except for one (stainless-steel?) bolt holding down the battery tray,... it seems that there was a drainage problem there before.
SunnyRayToronto is offline   Reply With Quote
Old 05-04-2012, 04:12 PM   #6
Newbie
 
Join Date: May 2012
Posts: 3
Drives: Mercedes C230 K
Why would driving the car gently be a problem ? The previous owner did use premium fuel .I realize short trips are hard on a car but the upside is the car has only 55 K Kms and body is spotless and I hope I got it for a good price .... $8,200 which included winter tires mounted on Mercedes alloy rims and Mercedes dealer inspection. I annually rust proof my cars and wash them weekly so I hope to keep the car rust free for another 10yrs.
Duke1959 is offline   Reply With Quote
Old 05-04-2012, 04:55 PM   #7
Super Member
 
Join Date: May 2009
Location: Toronto, Ontario, Canada, eh!
Posts: 779
Drives: 2003 C230 Sports Coupe, Paprika Metallic Red, Auto, Pano, Leather
These car require premium fuel.

Driving the car gently is NOT the problem. Driving it mainly on short little slow trips like a little old lady going to Sunday service at church would be a problem. The engine needs to warm up and go fast once in a while to burn off all the crap that accumulate in the engine. We're NOT saying drive like an idiot doing burn-outs and drifting,.... just warm up the engine and take it out on the highway.

There are different school of thoughts here,..... Annual chemical rust-proofing may or may not do any good, since the car already comes with a "wax" to counter rust from the factory,.... and Mercedes-Benz actually advise against chemical rust-proofing since it can damage their anti-rust protectant wax. Whether your car has galvanized steel or not, I think washing it once a week and giving it the occassional thorough water spraying to get rid of road salt will suffice to prevent rust. My personal opinion is that chemical rust proofing would be a waste of money and its bad for the environment.

Last edited by SunnyRayToronto; 05-04-2012 at 05:03 PM.
SunnyRayToronto is offline   Reply With Quote
Old 05-05-2012, 11:48 PM   #8
Super Member
 
Join Date: May 2009
Location: Atlanta, GA
Posts: 819
Drives: '02 C230 Coupe (Me) '03 SLK320 6MT (Wife)
Sounds like the brake switch on the car. Common until the changed the design or something. I wrote up changing mine. I will post a link when I can, you can see if the symptoms match what you are seeing.
MW_ATL is offline   Reply With Quote
Old 05-06-2012, 04:52 PM   #9
Super Member
 
Join Date: May 2009
Location: Atlanta, GA
Posts: 819
Drives: '02 C230 Coupe (Me) '03 SLK320 6MT (Wife)
Ok, check the symptoms I had and see if they are similar. If so, the fix is a twenty-some-odd dollar part and a bit of time. Help - Brake Assist Visit Workshop! BAS

I am not exactly sure when they stopped using the switch, but if yours has one listed for it, that could well be the problem. If it is the brake light switch, the lights will continue working fine - or at least mine did.
MW_ATL is offline   Reply With Quote
Old 05-06-2012, 05:17 PM   #10
Newbie
 
Join Date: Aug 2011
Posts: 10
Drives: C230 Coupe
Hi All,

I own an C230 Kompressor Coupe with 95k miles on it. I live in SF Bay Area. Yesterday I was driving at 10-20 MPH reaching my home. All of a sudden I lost control on the steering and ESP Not Available message came up. I slowed down and parked the car. I restarted and tried to move. The car went ahead straight and I wasn't able to turn the wheels at all. The steering rotates 360 Degrees as if something is broken inside. I stopped and started again. No change. Steering wheels rotates completely without any effect on the wheels. I should say providence saved me and my family. Just in the morning I was driving at 70MPH on I-880 with loads of traffic. I was just thinking if this happened on a freeway what would have happened. I am not able to steer the car at all. I towed it to an Indy shop @ $150 thanks to friendly MB Roadside (complimentary towing is only to a dealer). Any ideas folks? What is broken? What does a freely turning steering wheel mean? ESP Not Available at the same time?

Also, recently changed Poly-V belt, new battery, transmission flush. I feel a diesel truck like noise when it is idling especially inside the cabin with the doors closed and windows rolled-up. I am not sure what is happening. Does it need timing chain replacement? I am close to saying I am frustrated with my car . When I start in the morning it takes about 1-2 Mins to warm-up. Starts at 1100 RPM and comes down to 600 RPM in that time.

Last edited by harshaiit; 05-06-2012 at 05:34 PM. Reason: adding more details
harshaiit is offline   Reply With Quote
Old 05-06-2012, 10:26 PM   #11
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 4,420
Drives: THE E320 Bluetec and THE C320
samaritrey
I guess your steering shaft broke or something came off all of which I have never heard of happening on here.
__________________
Trey's Car History
87 Suzuki Samurai Gone :(
99 KIA Sportage 2Door Sold July 20 2009
97 J30 given when 16 Has been passed down to sibling
01 C320 Got at 16 as of 9-10-13 has 200,500 miles with Eurocharged Tune, AMG Style Trunk Spoiler, BIX, NAV 2.0, Tein Springs with Front Renntech Shocks and Koni's in the Rear
08 E320 Bluetec Purchased 04-28-14

All About Trey and Cars Thread
Trey's 2008 E320 Bluetec


samaritrey is offline   Reply With Quote
Old 05-06-2012, 10:53 PM   #12
Newbie
 
Join Date: Aug 2011
Posts: 10
Drives: C230 Coupe
Hi Samaritrey,

Is it possible to steer the car after ESP Not Available message comes up? I read somewhere that it is possible to switch off ESP and drive the car but cautiously. I am waiting for tomorrow morning....car is at an Indy shop...I hope it is not serious.
harshaiit is offline   Reply With Quote
Old 05-06-2012, 11:43 PM   #13
Newbie
 
Join Date: May 2012
Posts: 10
Drives: audi
The previous owner did use premium fuel .
__________________
GarfieldKoe is offline   Reply With Quote
Old 05-07-2012, 03:56 AM   #14
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 4,420
Drives: THE E320 Bluetec and THE C320
samaritrey
Quote:
Originally Posted by harshaiit View Post
Hi Samaritrey,

Is it possible to steer the car after ESP Not Available message comes up? I read somewhere that it is possible to switch off ESP and drive the car but cautiously. I am waiting for tomorrow morning....car is at an Indy shop...I hope it is not serious.
esp and being able to steer are two separate things. even if the cars electronics all fail you can still steer the car just might get harder if the PS pump is out. You can drive the car with no ESP but be careful since if it is down you never know when it might decide to kick in and could cause an accident if it were to go really bad. Remember it can brake each wheel individually and could if malfunctioning put you in a bad place. I had a similar issue and it ended up being a bad abs/esp control modular. Some water had gotten in the connecter and corroded the crap out of it. My car would be fine one day and the next say abs/esp/bas visit work shop. I have a star system and it said that the Brake light switch had errors so I replaced it twice and found no change. Then it got worse to where the car was stuck in 1st gear no brake lights and it happened so fast it could have killed me if I had been on a big road. Luckily I was 1/2 a mile from home so limped it home. I did some more work with star and it said 40% chance I had a bad modular. The problem is that from the dealer it cost over 1K. So then I found the corrosion and figured what the hell find a used one. So the hunt began sadly the 01's used a different modular then some 02 and 03 on so I had to find a wrecked 01 with hopefully low miles for a decent price. I found one in the whole usa and paid $450 for it. That same day a wrecked 01 c320 showed up at a place in Washington state. I called as they were listing each part on the web site and got it for 200 Shipped best day of my life (ok maybe not but close) so heck you might want to check for corrosion at the very least there was a TSB put out about it. Here is my post
All About Trey and Cars (Also have parts for sale!!)
__________________
Trey's Car History
87 Suzuki Samurai Gone :(
99 KIA Sportage 2Door Sold July 20 2009
97 J30 given when 16 Has been passed down to sibling
01 C320 Got at 16 as of 9-10-13 has 200,500 miles with Eurocharged Tune, AMG Style Trunk Spoiler, BIX, NAV 2.0, Tein Springs with Front Renntech Shocks and Koni's in the Rear
08 E320 Bluetec Purchased 04-28-14

All About Trey and Cars Thread
Trey's 2008 E320 Bluetec


samaritrey is offline   Reply With Quote
Old 05-07-2012, 03:18 PM   #15
Newbie
 
Join Date: Aug 2011
Posts: 10
Drives: C230 Coupe
Ok guys....went to the indy shop today morning....car was ready to go ....
Problem: A bolt in the steering shaft came loose and fell in the lower tray that protects the engine
Fix: Mechanic just took the bolt and tightened it
Reason: A lazy mechanic at the dealership may have absent-mindedly left the bolt after a repair to the steering column...I think the previous owner did some steering related repair......that almost cost my life. Per mechanic this is the first time in his 35 yrs with MBZ he has seen such a thing happen....happened to his neighbor's car (some Jap brand)...
Anyways totally a mechanical failure...some moron may be smoking pot on job....I can't even hold someone responsbile as there is no evidence (except bills) that this thing happened....
Cost: $20 if it was a new bolt per mechanic...labor extra...i guess a 5 min job...
Now that it has gone to the mechanic I asked him to change the spark plugs, Cam Solenoids and check for any other life-threatening things ...I am just thanking god to have kept me alive....BTW I still love my car

Add Towing: $150

Total: ~$400?

Took a rental car for few days...brand new Cruze with 30 Miles on it...but it doesn't feel like a Benz

So satisfaction of driving a Merc: Priceless

Anyways thanks all for your replies...I will post the exact details of which bolt came off once I see the invoice

Harsha

Last edited by harshaiit; 05-07-2012 at 03:26 PM. Reason: na
harshaiit is offline   Reply With Quote
Old 05-07-2012, 04:56 PM   #16
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 18,453
Drives: late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
See my reply to your PM - Looks like I was correct!
__________________

Llandudno, Cape Town, South Africa
Glyn M Ruck is offline   Reply With Quote
Old 05-07-2012, 09:06 PM   #17
Newbie
 
Join Date: Aug 2011
Posts: 10
Drives: C230 Coupe
Hi Glyn,

Yes, you were spot on. Got your PM..Thanks for the reply btw.....I got the car fixed...I guess this is what they call as the black swan event....rarest of the rare? but with a huge potential
harshaiit is offline   Reply With Quote
Old 05-07-2012, 09:30 PM   #18
Newbie
 
Join Date: Aug 2008
Posts: 9
Drives: C230 Kompressor
Love the 'priceless' comment... I feel the same way.
My 2002 C230 Kompressor Coupe has less than 80K (km) and looks mint. I never drove it in winter time, although the original owner did (I bought it off lease) and there's no rust on it. Looks better that my 2008 Pontiac I just ot rid of.
It almost looks like this car should look great in another 10 years, of course, with a bit of TLC.
somedude is offline   Reply With Quote
Old 05-08-2012, 12:49 AM   #19
MBWorld Fanatic!
 
C230 Sport Coup's Avatar
 
Join Date: Jun 2002
Location: Bay Area
Posts: 5,358
Drives: My massive brain cannot compare to Glyn's !
Quote:
Originally Posted by harshaiit View Post
Ok guys....went to the indy shop today morning....car was ready to go ....
Problem: A bolt in the steering shaft came loose and fell in the lower tray that protects the engine
Fix: Mechanic just took the bolt and tightened it
Harsha
Thats what I was going to say.
I've had that bolt out once to replace the starter.
I made a nice little video of it...
__________________
2002 C230 Sport Coup
and 2006 ML350
ASP Pulley-Supersprint Header-Remus Muffler-
TEIN SS Coilovers
22mm AMG Front sway bar, HR 19mm rear bar,
C32 Brakes
Tinted Windows- 2005 Tails, Grill & Blinkers-Clear Sides
Bi-Xenon Headlights!
Clear Fogs w/Philips Crystal Vision bulbs
Audio 10
Renntech style Spoiler
Supercharger Muffler Deleted!
"Aero Turbine" AR20 Rasp Eliminator (Resonator)
C230 Sport Coup is offline   Reply With Quote
Old 05-08-2012, 03:51 AM   #20
Newbie
 
Join Date: May 2012
Posts: 9
Drives: aodi
these cars need to be driven on the highway once in a while
__________________
FriedaTakaha is offline   Reply With Quote
Old 05-09-2012, 02:33 AM   #21
Newbie
 
Join Date: Aug 2011
Posts: 10
Drives: C230 Coupe
Looks interesting

Quote:
Originally Posted by C230 Sport Coup View Post
Thats what I was going to say.
I've had that bolt out once to replace the starter.
I made a nice little video of it...
http://www.youtube.com/watch?v=l2cXPxsB8PY
Hey There,

I guess the mechanic at the dealer forgot to put that bolt back together....Am going to get the car tomorrow...asked the indy shop mechanic to do all possible tests for the last two days..he sayz its all looking good...taking the car to LV in two weeks...let us see how things hold-up
harshaiit is offline   Reply With Quote
Old 05-10-2012, 12:33 PM   #22
Newbie
 
Join Date: Aug 2011
Posts: 10
Drives: C230 Coupe
Ok guys here you go....the details from the invoice....

1) Steering shaft found disconnected from steering rack....job done - connect them back and secured lock bolt with lock-tie...steering angle reset, ESP erased, testing etc...

2) Cam solenoids replaced
3) spark plugs changed

car feels good now....btw got an email from MBZ USA about a customer satisfaction survey....wonder what I should be satisfied about? the product? or the towing?

anyways thanks all of you guys...btw total bill came to less than $350 at the indy shop...
harshaiit is offline   Reply With Quote
Old 05-10-2012, 12:33 PM
 
 
 
Reply

Tags
03, 2003, c230, compressor, coupe, esp, kompressor, light, lmessage, malfunction, model, problems, spin, tire, w203



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 07:05 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details
You Rated this Thread: 5