Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
Sign in using an external account
Register Forgot Password?

C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 08-14-2006, 12:55 PM   #51
Member
 
Join Date: May 2006
Location: Vancouver, BC
Posts: 77
Drives: 2002 C240
I had the same problem on my 02 C240 about 2 months ago. I tried to reset with the sunroof myself with the overhead switch. No luck, so I took it to the dealer and asked them. Service advisor came out to my car, opened and closed it a few times (2 inches at a time). Then he held the button in the pop-up position for about 10 seconds, then to the closed position. Then he pulled back on the switch for the side open function. Worked fine after that. I told him that I that I did the same thing, only I held the button in the pop-up position for about 3 seconds. Best of all, there was no charge for the fix.
Good luck, hope this works for you.
To remove this ad, register today or login if you already are registered!

1st lite is offline   Reply With Quote
Old 08-14-2006, 01:39 PM   #52
Junior Member
 
Join Date: Aug 2006
Location: Seattle, WA
Posts: 24
Drives: 2001 C320
1st lite - Thanks for the suggestion. What do you mean by "side open function?" Do you just mean opening it all the way back?
csaunder is offline   Reply With Quote
Old 08-14-2006, 02:07 PM   #53
Member
 
Join Date: Aug 2006
Location: North Jersey
Posts: 134
Drives: 2007 C230 Sport manual
My first Benz was a 2001 C230 coupe. The major gremlin was the sun-roof. It had to have its motor replaced, etc. at least once and had to be re-programed a number of times. My 2004 C230 SS has only once had to have a simple re-programming done.

It sounds as if you might have a pretty bad problem. Unless you do not want to use the sunroof anymore, you will need to spring for it to be done properly.
scottw is offline   Reply With Quote
Old 08-14-2006, 03:05 PM   #54
Member
 
Join Date: May 2006
Location: Vancouver, BC
Posts: 77
Drives: 2002 C240
I meant to type "slide open function". Yes, all the way back. Do this a few times (2 inches at a time). when the sunroof reaches the closed position, hold the button for approx. 10 seconds each time. Then when opening to the pop-up position, hold the button in that position for approx. 10 seconds.
It worked on my sunroof, hope it works on yours.
It may also be in your owners manual.
1st lite is offline   Reply With Quote
Old 08-14-2006, 08:31 PM   #55
Super Moderator
 
drexappeal's Avatar
 
Join Date: Mar 2004
Location: West Los Angeles
Posts: 7,679
Drives: Midnight Blue 2004.5 C230 Kompressor Sport Sedan. 2002 w210 E320, 2009 w211 E350 Sport
Send a message via AIM to drexappeal
Quote:
Originally Posted by 1st lite
I meant to type "slide open function". Yes, all the way back. Do this a few times (2 inches at a time). when the sunroof reaches the closed position, hold the button for approx. 10 seconds each time. Then when opening to the pop-up position, hold the button in that position for approx. 10 seconds.
It worked on my sunroof, hope it works on yours.
It may also be in your owners manual.
this is aka re-sync, but for some reason this sounds bigger than a re-sync issue.
drexappeal is offline   Reply With Quote
Old 08-15-2006, 12:06 AM   #56
Super Member
 
Moze's Avatar
 
Join Date: Jul 2006
Location: Syracuse
Posts: 512
Drives: 13 X3 28i M-Sport
I had sort of a similar problem... sometimes (not often), I'd auto close the sunroof and it'd close and then open back up a few inches...

It semed to only do it when I auto-closed the sunroof when it was NOT all the way open...

Took it in, they tested it... Said it was pulling up a couple "error codes..." they cleared them and I haven't had the problem since...

Fortunately covered by the warranty... $95/hr labor is a lot no matter how small of an issue
Moze is offline   Reply With Quote
Old 08-15-2006, 01:00 AM   #57
Super Member
 
Join Date: Dec 2001
Location: PHILIPPINES
Posts: 626
Drives: 07' ML350
i have this issue on my C240 as well, resynchronizing wont work either.

my sunroof closes automatically, but when i auto open it, it stops in the middle and i have to push the button again. it refuses to auto open all the way. from time to time it also decides to open all the way, mood swings?

dealer says they have to remove the headliner etc...so i didnt bother...
__________________
BruNo
10 Bmw 740Li (F02)
11 Mini John Cooper Works
12 Range Rover Evoque Dynamic Si4
BruNo is offline   Reply With Quote
Old 08-15-2006, 11:58 AM   #58
Newbie
 
Join Date: Jun 2006
Location: Los Angeles, CA
Posts: 12
Drives: 2006 C230
Mine just did that the other day for the first time. Closed all the way and then rolled back half way and ITS A 2006!!!!! I did the 10 second up and closed and it worked so far. I really didnt test it that much though, but it did close after that. Its the first issue and I hope not many to come. Ive heard all the horror stories with problems.SCARY . When I bought a MB I thought they would be more reliable
luislobo0711 is offline   Reply With Quote
Old 08-15-2006, 12:01 PM   #59
Super Member
 
shahedC's Avatar
 
Join Date: Mar 2006
Location: Washington DC
Posts: 970
Drives: OLD: 2004 C230 Sport Sedan, NEW: 2007 SLK350
I had a sunroof problem with my 2004 C230 in the first year... I would press the button to open it fully, but it would not open completely, and would get stuck

I had to hold the button down until the whole thing opened..
__________________
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

THEN: 2004 C230 Sport, NOW: 2007 SLK350: P-I,II,III, 7AT, Heating w/ Airscarf, Door Sills, 6CD
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
2007 SLK350 360-degree walkaround:
http://BenzFanz.com/2007SLK350/
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
shahedC is offline   Reply With Quote
Old 08-19-2006, 06:00 PM   #60
Junior Member
 
Join Date: Aug 2006
Location: Seattle, WA
Posts: 24
Drives: 2001 C320
Fixed

Well I gave in and took my car to the dealership. $196 later it was fixed with not a single new part added. Looks like they just reset some codes on the computer and reinstalled the motor after adjusting the sunroof and motor positioning. Oh well, it's fixed.
csaunder is offline   Reply With Quote
Old 05-11-2007, 09:13 PM   #61
MBWorld Fanatic!
 
kevblah's Avatar
 
Join Date: Feb 2007
Location: MA
Posts: 3,846
Drives: E90 M3
Send a message via AIM to kevblah
Exclamation Sunroof Broken

So, today I go to close my sunroof and it starts to go and then the driver's side of the roof seems to get stuck on something and it doesn't move, but the pass. side keeps on going and it eventually stops going altogether. If I use my hand and pull on the driver's side and assist it, it'll close, but it won't close fully. Anyone ever hear of this happening before?
__________________
2007 CLS63 (Sold) | 20% Tint | Tinted Taillights | 5000K Bulbs | LED License Plate Lights
2007 CLK550 (Sold) | 25% Tint | 6000K Bi-Xenons and Fogs | Resonator Delete | LED City and License Plate Lights
LED Interior Lights | Smoked Side Markers | Tinted Taillights | OEM E63 AMG Rims | H&R Spacers | Custom Quad Exhaust
kevblah is offline   Reply With Quote
Old 05-11-2007, 10:04 PM   #62
MBWorld Fanatic!
 
Join Date: Jan 2007
Location: Los Angeles
Posts: 2,377
Drives: SL500
Send a message via AIM to FreshTAMPON
no, but what has happened to me is very similar. it would open all the way ok but when i want to do the auto close one-push on the button it wont close all the way, it'll go half way then back open the other half. so it wouldnt close, but if i pushed and held the button it would close all the way with no problems. took it to the dealer and warranty covered it.
__________________
FARWEST | SKOOLBOYZ | PLATINUMLIFESTYLE
FreshTAMPON is offline   Reply With Quote
Old 05-11-2007, 10:28 PM   #63
MBWorld Fanatic!
 
kevblah's Avatar
 
Join Date: Feb 2007
Location: MA
Posts: 3,846
Drives: E90 M3
Send a message via AIM to kevblah
Quote:
Originally Posted by kleen C View Post
no, but what has happened to me is very similar. it would open all the way ok but when i want to do the auto close one-push on the button it wont close all the way, it'll go half way then back open the other half. so it wouldnt close, but if i pushed and held the button it would close all the way with no problems. took it to the dealer and warranty covered it.
im gonna go downstairs and try this
__________________
2007 CLS63 (Sold) | 20% Tint | Tinted Taillights | 5000K Bulbs | LED License Plate Lights
2007 CLK550 (Sold) | 25% Tint | 6000K Bi-Xenons and Fogs | Resonator Delete | LED City and License Plate Lights
LED Interior Lights | Smoked Side Markers | Tinted Taillights | OEM E63 AMG Rims | H&R Spacers | Custom Quad Exhaust
kevblah is offline   Reply With Quote
Old 05-11-2007, 10:41 PM   #64
MBWorld Fanatic!
 
kevblah's Avatar
 
Join Date: Feb 2007
Location: MA
Posts: 3,846
Drives: E90 M3
Send a message via AIM to kevblah
Update: didnt work, im gonna have my tech look at it in the morning. its like this small clip is holding it back, i can see the problem...hard to describe in writing tho
__________________
2007 CLS63 (Sold) | 20% Tint | Tinted Taillights | 5000K Bulbs | LED License Plate Lights
2007 CLK550 (Sold) | 25% Tint | 6000K Bi-Xenons and Fogs | Resonator Delete | LED City and License Plate Lights
LED Interior Lights | Smoked Side Markers | Tinted Taillights | OEM E63 AMG Rims | H&R Spacers | Custom Quad Exhaust
kevblah is offline   Reply With Quote
Old 05-11-2007, 10:43 PM   #65
MBWorld Fanatic!
 
Join Date: Jan 2007
Location: Los Angeles
Posts: 2,377
Drives: SL500
Send a message via AIM to FreshTAMPON
yea just take it to the dealer. all under warranty
__________________
FARWEST | SKOOLBOYZ | PLATINUMLIFESTYLE
FreshTAMPON is offline   Reply With Quote
Old 05-11-2007, 10:55 PM   #66
MBWorld Fanatic!
 
kevblah's Avatar
 
Join Date: Feb 2007
Location: MA
Posts: 3,846
Drives: E90 M3
Send a message via AIM to kevblah
Quote:
Originally Posted by kleen C View Post
yea just take it to the dealer. all under warranty
lol, my '02...WHAT WARRANTY?
and i meant the tech that works at my dads dealer
__________________
2007 CLS63 (Sold) | 20% Tint | Tinted Taillights | 5000K Bulbs | LED License Plate Lights
2007 CLK550 (Sold) | 25% Tint | 6000K Bi-Xenons and Fogs | Resonator Delete | LED City and License Plate Lights
LED Interior Lights | Smoked Side Markers | Tinted Taillights | OEM E63 AMG Rims | H&R Spacers | Custom Quad Exhaust
kevblah is offline   Reply With Quote
Old 05-12-2007, 01:58 AM   #67
MBWorld Fanatic!
 
Join Date: Jan 2007
Location: Los Angeles
Posts: 2,377
Drives: SL500
Send a message via AIM to FreshTAMPON
oh lol hahah
__________________
FARWEST | SKOOLBOYZ | PLATINUMLIFESTYLE
FreshTAMPON is offline   Reply With Quote
Old 05-12-2007, 02:23 AM   #68
MBWorld Fanatic!
 
KIRA's Avatar
 
Join Date: Jul 2005
Location: San Jose, Bay Area
Posts: 2,989
Drives: 2002 C230 coupe , NOt THE AVATAR!!
Send a message via AIM to KIRA
you have to jump on it
__________________
KIRA is offline   Reply With Quote
Old 05-21-2007, 02:59 AM   #69
Almost a Member!
 
e55bliss's Avatar
 
Join Date: Oct 2002
Location: Dallas
Posts: 66
Drives: 2001 S600 Black/Black
2001 S600 - Sunroof Behavior Puzzling

Maybe some common issues here ..

My sunroof is acting crazy. The problem changes, and the traditional reset is not working.

Last week: it would close almost all the way and at the last second reverse and stop about 3" open. Try to close and hold - it stops and reverses back to 3" again like something is blocking it. Slide back all the way to hold for reset - no effect. Going forward again reverses itself. Tilt doesn't work either, at all. So I hand crank it back to closed position and leave it there the rest of the week.

Today: I removed the fuse 77 in the right passenger foot area. Put fuse back in. Hit UP. Now it goes up, but it seem too far up, and clicks. Pressing down does nothing. Lubed the joints with a plentiful combo of wd40 and lithium grease. Press down. Now it closes all the way. Holding it back lowers it, forward raises it. One-touch doesn't work. Keep button held back - closes it 2 inches at a time. Keep doing this and it goes all the way - seems like too far, as a hear a couple of clicks - almost like a crunching sound before stopping. All the way forward and up, hold for 10 seconds. Same situation.

All the plastic in there seems fine. At one point the rear tilting window seal thing seemed to be dislodged on the front joints so I put that back into the holes on the sides. So to summarize the current state: it is going too far in either direction, one-click does not work, and going back only goes 2-inches at a time, so you have to keep clicking over and over before it reaches all the way back.

I have no idea now what is causing this, and I can't decide whether to just say the hell with it and stop using it altogether, or keep playing with the damn thing until it corrects itself. The dealership says it needs a new control module, $1200. But I get the feeling they won't seriously troubleshoot it until they have a contract for $1000.

If anyone has experienced this please let me know!
e55bliss is offline   Reply With Quote
Old 05-21-2007, 03:22 AM   #70
Member
 
hawaiian's Avatar
 
Join Date: Sep 2002
Location: Colorado Springs, CO.
Posts: 153
Drives: 2003 C230K SS (6 spd)
Quote:
Originally Posted by kleen C View Post
no, but what has happened to me is very similar. it would open all the way ok but when i want to do the auto close one-push on the button it wont close all the way, it'll go half way then back open the other half. so it wouldnt close, but if i pushed and held the button it would close all the way with no problems. took it to the dealer and warranty covered it.
I have the EXACT problem. What did the dealer say the problem was? I don't have a warranty anymore as it has just expired.
hawaiian is offline   Reply With Quote
Old 11-11-2007, 06:47 AM   #71
Member
 
Adi_V's Avatar
 
Join Date: Mar 2007
Location: Melbourne, Australia
Posts: 112
Drives: CL203 & sprinter
**** bang!
me too!
if you know what the prob is.. please, do tell.
__________________
MERCEDES vs. BMW
Adi_V is offline   Reply With Quote
Old 11-11-2007, 08:39 AM   #72
Super Member
 
valexv's Avatar
 
Join Date: Nov 2006
Location: Houston
Posts: 907
Drives: 02 cl203
Anyone have the part number for the motor, pana roof on a coupe. I think its the motor, just makes a thumpin noise and goes nowhere nor the shades move.
__________________
valexv is offline   Reply With Quote
Old 11-11-2007, 01:16 PM   #73
MBWorld Fanatic!
 
C230 Sport Coup's Avatar
 
Join Date: Jun 2002
Location: Bay Area
Posts: 5,287
Drives: 2002 C230 & 2006 ML350
Quote:
Originally Posted by valexv View Post
Anyone have the part number for the motor, pana roof on a coupe. I think its the motor, just makes a thumpin noise and goes nowhere nor the shades move.
EPC will get you pn's.
Service DVD has instructions for repair.
__________________
2002 C230 Sport Coup
ASP Pulley-Supersprint Header-Remus Muffler-
TEIN SS Coilovers
AMG; Wheels, 22mm AMG Front sway bar, HR 19mm rear bar,
C32 Brakes
Tinted Windows- 2005 Tails, Grill & Blinkers-Clear Sides
Bi-Xenon Headlights!
Clear Fogs w/Philips Crystal Vision bulbs
Audio 10
Renntech style Spoiler
Supercharger Muffler Deleted!
"Aero Turbine" AR20 Rasp Eliminator (Resonator)
C230 Sport Coup is offline   Reply With Quote
Old 11-13-2007, 02:33 AM   #74
Member
 
Adi_V's Avatar
 
Join Date: Mar 2007
Location: Melbourne, Australia
Posts: 112
Drives: CL203 & sprinter
Quote:
Originally Posted by C230 Sport Coup View Post
EPC will get you pn's.
Service DVD has instructions for repair.
service dvd??
where can i get my hands on that baby?
__________________
MERCEDES vs. BMW
Adi_V is offline   Reply With Quote
Old 06-14-2010, 01:28 PM   #75
Super Member
 
Join Date: Jun 2008
Location: Las Vegas, NV
Posts: 924
Drives: I drive a Toyota Hybrid...
geez i never notice this forum is such great help until recently my car start having all these problems...
__________________
kirax2 is offline   Reply With Quote
Old 06-14-2010, 01:28 PM
 
 
 
Reply

Tags
2001, 2002, c230, c320, coupe, gears, ims, ml350, problem, problems, resync, resynch, shade, sunroof, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 01:45 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details

SEO by vBSEO 3.5.2