Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Sign in using an external account
Register Forgot Password?

C-Class (W204) 2008-Present: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 04-12-2010, 11:22 PM   #1
Junior Member
 
Join Date: Aug 2009
Location: Edmonton, Alberta, Canada
Posts: 64
Drives: Mercedes Benz C300 4Matic
c300 install rear view camera issue

my c is 2010 model with every package except the back camera.

i was thinking install it by myself. i'v heard the car already preset the video cable in somewhere in the trunk(passenger side). you just plug and play.
is that true?

if so please help me find it out

my english sukx, sorry~
To remove this ad, register today or login if you already are registered!

billvip is offline   Reply With Quote
Old 04-13-2010, 11:34 AM   #2
Senior Member
 
Join Date: Jan 2008
Location: Vancouver, BC
Posts: 258
Drives: 08 C300
i'm also from Edmonton, and installed the back up camera myself.
If you want, pm me, i can give you some heads up.
white46 is offline   Reply With Quote
Old 04-13-2010, 01:25 PM   #3
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,089
Drives: 2012 C250 Coupe
jctevere
Your english isn't that bad at all, I easily understood you. While I am not familiar with 2010 c class or if the c-class in Canada differs from the ones in the U.S. I know that in my 2009 c300, it did not have a cable in the trunk to connect the back-up camera to. But it has the jack on the radio or command interface to connect to cable for a back-up camera. If you install the back-up camera and run the cable to the command interface, all you need to do is enable the option in the car diagnostics for a back-up camera to let the vehicle know that one is installed.

If however the cable is already run like you said, then all you do is mount the camera under the trunk above the license plate. There is already a great DIY in the sticky thread to show you how to do that. And then just connect the jack to the pre-run cable. After that, if it still does not work, you may have to enable the back-up camera option in the command interface yourself, or by going to the dealer and having them do it.

To do it by yourself (at least on U.S. cars) you must have the key in the ignition but only turned to the right once (electrical but no engine running) after that you press and hold the (Answer telephone button and the "OK" button on the steering wheel at the same time and hold for about 3 seconds)

Hopefully all goes well...
jctevere is offline   Reply With Quote
Old 04-14-2010, 06:04 AM   #4
MBWorld Fanatic!
 
Join Date: Oct 2008
Location: Palos Verdes/La Jolla
Posts: 1,191
Drives: '09 C63
http://www.mbworld.org/forums/c-clas...d-cyclops.html

If you search "cyclops" in this forum you will get more results as well. Dunno if those threads will answer your questions though.
Jae Duk is offline   Reply With Quote
Old 04-14-2010, 06:09 AM   #5
Junior Member
 
Join Date: Aug 2009
Location: Edmonton, Alberta, Canada
Posts: 64
Drives: Mercedes Benz C300 4Matic
the message is confirmed. the 2010 c class DO preset up the video cables in the trunk, but i dont know which one is???
billvip is offline   Reply With Quote
Old 04-25-2010, 12:18 PM   #6
MBWorld Fanatic!
 
clkcadet's Avatar
 
Join Date: Oct 2004
Location: NYC
Posts: 2,019
Drives: C300 4matic
Can I enable the cyclops camera even if I have the standard screen? I also saw Midcity had a very cool backup sensor that installs on top of the rear seat (just like the s550) I was wondering if anyone installed that?
__________________
'10 C300 4matic Sport Steel Grey/ Grey & Black MBTex

clkcadet is offline   Reply With Quote
Old 04-25-2010, 07:51 PM   #7
Junior Member
 
Join Date: Apr 2010
Posts: 36
Drives: C300 SPORT 4MATIC SEDAN
so is there? in the trunk?
HOTGQ161 is offline   Reply With Quote
Old 04-26-2010, 01:22 PM   #8
Senior Member
 
Join Date: Feb 2009
Location: S.Cali, US
Posts: 323
Drives: 2009 C300S 6mt
Quote:
Originally Posted by billvip View Post
the message is confirmed. the 2010 c class DO preset up the video cables in the trunk, but i dont know which one is???
are you sure?

where is this cable located exactly?
kaku is offline   Reply With Quote
Old 04-26-2010, 01:47 PM   #9
Junior Member
 
Join Date: Aug 2009
Location: Edmonton, Alberta, Canada
Posts: 64
Drives: Mercedes Benz C300 4Matic
you have to remove the trunk cover, passenger side.
right behind the "big black box with lots of wires". hope that help
billvip is offline   Reply With Quote
Old 04-27-2010, 07:58 PM   #10
Member
 
Join Date: Jan 2010
Location: near Vancouver, Canada
Posts: 117
Drives: 2010 C300 4matic Special Edition
Rear camera in 2010 C300 (Canada)

So how is the installation going? Could you post a picture of the cable in the trunk (so that I know what to look for)? I had a rummage in that area but could not find it, however, I did not remove the cover. How do you remove that side cover anyway? Thanks for any help, Roger
Rogwp is offline   Reply With Quote
Old 04-27-2010, 08:30 PM   #11
Junior Member
 
Join Date: Aug 2009
Location: Edmonton, Alberta, Canada
Posts: 64
Drives: Mercedes Benz C300 4Matic
i havent done that yet, but i have the pic.

here is the pic, hope that helps.
Attached Thumbnails
c300 install rear view camera issue-20100129_632a879918de87221921zfgqzftfftgu.jpg  
billvip is offline   Reply With Quote
Old 05-02-2010, 04:42 PM   #12
Member
 
Join Date: Jan 2010
Location: near Vancouver, Canada
Posts: 117
Drives: 2010 C300 4matic Special Edition
Quote:
Originally Posted by billvip View Post
i havent done that yet, but i have the pic.

here is the pic, hope that helps.
Hi again, I just went to check in my trunk, passenger side, and I can't tell where the photo is taken from. Is it between the fuse box and the back seats, or between the fuse box and the tail lights? Do I need to take off the whole side panel inside the trunk, or should I be able to find the cable through the fuse box access panel? Many thanks.
Rogwp is offline   Reply With Quote
Old 05-11-2010, 04:54 PM   #13
Junior Member
 
Join Date: Apr 2010
Posts: 36
Drives: C300 SPORT 4MATIC SEDAN
my dealer asked me for $1500.....crazy dudes. today i just got the fakra cable from midcity..... so i guess all i need is to pick up a camera, run the cable from the trunk to the nav and plug it in.... is it this easy? i think i also gonna need some sore of programing, is that right?
HOTGQ161 is offline   Reply With Quote
Old 05-11-2010, 11:03 PM   #14
Member
 
Join Date: Jan 2010
Location: near Vancouver, Canada
Posts: 117
Drives: 2010 C300 4matic Special Edition
Quote:
Originally Posted by HOTGQ161 View Post
my dealer asked me for $1500.....crazy dudes. today i just got the fakra cable from midcity..... so i guess all i need is to pick up a camera, run the cable from the trunk to the nav and plug it in.... is it this easy? i think i also gonna need some sore of programing, is that right?
Do you have a 2010? If so the video cable is already in the trunk.
Rogwp is offline   Reply With Quote
Old 05-12-2010, 11:15 AM   #15
Junior Member
 
Join Date: Apr 2010
Posts: 36
Drives: C300 SPORT 4MATIC SEDAN
Quote:
Originally Posted by Rogwp View Post
Do you have a 2010? If so the video cable is already in the trunk.
yeah, 2010 c300 w/ MM..... i heard of this but i cant find it.... i removed the pannals in the trunk and did a light search next to the black box and nothing..... can u tell me wherein the trunk? thanks do
HOTGQ161 is offline   Reply With Quote
Old 05-12-2010, 11:16 AM   #16
Junior Member
 
Join Date: Apr 2010
Posts: 36
Drives: C300 SPORT 4MATIC SEDAN
Quote:
Originally Posted by Rogwp View Post
Do you have a 2010? If so the video cable is already in the trunk.
did u find it in urs?
HOTGQ161 is offline   Reply With Quote
Old 05-12-2010, 12:12 PM   #17
MBWorld Fanatic!
 
Ron Jr's Avatar
 
Join Date: May 2008
Location: Long Island, New York
Posts: 2,822
Drives: 2013 C300 Sport Black Darth V3.0
I would search on the trunk lid if it was pre-run at the factory. Thats where the camera will be mounted.
__________________
`


"A Brabus Maybach," he said, as she turned her head in time to see him give the wheel a little pat. "The firm of Brabus extensively tweaks the product of Maybach, to produce one of these."

"Darth my ride?"

From chapter 17 of Spook Country by William Gibson
Ron Jr is offline   Reply With Quote
Old 05-12-2010, 01:53 PM   #18
Junior Member
 
Join Date: Apr 2010
Posts: 36
Drives: C300 SPORT 4MATIC SEDAN
Quote:
Originally Posted by Ron Jr View Post
I would search on the trunk lid if it was pre-run at the factory. Thats where the camera will be mounted.
Just did that and is not there.... ;-( my trunk looks naked.... cant find anything like it, not on the trunk lid, right pannel nor the left one,,,,, i even check the floor. same result. im starting to think this "pre-wired cable" stuff is just a mith
HOTGQ161 is offline   Reply With Quote
Old 05-12-2010, 08:05 PM   #19
Member
 
Join Date: Jan 2010
Location: near Vancouver, Canada
Posts: 117
Drives: 2010 C300 4matic Special Edition
Oh, well!

Quote:
Originally Posted by HOTGQ161 View Post
Just did that and is not there.... ;-( my trunk looks naked.... cant find anything like it, not on the trunk lid, right pannel nor the left one,,,,, i even check the floor. same result. im starting to think this "pre-wired cable" stuff is just a mith
I was afraid of that, I haven't had a good look myself yet, I was hoping that someone else would confirm that the cable was there. The OP posted a photo but I couldn't match the photo with my trunk. My C300 was made 01/10 if that makes any difference.
Rogwp is offline   Reply With Quote
Old 05-13-2010, 05:42 AM   #20
Former Vendor of MBWorld
 
Join Date: Mar 2007
Location: Chicago, IL
Posts: 615
Drives: ML350, Lotus Elise
I have not seen any W204's with the camera pre-wired... The Blue fakra in the pic looks like a GPS or SAT antenna.. The camera FAKRA should be green.
rob13572468 is offline   Reply With Quote
Old 05-13-2010, 03:59 PM   #21
Junior Member
 
Join Date: Apr 2010
Posts: 36
Drives: C300 SPORT 4MATIC SEDAN
Quote:
Originally Posted by Rogwp View Post
I was afraid of that, I haven't had a good look myself yet, I was hoping that someone else would confirm that the cable was there. The OP posted a photo but I couldn't match the photo with my trunk. My C300 was made 01/10 if that makes any difference.
i think we have been fooled, we want to believe is there but is not, a tech from MB whos a friend of a friend told me "IS NOT"
HOTGQ161 is offline   Reply With Quote
Old 06-16-2010, 02:50 AM   #22
Member
 
huir's Avatar
 
Join Date: May 2010
Location: California
Posts: 200
Drives: 2010 W204
Is there any update for this thread?
Anyone with 2010 C class find a pre-wired in the trunk?
huir is offline   Reply With Quote
Old 08-29-2010, 09:57 AM   #23
Newbie
 
Join Date: Aug 2010
Posts: 1
Drives: Mercedes c 300 2010
C300 navigation wiring in trunk?

Anyone have an update to this thread? Would like to add a camera to my 2010 with NAV. Tnx
jsturdi is offline   Reply With Quote
Old 04-12-2011, 06:34 PM   #24
Senior Member
 
Join Date: Mar 2011
Location: Bay Area, CA
Posts: 469
Drives: 2011 C300 Sport, Palladium Silver, P1, MM, Wood, Heated FS, self installed rearview camera. 2002 QX4
I also want to know if my 2011 C300 is camera pre wired. Mine has P1 and MM package. I asked three local dealers, some never replied, some said they don't not provide installation. No one says it's pre wired or not.
C300CA is offline   Reply With Quote
Old 04-12-2011, 08:59 PM   #25
Junior Member
 
Garry1104's Avatar
 
Join Date: Mar 2011
Posts: 58
Drives: C300 4MATIC
It's really not that hard to do. Took me a good 3 hrs last weekend to do it. All I bought was a FARKA cable from mid-city and a Sony rear view camera from amazon. Total cost was just $111 but knowing I did everything myself and it worked following the DIY info on this forum was just PRICELESS
Garry1104 is offline   Reply With Quote
Old 04-12-2011, 08:59 PM
 
 
 
Reply

Tags
2008, 2010, back, backup, benz, c230, c300, c350, camera, connecting, instal, install, mercedes, model, rear, view



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 12:07 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details

SEO by vBSEO 3.5.2