E.S.P warning, TPS problem? - MBWorld.org Forums

Log In 


C32 AMG, C55 AMG (W203) Discuss the C32 and C55 AMG.

Sponsored by CARiD
Click Here


E.S.P warning, TPS problem?

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 04-27-2009, 01:36 PM   #1
Super Member
Thread Starter
 
Join Date: Mar 2007
Location: Bay Area
Posts: 944
Drives: 03 C32, 06 CLS55
Thanks: 0
Thanked 0 Times in 0 Posts
E.S.P warning, TPS problem?

Ok, I got E.S.P warning and rpm went up to 2000rpm at idle. Scanned code is P0221.
I did a research on this and its most likely the TPS (throttle position sensor) is bad. I cleared the code and car ran fine for 2 days and it went back again. Again I clear it and it runs fine now.

Does this the TPS problem? (I want a confirmation )
Does anyone know the part #, a good source to buy this part, and a DYI?

Thanks in advance,
CLKCLK is offline   Reply With Quote
Old 04-27-2009, 03:28 PM   #2
MBWorld Fanatic!
 
Join Date: Jul 2007
Location: East Bay, Bay Area
Posts: 1,884
Drives: 2002 C32, 2012 S550
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by CLKCLK View Post
Ok, I got E.S.P warning and rpm went up to 2000rpm at idle. Scanned code is P0221.
I did a research on this and its most likely the TPS (throttle position sensor) is bad. I cleared the code and car ran fine for 2 days and it went back again. Again I clear it and it runs fine now.

Does this the TPS problem? (I want a confirmation )
Does anyone know the part #, a good source to buy this part, and a DYI?

Thanks in advance,
My TPS went out, but I had different symptoms than you. Once, when I went WOT, my car went into limp mode. I restarted and the CEL was still on, but it ran fine. I had a loss of power at high RPM's and it eventually caused missfires and the TPS codes.

I had my TPS rebuilt by BBA Remanufacturing, it was $400 for the rebuild plus 7-10 days turnaround time. Otherwise the TPS's are prohibitively expensive to replace.
My mechanic did it, but I think labor wasn't that long, maybe an hour or two?

Good luck brother, these cars can be really frustrating at times.

http://www.bba-reman.com/uk/index.aspx
Gramma_Benz is online now   Reply With Quote
Old 04-27-2009, 07:51 PM   #3
MBWorld Fanatic!
 
c32used's Avatar
 
Join Date: Feb 2006
Location: Elgin IL
Posts: 6,158
Drives: LET C32 2002
Thanked 0 Times in 0 Posts
interesting tell me the results please
c32used is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mirror turnsignal not working but no warning message TheBestOrNothin GLK-Class (X204) 4 06-20-2016 09:22 AM
Airmatic problem, car leaning to one side rbengry GL Class (X164) 2 06-02-2016 11:47 AM
collision assist inoperative djokodallas C Class (W205) 38 05-26-2016 05:59 PM
2006 S500 W221 Michael Wilks Mercedes Tech Talk 1 09-07-2015 06:47 AM
Trans won't shift into DRIVE BLKROKT C63 AMG (W204) 8 09-04-2015 10:33 AM


Tags
amg, c32, code, electrostatic, esp, location, mercedes, position, precipitor, problem, sprintbooster, throttle, tps, w203, warning


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 12:54 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.