Actron scanner not working for MB - MBWorld.org Forums

Log In 


C63 AMG (W204) Discuss the C63 AMG

Actron scanner not working for MB

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 02-16-2011, 09:07 PM   #1
Senior Member
Thread Starter
 
jim07's Avatar
 
Join Date: Feb 2010
Location: San Antonio
Posts: 336
Drives: 09 c63 p30 mars red
Thanks: 0
Thanked 0 Times in 0 Posts
Actron scanner not working for MB

Bought an Actron cp9575 scannner. It's advertising and website never indicated that is does not work on MB's. It does not!!! I called the tech line and they are sending me a USB cable to try and reprogram the unit on line. Very disappointed with the lack of discloser!! The tech said it does not work with Porsche either.
jim07 is offline   Reply With Quote
Old 02-20-2011, 06:40 PM   #2
Junior Member
 
Join Date: Feb 2007
Location: Bay Area, CA
Posts: 35
Drives: C63
Thanks: 0
Thanked 0 Times in 0 Posts
Actron scanner ditto

Just tried my Acutron scanner on my 2009 C63 (same unti as yours) - had the same problem. No connection. Upgraded to the latest on-line version of the scanner, still no communication with the car. BTW - this unit did work with my MY2000 Porsche.
mfissel is offline   Reply With Quote
Old 02-20-2011, 09:14 PM   #3
Senior Member
Thread Starter
 
jim07's Avatar
 
Join Date: Feb 2010
Location: San Antonio
Posts: 336
Drives: 09 c63 p30 mars red
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by mfissel View Post
Just tried my Acutron scanner on my 2009 C63 (same unti as yours) - had the same problem. No connection. Upgraded to the latest on-line version of the scanner, still no communication with the car. BTW - this unit did work with my MY2000 Porsche.
Thanks for the reply! I have a feeling I am going to have the same results after my upgrade also. It pisses me off that Actron does not state their scanners don't work with MB and other brands! I plan on raising hell with them until this is resolved. Very misleading packaging. I will let ya know.
jim07 is offline   Reply With Quote
Old 02-21-2011, 09:25 PM   #4
Senior Member
Thread Starter
 
jim07's Avatar
 
Join Date: Feb 2010
Location: San Antonio
Posts: 336
Drives: 09 c63 p30 mars red
Thanks: 0
Thanked 0 Times in 0 Posts
Upgraded the program ==== still doesn't work. It worked with my Saab but not the c63. I will be chewing a$$ tomorrow!!!
jim07 is offline   Reply With Quote
Old 02-22-2011, 09:09 AM   #5
MBWorld Fanatic!
 
Join Date: Feb 2010
Posts: 4,188
Drives: 2012 C63;1971 280SE 3.5(Sold);2003 1500 HD Silverado;2015 GLA 250 (wife's)
Thanked 26 Times in 25 Posts
You just bought this scanner correct? Why not return it for a refund and get them to pay return shipping for their omission of the fact it will not work on MB?
Mort is offline   Reply With Quote
Old 03-14-2011, 11:51 AM   #6
MBWorld Fanatic!
 
obsidian05e55's Avatar
 
Join Date: Dec 2006
Location: Livingston NJ
Posts: 3,281
Drives: C63, Grigio Medio E46 M3
Thanks: 0
Thanked 0 Times in 0 Posts
Any luck with getting these things to work with our cars?
obsidian05e55 is offline   Reply With Quote
Old 03-14-2011, 11:59 AM   #7
Senior Member
Thread Starter
 
jim07's Avatar
 
Join Date: Feb 2010
Location: San Antonio
Posts: 336
Drives: 09 c63 p30 mars red
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by obsidian05e55 View Post
Any luck with getting these things to work with our cars?
Nope! Never worked even after the upgrade from Actron. The tech told me to return it so I did.
I still would like to know of a unit that does work with the c63 that is not crazy priced ( $75-$125).
jim07 is offline   Reply With Quote
Old 03-14-2011, 12:44 PM   #8
MBWorld Fanatic!
 
Join Date: Feb 2007
Location: Desert
Posts: 3,443
Drives: 02 CLK 55 AMG,09 C63 loaded with P30
Thanks: 0
Thanked 0 Times in 0 Posts
I have the Actron-CP9125. Works fine..
Jons95c36amg is offline   Reply With Quote
Old 03-14-2011, 12:49 PM   #9
MBWorld Fanatic!
 
obsidian05e55's Avatar
 
Join Date: Dec 2006
Location: Livingston NJ
Posts: 3,281
Drives: C63, Grigio Medio E46 M3
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Jons95c36amg View Post
I have the Actron-CP9125. Works fine..
Really? I gotta pick one up. Changed my Purge Valve, and dont feel like paying the dealer to reset the light.
obsidian05e55 is offline   Reply With Quote
Old 03-14-2011, 12:52 PM   #10
MBWorld Fanatic!
 
Join Date: Feb 2007
Location: Desert
Posts: 3,443
Drives: 02 CLK 55 AMG,09 C63 loaded with P30
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by obsidian05e55 View Post
Really? I gotta pick one up. Changed my Purge Valve, and dont feel like paying the dealer to reset the light.
Yes its cheap $50 or so.
Jons95c36amg is offline   Reply With Quote
Old 03-14-2011, 01:06 PM   #11
MBWorld Fanatic!
 
obsidian05e55's Avatar
 
Join Date: Dec 2006
Location: Livingston NJ
Posts: 3,281
Drives: C63, Grigio Medio E46 M3
Thanks: 0
Thanked 0 Times in 0 Posts
Cool. Thanks!
obsidian05e55 is offline   Reply With Quote
Old 03-14-2011, 05:04 PM   #12
MBWorld Fanatic!
 
obsidian05e55's Avatar
 
Join Date: Dec 2006
Location: Livingston NJ
Posts: 3,281
Drives: C63, Grigio Medio E46 M3
Thanks: 0
Thanked 0 Times in 0 Posts
Got the Actron CP9125 $59. Worked!! Ran, and cleared the code, but now when i start the car the screen says "TeleAid Inoperable"

My code was P0455. I had the Gas Cap loose light, deaker replaced gas cap. CEL came back, so I replaced the Purge Valve. Seems to be fixed now.

Code P0455 says EVAP Emission Control System Leak (Large)
obsidian05e55 is offline   Reply With Quote
Old 03-23-2012, 08:28 PM   #13
MBWorld Fanatic!
 
drawde's Avatar
 
Join Date: Feb 2009
Location: Northern NJ
Posts: 1,020
Drives: 2009 C63
Thanks: 0
Thanked 0 Times in 0 Posts
Thank you all for this thread. My CP9325 wasn't working on my car, picked up the 9125 and all is well. Bumping for anyone else looking for a cheap working OBD II scanner for their 63.
drawde is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
collision assist inoperative djokodallas C Class (W205) 38 05-26-2016 05:59 PM
Boot Locked, Batt Dead, No Key NSWEuroCharged W211 AMG 9 09-07-2015 03:15 PM
HELP! Changed battery,now supercharger doesn't work! AMG185MM W211 AMG 0 09-05-2015 10:43 AM
W220 Windsheild Wipers sabri S-Class (W220) 0 09-04-2015 12:35 PM
What could it be? 12V not working in truck. kino1161 M-Class (W164) 1 09-03-2015 07:55 AM


Tags
05, 2009, actron, actroncp9575, connecting, cp9125, cp9575, davidson, harley, mercedes, mercedesbenz, problem, scanner, silverado, wontwork, working


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 12:55 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.