Go Back   MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > CL-Class (W215)
Sign in using an external account
Register Forgot Password?


CL-Class (W215) 2000-2006: CL 500, CL 600

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 07-30-2006, 09:21 AM   #1
Senior Member
 
V12toHybrid's Avatar
 
Join Date: May 2002
Location: Wyomissing, Pa
Posts: 268
Drives: Kia Sedona
changed a dead battery and now abs, esp, and bas lights are on

my battery died last week and i finally changed it with a after market one last night and then when i cranked it up, the computer is showing esp and bas malfunction and the abs light came on. tried that ecu resetting procedure (key to sec position, press gas padal, turn off, release gas, remove key) but it didn't work. the car was fine before the battery failure. is the new battery messing up the computer or there are something truely wrong with the car? going to drive it this am and see. will report back.
To remove this ad, register today or login if you already are registered!

__________________
1995 C220 my ever-so-dependable-sold
2001 CL600 i think i just ran over a prius-traded in
2002 ML320 never been off road and proud of it-traded
2010 S400 Hybrid- look ma, I'm green!-totaled by hail storm 6-14
2011 ML 350-still haven't been off road.-totaled by hail storm 6-14
2014 SLK white-wife's midlife crisis
2014 Cayenne Platinum edition-finally joined the soccer dad club
V12toHybrid is offline   Reply With Quote
Old 07-30-2006, 11:19 AM   #2
Super Member
 
Jud Chapin's Avatar
 
Join Date: Nov 2004
Location: West Palm Beach, Florida
Posts: 746
Drives: '02 CL500, '91 Mark VII, '76 Vette
For an '02 CL500, the procedure to restore the system after battery disconnect is to start the engine and turn the steering wheel fully left and then fully right. That should solve the warning light problem. The other procedures involves windows which requires closing all windows and holding each button in the up position for a second or so. Lastly, open the moon roof to the rear open position and again hold the button down for a second or so. I don't know if this procedure is for your vehicle. Check your manual if this doesn't work. Good luck.
__________________
2002 CL500
1991 Lincoln Mark VII
1976 Corvette
Jud Chapin is offline   Reply With Quote
Old 07-30-2006, 11:27 AM   #3
Senior Member
 
V12toHybrid's Avatar
 
Join Date: May 2002
Location: Wyomissing, Pa
Posts: 268
Drives: Kia Sedona
DUDE!!! THANK YOU SOOOOOOOOO MUCH!!!!
you just made my day!! going to try it now
__________________
1995 C220 my ever-so-dependable-sold
2001 CL600 i think i just ran over a prius-traded in
2002 ML320 never been off road and proud of it-traded
2010 S400 Hybrid- look ma, I'm green!-totaled by hail storm 6-14
2011 ML 350-still haven't been off road.-totaled by hail storm 6-14
2014 SLK white-wife's midlife crisis
2014 Cayenne Platinum edition-finally joined the soccer dad club
V12toHybrid is offline   Reply With Quote
Old 07-30-2006, 01:51 PM   #4
Senior Member
 
V12toHybrid's Avatar
 
Join Date: May 2002
Location: Wyomissing, Pa
Posts: 268
Drives: Kia Sedona
problems solved just like you said, turn steering wheel to the left then to the right and all the lights are off. it's actually in the manuel just like you said as well. resetted the time, windows and sunroof also. can't thank you enough. i love mbworld
__________________
1995 C220 my ever-so-dependable-sold
2001 CL600 i think i just ran over a prius-traded in
2002 ML320 never been off road and proud of it-traded
2010 S400 Hybrid- look ma, I'm green!-totaled by hail storm 6-14
2011 ML 350-still haven't been off road.-totaled by hail storm 6-14
2014 SLK white-wife's midlife crisis
2014 Cayenne Platinum edition-finally joined the soccer dad club
V12toHybrid is offline   Reply With Quote
Old 07-30-2006, 08:47 PM   #5
Banned
 
bltserv's Avatar
 
Join Date: Sep 2004
Location: Irvine, CA.
Posts: 725
Drives: 2005 SL55, 2000 CL500
Talking Battery Reset

I freaked when the MB Field guy replaced my battery
and all those warning lights came on.
He was cool and said not to worry.
He did exactly what was discribed in the thread.
Steering wheel, Windows, I think he hit the ESP and ABC buttons too.
After that all was fine.
bltserv is offline   Reply With Quote
Old 07-30-2006, 11:59 PM   #6
Super Member
 
Jud Chapin's Avatar
 
Join Date: Nov 2004
Location: West Palm Beach, Florida
Posts: 746
Drives: '02 CL500, '91 Mark VII, '76 Vette
Quote:
Originally Posted by 02ml320
problems solved just like you said, turn steering wheel to the left then to the right and all the lights are off. it's actually in the manuel just like you said as well. resetted the time, windows and sunroof also. can't thank you enough. i love mbworld
Glad I could help. I don't know why MB doesn't explain this to customers when they buy a CL or other MB. I specifically asked the service writer about this when the car was first in for service. He talked about how to redo the radio favorite channels and how that was all that needed to be done. I didn't believe him at the time and found out later, like you, when all the warning lights came on.
__________________
2002 CL500
1991 Lincoln Mark VII
1976 Corvette
Jud Chapin is offline   Reply With Quote
Old 08-01-2006, 09:42 AM   #7
Super Member
 
Whodat's Avatar
 
Join Date: Apr 2006
Location: Somewhere in Maryland
Posts: 555
Drives: 2000 CLK 430 Cabriolet
Quote:
Originally Posted by Jud Chapin
Glad I could help. I don't know why MB doesn't explain this to customers when they buy a CL or other MB. I specifically asked the service writer about this when the car was first in for service. He talked about how to redo the radio favorite channels and how that was all that needed to be done. I didn't believe him at the time and found out later, like you, when all the warning lights came on.
They want you to bring it back to them so they can charge you 2 hours labor for a stupid computer reset!
__________________
Mods: Floor mats....
Whodat is offline   Reply With Quote
Old 01-18-2014, 03:16 PM   #8
Newbie
 
BigJohn06's Avatar
 
Join Date: Jan 2014
Posts: 1
Drives: CL500
Thanks. You're a genius.

Thanks Again
BigJohn06 is offline   Reply With Quote
Old 01-18-2014, 03:16 PM
 
 
 
Reply

Tags
02, 600, abs, bas, battery, batttery, cl, cl600, dead, ebs, esp, failure, light, ml320, reset



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 01:33 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details