Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W210)
Sign in using an external account
Register Forgot Password?


E-Class (W210) 1995-2002: E 200, E 220D, E 240, E 290TD, E 300TD, E 200, E 240, E 280, E 320, E 420, E 430 (Wagon, Touring, 4Matic)

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 07-06-2003, 07:14 PM   #1
Almost a Member!
 
Join Date: Jul 2003
Location: Portland OR
Posts: 26
Drives: 1998 E320 Sedan
Radio Antenna 1998 E320

I have terrible AM reception on my 98 E320. The deal fixed it once, but it still has lots of static much of the time; at other times it gets fairly good AM reception. I would like to try to fix it myself this time. Can someone tell me how the antenna is routed? Does it go to the rear window, the rear bumper or both? Is their a connection in the antenna cable in the trunk that I could unplug and plug in a conventional antenna to rule out a problem at the radio itself?
To remove this ad, register today or login if you already are registered!

tomscia is offline   Reply With Quote
Old 07-06-2003, 07:36 PM   #2
MBWorld Fanatic!
 
E-Klasse's Avatar
 
Join Date: Mar 2002
Location: Arizona, USA
Posts: 1,509
Drives: E-Class W210, SLK R170, Jetta MKV TDI, MINI Cooper S
You could run a new cable and mount an aftermarket mast antenna. The connector on the back of the stereo is not conventional so you might have to splice that on the end of the new cable. Or contact Harman/Becker to order the correct connection.

Go Here for Harman/Becker
__________________
I assume no liability for any incidental, consequential or other liability from the use of this information. All risks and damages, incidental or otherwise, arising from the use or misuse of the information contained herein are entirely the responsibility of the user. Although careful precaution has been taken in the preparation of this information, I assume no responsibility for omissions or errors.
E-Klasse is offline   Reply With Quote
Old 07-07-2003, 11:30 AM   #3
MBWorld Fanatic!
 
jimmydagreek's Avatar
 
Join Date: Mar 2003
Location: SFV, SoCal
Posts: 5,550
Drives: '04 Silverado Z71 - sold all my Benzes and need another!
How did the dealer fix it the first time and did it work fine after that? Next question, are you windows tinted by any chance???
jimmydagreek is offline   Reply With Quote
Old 07-23-2003, 02:00 AM   #4
Almost a Member!
 
Join Date: Jul 2003
Location: Portland OR
Posts: 26
Drives: 1998 E320 Sedan
AM antenna 1998 E320

My car does have tinted windows. The dealer removed both left and right trunk liner and both left and right "C" pillar trim. They "traced antenna wiring to splitter behind L/R "C" pillar trim and found loose connection at splitter. The connection did not affect FM reception. Repaired." Can anyone tell me how the antenna cable is routed from the radio to the rear window antenna? Did the dealer need to remove both left and right side trunk liners and "C" pillar trim (rather than just the right or just the left) to examine the antenna cable? Thanks, Tom
tomscia is offline   Reply With Quote
Old 08-15-2004, 10:49 PM   #5
Member
 
johnny's E320's Avatar
 
Join Date: Dec 2002
Location: Palo Alto, CA
Posts: 84
Drives: 1998 E320 Sedan
Send a message via Yahoo to johnny's E320
So, I seem to have the same problem. I have tinted windows on my 98 E320, and my AM is awful!

Is there a way to remedy this problem without removing the tint? How does one get access to the C-pillar? Any special tools from MB?

I used to work in a body shop, so I'm not afraid to do the work, just want to be sure that I don't break anythng, or that doing this myself is futile at best, even if I know the problem.

Help me.
__________________


1998 E320 Sedan * 2003 Honda ST1300 * 2006 Yamaha Fino 110cc * 2007 Honda Air Blade 125cc * Toro 3.5hp Lawn Mower * Braun Electric Toothbrush
johnny's E320 is offline   Reply With Quote
Old 09-14-2005, 01:49 PM   #6
Almost a Member!
 
Join Date: Mar 2004
Location: Oxnard
Posts: 64
Drives: 2000 E320 Nice & Stock
Send a message via AIM to cody Send a message via Yahoo to cody
Try rolling all your windows down and see if you AM reception improves. If it doesn't, it's not your tint.
cody is offline   Reply With Quote
Old 09-14-2005, 01:49 PM
 
 
 
Reply

Tags
1998, 2000, 2002, 98, antenna, cpillar, e320, mercedes, problem, problems, radio, radion, reception, sedan, w210



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 12:29 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details