Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Sign in using an external account
Register Forgot Password?


E-Class (W211) 2003-2009

Sponsored by : Autohaus AZ
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 06-14-2011, 11:15 AM   #1
Newbie
 
Join Date: Jun 2010
Posts: 5
Drives: 2003 E500
Headlight Problem

I have a 2003 E-500. I'm having a problem figuring out why one of my headlights isn't getting power. My mechanic did a HID conversion to my headlamps. Both lamps worked when he 1st installed them, but the lights were flickering and I got the message on the dash that the left bulb was out. I then got the computer set to xenon=present by the dealership, but when I got the car back, the left headlight stop working and the right headlight is working fine, and I'm still getting the message on the dash that the left bulb is out. My mechanic said that he connected everything on the left and right side the exact same way. He's checked for power coming out of the socket and there's no power coming out. He said he checked all of the fuses and the bulbs and they all work. He seems to be pretty stumped.....does anyone have any ideas of what the problem could be? Please help!!
To remove this ad, register today or login if you already are registered!

t_than is offline   Reply With Quote
Old 06-14-2011, 11:44 AM   #2
MBWorld Fanatic!
 
Join Date: Sep 2009
Location: NJ / VA
Posts: 6,651
Drives: 06 CLS55
djrabbi djrabbi2001 djrabbi
Send a message via AIM to djrabbi
they might not be getting enough power.....did you get a harness for it?
__________________
'06 CLS55

djrabbi is offline   Reply With Quote
Old 06-14-2011, 12:12 PM   #3
Newbie
 
Join Date: Jun 2010
Posts: 5
Drives: 2003 E500
It was a D-nex HID kit. It came with harnesses.
t_than is offline   Reply With Quote
Old 06-15-2011, 03:38 AM   #4
Junior Member
 
Join Date: Apr 2011
Location: San Francisco, Santa Barbara
Posts: 22
Drives: 2003 E320, 2005 4Runner
facebook.com/tonymac @tony_mac
I have the same problem with the left headlight after an aftermarket HID install. I haven't had the chance to check mine out yet but I think it could be the ignitor.
T-Mac is offline   Reply With Quote
Old 06-15-2011, 09:06 AM   #5
Newbie
 
Join Date: Jun 2010
Posts: 5
Drives: 2003 E500
Quote:
Originally Posted by T-Mac View Post
I have the same problem with the left headlight after an aftermarket HID install. I haven't had the chance to check mine out yet but I think it could be the ignitor.

Let me know what you find out.
t_than is offline   Reply With Quote
Old 06-15-2011, 12:00 PM   #6
Newbie
 
Join Date: Jun 2010
Posts: 5
Drives: 2003 E500
Figured it out. It was the ballast. We used a test ballast from another car that we thought was working, but it was going bad. So, we thought the ballast was ok. Then, we later installed the test ballast back into the car we got it out of and the light started flickering. Might be your ballast?
t_than is offline   Reply With Quote
Old 06-15-2011, 12:00 PM
 
 
 
Reply

Tags
2003, ballast, benz, e500, front, head, headlight, hedlight, light, mercedes, present, problems, set, w211, working, xenon



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 01:21 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details