Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Sign in using an external account
Register Forgot Password?

E-Class (W211) 2003-2009

Sponsored by : Autohaus AZ
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 08-31-2012, 08:32 PM   #1
Junior Member
 
JayDee4711's Avatar
 
Join Date: Aug 2007
Location: Nova Scotia, Canada
Posts: 60
Drives: 2003 CLK430 Cabrio, 2009 BMW 535 iX Wagon
Question W211: Glove box light is out. Any ideas?

I tried putting an LED bulb in the glove box and must have caused a short. Now the light won't come on anymore, neither with the LED, nor the original bulb. The bulb is OK, and so is the fuse. We are talking darkness and ignition on.

I found a couple threads that said the glove box light is under the control of one of the many black boxes. Makes sense if it senses daylight or darkness. Does anyone have an idea what can be done here? Any more details?

Thanks in advance!
To remove this ad, register today or login if you already are registered!

JayDee4711 is offline   Reply With Quote
Old 09-24-2012, 05:01 PM   #2
Junior Member
 
JayDee4711's Avatar
 
Join Date: Aug 2007
Location: Nova Scotia, Canada
Posts: 60
Drives: 2003 CLK430 Cabrio, 2009 BMW 535 iX Wagon
Any ideas?

JayDee4711 is offline   Reply With Quote
Old 09-27-2012, 12:35 PM   #3
Super Member
 
Long Islander's Avatar
 
Join Date: May 2003
Location: Long Island, New York
Posts: 529
Drives: 2008 E350 4matic Wagon (well, actually she drives it mostly)
Quote:
Originally Posted by JayDee4711 View Post
I tried putting an LED bulb in the glove box and must have caused a short. Now the light won't come on anymore, neither with the LED, nor the original bulb. The bulb is OK, and so is the fuse. We are talking darkness and ignition on.

I found a couple threads that said the glove box light is under the control of one of the many black boxes. Makes sense if it senses daylight or darkness. Does anyone have an idea what can be done here? Any more details?

Thanks in advance!
I would put a volt meter across the contacts for the glove box light and see what it reads. If you're getting proper voltage, check the contacts to make sure they're actually making contact with the bulb. I removed and reinstalled a bulb in my hatchback and noticed that there was something wrong with the contacts when the bulb would no longer light up. So I had to bend the contacts back to make sure they touched. Also, I noticed that some interior lights don't light up when the car is parked outside in daylight (light sensor somewhere). Are you checking in a dark garage?
Long Islander is offline   Reply With Quote
Old 09-27-2012, 02:09 PM   #4
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,542
Drives: 2004 E320
Quote:
Originally Posted by Oggie (on L.I.) View Post
Also, I noticed that some interior lights don't light up when the car is parked outside in daylight (light sensor somewhere). Are you checking in a dark garage?
+1, what oggie said
__________________
2004 E320 4Matic, Tectite, Pano roof, keyless go, Navi, appearance package
starbrite is offline   Reply With Quote
Old 09-29-2012, 04:45 PM   #5
Super Member
 
Long Islander's Avatar
 
Join Date: May 2003
Location: Long Island, New York
Posts: 529
Drives: 2008 E350 4matic Wagon (well, actually she drives it mostly)
BTW, my glove compartment lamp only lights when the ignition is turned to the "On" position (not just the "Accessory" position).
Long Islander is offline   Reply With Quote
Old 03-08-2014, 07:00 PM   #6
Junior Member
 
sthoms's Avatar
 
Join Date: Jan 2014
Location: Hood River, OR
Posts: 34
Drives: 2004 AMG E55, 2011 Ram 2500 6.7L
Also note, if the bulb isn't present when the car it turn "On", the system will disconnect it. At least that is what I have observed trying to do the same to the license plate lights.
sthoms is offline   Reply With Quote
Old 03-08-2014, 09:40 PM   #7
MBWorld Fanatic!
 
Join Date: Aug 2010
Posts: 2,472
Drives: 2007 W211 E350 4Matic / 2008 X164 GL320 CDI
The glove box light seems to simply follow the ignition without other intervention.


The switch a funky mechanical piece and could have been broken playing with the bulbs.
N_Jay is offline   Reply With Quote
Old 03-08-2014, 09:40 PM
 
 
 
Reply

Tags
2007, benz, box, bulb, classic, e350, eclass, glove, glovebox, light, mercedes, o7, panel, w209, w215



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 10:07 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details