Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
Sign in using an external account
Register Forgot Password?

E-Class (W212) 2010-present: E 350, E 550

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 03-16-2013, 04:54 PM   #1
Junior Member
 
Join Date: Feb 2013
Posts: 31
Drives: 2010 E550
mbrace account question

Got my 2010 E550 and signed up for owners online, which is where I saw something bout mbrace and online vehicle services. Got a letter in the mail from MBUSA asking me to call to activate mbrace, so I call up, get the 3 month trail of basic + Plus features. That was this past Thursday. I still can't login to mbrace.mbusa.com and the iPhone app won't work, saying incorrect account/pin combination. I called the 866 number and they said it takes 2 days for that activation.

How long should this process take? It's an all digital service, seems like it should be pretty quick for me to be able to login and check things...
To remove this ad, register today or login if you already are registered!

RyanRice is offline   Reply With Quote
Old 03-16-2013, 10:37 PM   #2
MBWorld Fanatic!
 
Arrie's Avatar
 
Join Date: Oct 2010
Posts: 1,529
Drives: 2010 E550
Quote:
Originally Posted by RyanRice View Post
Got my 2010 E550 and signed up for owners online, which is where I saw something bout mbrace and online vehicle services. Got a letter in the mail from MBUSA asking me to call to activate mbrace, so I call up, get the 3 month trail of basic + Plus features. That was this past Thursday. I still can't login to mbrace.mbusa.com and the iPhone app won't work, saying incorrect account/pin combination. I called the 866 number and they said it takes 2 days for that activation.

How long should this process take? It's an all digital service, seems like it should be pretty quick for me to be able to login and check things...

Also, as your car is a 2010 model it probably is set for the "Cars Connected" service, which MB used before the mbrace. This means that if you use the buttons inside the car they will call wrong numbers if MB did not change this. Your dealer service must change the phone number the car will call if you switch to mbrace.
Arrie is offline   Reply With Quote
Old 03-17-2013, 08:33 AM   #3
Member
 
Join Date: Aug 2012
Location: South East
Posts: 206
Drives: 2013 E350 Sport Sedan, 2012. C250 Sport Sedan, HD-FatBoy
I love my 2013 E350, but have to say, MBrace is SUB-PAR. I've had nothing but problems with my account, (charged twice for the same period of service, charged after I cancelled, they had 2 accounts for me, etc.) The MBrace internet is a farce...the Internet apps are so slow that they're just not worth using. My last vehicle had on-star...It was half the price and better, by far.
Tomspo04 is offline   Reply With Quote
Old 03-17-2013, 11:10 AM   #4
Newbie
 
Join Date: Mar 2013
Location: Roanoke, VA
Posts: 6
Drives: 2012 E 350, 4Matic
If you read the reviews for the iPhone app, what you describe is par for the course.

I too was set up with the free 3 month trail, however after dealing with a completely incompetent sales rep over the phone and dealing with an app that was obviously designed by the interns, I think I'll wait until they get themselves together before I decide to actually pay for it.
Thom228 is offline   Reply With Quote
Old 03-17-2013, 04:42 PM   #5
Junior Member
 
Join Date: Feb 2013
Posts: 31
Drives: 2010 E550
I still can't even login to the web portion of the service. I know they entered the PIN correctly during signup as when I deliberately try the incorrect pin it tells me so. When I use the correct PIN, it sits for about 20 seconds, then gives me the following:

Quote:
An error has occured, please try again. If the problem persists, please call Customer Support at 1866-990-9007.
I called the number and they told me to wait. Well, I've waited. If I was paying for this I'd be pretty pissed. I can say I won't be paying...
RyanRice is offline   Reply With Quote
Old 03-18-2013, 03:33 PM   #6
Senior Member
 
Join Date: Feb 2003
Location: Washington, NJ
Posts: 350
Drives: 2003 E320
On my 2013 E350, it took a visit to the dealer to get it activated. So far, the only thing I find useful is the Send2Benz feature. I've used it a few times and it works as advertised. I'm not sure I'll pay for it once my trial ends.
__________________
John Keane

2013 E350 4MATIC-Luxury with P1, Driver's Assistance Package, Heated Steering Wheel, ParkTronic, Split Folding Rear Seats in Steel Grey/Black MB-Tex

2003 Pewter Silver/Charcoal E320, E2, E5, CD Changer
2005 US-Spec Comand, Sirius Satellite, Navigation, MHI, Bluetooth, European Mirrors (Thanks Steve)

jbec.keane is offline   Reply With Quote
Old 03-18-2013, 11:05 PM   #7
Junior Member
 
Join Date: Feb 2013
Posts: 31
Drives: 2010 E550
Mine is sort of working. I can now login to the mobile app and web site. Nothing works though. I'm hoping this is due to the fact that its configured for cars connected still,which I verified by pressing the info button. I'm hoping the reconfiguration does more than change some telephone numbers, otherwise nothing works. No location, no lock/unlock. No send2benz. Not useful.
RyanRice is offline   Reply With Quote
Old 03-19-2013, 12:23 PM   #8
MBWorld Fanatic!
 
SoCalCLK's Avatar
 
Join Date: Mar 2003
Location: Southern California
Posts: 2,936
Drives: 2010 W212 E550
This sort of thing makes me not want to subscribe to mbrace!
SoCalCLK is offline   Reply With Quote
Old 03-19-2013, 03:22 PM   #9
MBWorld Fanatic!
 
Join Date: Jan 2011
Location: Central Pennsylvania
Posts: 1,757
Drives: 2012 S350 Bluetec 4Matic, Diamond White, P2
I have had nothing but good experiences with mBrace. I like that the Concierge service can be added "a la carte" for a month. It is a great service.
__________________
___________________________________
2012 S350 Bluetec 4Matic, Diamond White, P2, Flux Capacitor, Mr. Fusion, and one jar Gray Poupon.
ImInPA is offline   Reply With Quote
Old 03-19-2013, 04:45 PM   #10
Junior Member
 
Join Date: Feb 2013
Posts: 31
Drives: 2010 E550
I spoke with my dealer and they said that all they reconfigure is the phone number it calls, the rest is on mbrace. Not sure how that works since they have to remotely control some vehicle functions, which requires a digital network connection.

Of course, the SA also mentioned that Teleaid didn't have remote lock and unlock, which isn't true either as I saw it in the literature in the glove box.

I hope it's some epic adventure to get it working properly, I'd like to enjoy the service.
RyanRice is offline   Reply With Quote
Old 03-20-2013, 11:41 AM   #11
MBWorld Fanatic!
 
Arrie's Avatar
 
Join Date: Oct 2010
Posts: 1,529
Drives: 2010 E550
Quote:
Originally Posted by RyanRice View Post
I spoke with my dealer and they said that all they reconfigure is the phone number it calls, the rest is on mbrace. Not sure how that works since they have to remotely control some vehicle functions, which requires a digital network connection.

Of course, the SA also mentioned that Teleaid didn't have remote lock and unlock, which isn't true either as I saw it in the literature in the glove box.

I hope it's some epic adventure to get it working properly, I'd like to enjoy the service.

Teleaid has remote unlock. I tested this as I have it. I don't know about remote lock but can't think why they would not have this too.

Best of all, teleaid has the NAV address service included with the basic package, i.e. when I need an address or a POI that does not exist on the NAV system data it pops up in about 10 seconds when I call the TeleAid number and ask for it.

I had MBRACE in my 2011 E350 and found it quite useless.
Arrie is offline   Reply With Quote
Old 03-20-2013, 11:56 AM   #12
Member
 
Join Date: Oct 2008
Posts: 124
Drives: 2013 E350 Sedan
Quote:
Originally Posted by jbec.keane View Post
On my 2013 E350, it took a visit to the dealer to get it activated. So far, the only thing I find useful is the Send2Benz feature. I've used it a few times and it works as advertised. I'm not sure I'll pay for it once my trial ends.
Send2Benz is the only feature I use also. I have no use for the others. I did get 6 months free so when that expires, no reason for me to keep paying to use this.
aprevo15 is offline   Reply With Quote
Old 03-22-2013, 09:56 AM   #13
Senior Member
 
Join Date: Jul 2006
Posts: 266
Drives: 2011 E550, 2008 SL55 AMG
2011 E550 - never had a problem with mbrace. Tried the Concierge service, but didn't use it enough to make it worthwhile.
__________________
2011 E550, 2008 SL55 AMG
pdjv is offline   Reply With Quote
Old 03-27-2013, 09:09 PM   #14
Junior Member
 
Join Date: Feb 2013
Posts: 31
Drives: 2010 E550
So I got my car back from service, it was updated to mbrace. When I pressed the Info button, I got connected to mbrace. They said they couldn't get my GPS coordinates, though my Navigation continues to work perfectly. Tried the iphone app, no functions worked, all said unsuccessful. Tried the web-site, it says successful, but nothing worked. I tried the unlock procedure and after holding down the trunk release... nothing happened, or so I thought. I looked in the drivers window as I passed by the and the information center was red and stated Connecting SOS call. Car was locked, I hadn't been in it to press SOS. Maybe it was phoning home because I was trying to break in? No idea, but here we are and I've still yet to use a single mbrace function.

One thing, the app said that Send2Benz wouldn't work for my vehicle. I guess that is true it's a 2010 with NTG 4.0, though the website lists it as an option. When I try, it fails. Maybe because mbrace is failing, or because it doesn't support it. Either way, nothing works, won't be paying for this.
RyanRice is offline   Reply With Quote
Old 04-24-2013, 12:28 PM   #15
Junior Member
 
Join Date: Feb 2013
Posts: 31
Drives: 2010 E550
Update. At long last I can lock my doors and track the vehicle. I still cannot unlock it. I send the unlock request and hold the trunk release... The only thing that happens is the instrument cluster goes red and shows SOS Emergency call connecting. That never goes away in its own. I have to go into the vehicle and hit call end.

So one month of my free trial down, and it still doesn't fully function.

Can anyone tell me if they've got an ntg 4.0 based vehicle that successfully works with send2benz? I've never gotten that to work either.
RyanRice is offline   Reply With Quote
Old 04-24-2013, 12:28 PM
 
 
 
Reply

Tags
18669909007, account, activate, added, bluetooth, iphone, locate, log, mbrace, mercedes, pin, problems, vehicle, wont, work, worth



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 09:31 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details

SEO by vBSEO 3.5.2