C300 ignition problem - MBWorld.org Forums

General Mercedes Discussion Use this forum to discuss general Mercedes-Benz topics that are not specifically model related.

C300 ignition problem

LinkBack Thread Tools Search this Thread Rate Thread
Old 12-24-2012, 12:19 PM   #1
Thread Starter
Join Date: Dec 2012
Posts: 1
Drives: C300, 2008
Thanks: 0
Thanked 0 Times in 0 Posts
C300 ignition problem

I have a 2008 C300 with 90,000 miles, it is currently in repair shop diagnosed with bad ignition switch and computer problem. has anyone else encountered problems like this. So far my repair cost is $1100 and counting.
drmann83 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
collision assist inoperative djokodallas C Class (W205) 43 10-08-2016 06:59 PM
Can't start after service RothnerD C-Class (W203) 9 09-14-2015 05:27 PM
Anybody else have problems with MY16 C300? jakc C Class (W205) 9 09-04-2015 10:50 PM
Fog Light Install help-C300 4Matic 2009 alexfirth91 C-Class (W204) 5 09-03-2015 04:50 PM
1992 MB 500sel System500SEL S-Class (W140) 0 09-02-2015 11:39 PM

2008, 300c, bad, benz, c300, electronic, forum, ignition, issue, mercedes, problem, problems, sport, switch, symptoms

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

All times are GMT -4. The time now is 06:30 AM.

Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.