Go Back   MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > M-Class (W163)
Sign in using an external account
Register Forgot Password?


M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 09-07-2006, 02:23 PM   #1
Member
 
Join Date: May 2005
Location: CA
Posts: 180
Drives: 09 S550
Dash lights up with brake problem

Hello,

I have 2002 ML-320. When the card is cold and you start it all brake indicators light up: ABS. ESP. Brakes etc.
Once the car warms up and you restart it. It is fine.
Does anyone have any suggestions?

The car is out of warranty.

Thanks.
To remove this ad, register today or login if you already are registered!

__________________
2013 s550
Black on Black
Premium pkg
Sport pkg plus with 20 inch wheels
Other cars:
Land Rover Discovery 2003
Lexus rx350 2012
avb777 is offline   Reply With Quote
Old 09-08-2006, 02:51 AM   #2
MBWorld Fanatic!
 
Join Date: Apr 2006
Location: Arizona
Posts: 2,768
Drives: BMW FTW
Quote:
Originally Posted by avb777 View Post
Hello,

I have 2002 ML-320. When the card is cold and you start it all brake indicators light up: ABS. ESP. Brakes etc.
Once the car warms up and you restart it. It is fine.
Does anyone have any suggestions?

The car is out of warranty.

Thanks.
Not to be rude but this is a common problem and if you do a search it has been covered many times, you will be able to find the part number and someone has a DIY on the fix. Dont feel bad it gets asked so many times we should have a sticky for the topic....
AndrewAZ is offline   Reply With Quote
Old 09-08-2006, 01:15 PM   #3
Member
 
Join Date: May 2005
Location: CA
Posts: 180
Drives: 09 S550
I did do a search, and I did read about the brake switch. But the conditions are different.
Anybody has any suggestions?
__________________
2013 s550
Black on Black
Premium pkg
Sport pkg plus with 20 inch wheels
Other cars:
Land Rover Discovery 2003
Lexus rx350 2012
avb777 is offline   Reply With Quote
Old 09-08-2006, 03:25 PM   #4
MBWorld Fanatic!
 
Join Date: Apr 2006
Location: Arizona
Posts: 2,768
Drives: BMW FTW
Quote:
Originally Posted by avb777 View Post
I did do a search, and I did read about the brake switch. But the conditions are different.
Anybody has any suggestions?
My car did the same thing that your car is doing and it was the brake switch. When I would first start it in the morning I would get the lights, then in the afternoon when I drove it again the lights would be out. Had the switch replaced under warranty and problem went away, if I remember right the part is less than $20.
AndrewAZ is offline   Reply With Quote
Old 09-12-2006, 12:34 PM   #5
Member
 
Join Date: May 2005
Location: CA
Posts: 180
Drives: 09 S550
Quote:
Originally Posted by AndrewAZ View Post
My car did the same thing that your car is doing and it was the brake switch. When I would first start it in the morning I would get the lights, then in the afternoon when I drove it again the lights would be out. Had the switch replaced under warranty and problem went away, if I remember right the part is less than $20.
Just came back from the dealer and it turns our to be $2200 repair - control unit needs to be replaced. $1700 part. Not sure what to do now.
__________________
2013 s550
Black on Black
Premium pkg
Sport pkg plus with 20 inch wheels
Other cars:
Land Rover Discovery 2003
Lexus rx350 2012
avb777 is offline   Reply With Quote
Old 09-13-2006, 10:30 PM   #6
MBWorld Fanatic!
 
Join Date: Apr 2006
Location: Arizona
Posts: 2,768
Drives: BMW FTW
Quote:
Originally Posted by avb777 View Post
Just came back from the dealer and it turns our to be $2200 repair - control unit needs to be replaced. $1700 part. Not sure what to do now.
Ouch. That is probably the worst thing to go bad. Its not like a guessing game when they plug the computer in and it says the unit is not working so my guess is they are 100% right. Its up to you if you want to replace it or not but i dont think ESP or BAS work without it, you dont need either but they are safety features you might want especially for an SUV.
AndrewAZ is offline   Reply With Quote
Old 09-13-2006, 10:30 PM
 
 
 
Reply

Tags
2006, brake, class, dash, dashboard, light, lights, mercedes, ml430, problem, s550, switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear brake problem E430 4matic salnic2000 E-Class (W210) 0 06-27-2006 12:31 PM
Adaptive brake lights... konigstiger S-Class (W221) 2 02-19-2006 01:54 PM
3rd brake light out along with regular lights GT23 E-Class (W210) 3 08-01-2005 10:00 PM
brake lights blow fuse!!!! HELP ybgoss C-Class (W202) 0 06-30-2005 10:54 AM
W208 Dash Problem. - At warm up, the entire dash turns on and off singlemalt Mercedes Tech Talk 0 01-04-2005 12:49 PM



All times are GMT -4. The time now is 06:20 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details