Dash lights up with brake problem - MBWorld.org Forums

Log In 


M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Dash lights up with brake problem

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 09-07-2006, 02:23 PM   #1
Member
Thread Starter
 
Join Date: May 2005
Location: CA
Posts: 180
Drives: 09 S550
Thanks: 0
Thanked 0 Times in 0 Posts
Dash lights up with brake problem

Hello,

I have 2002 ML-320. When the card is cold and you start it all brake indicators light up: ABS. ESP. Brakes etc.
Once the car warms up and you restart it. It is fine.
Does anyone have any suggestions?

The car is out of warranty.

Thanks.
avb777 is offline   Reply With Quote
Old 09-08-2006, 02:51 AM   #2
MBWorld Fanatic!
 
Join Date: Apr 2006
Location: Arizona
Posts: 2,767
Drives: BMW FTW
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by avb777 View Post
Hello,

I have 2002 ML-320. When the card is cold and you start it all brake indicators light up: ABS. ESP. Brakes etc.
Once the car warms up and you restart it. It is fine.
Does anyone have any suggestions?

The car is out of warranty.

Thanks.
Not to be rude but this is a common problem and if you do a search it has been covered many times, you will be able to find the part number and someone has a DIY on the fix. Dont feel bad it gets asked so many times we should have a sticky for the topic....
AndrewAZ is offline   Reply With Quote
Old 09-08-2006, 01:15 PM   #3
Member
Thread Starter
 
Join Date: May 2005
Location: CA
Posts: 180
Drives: 09 S550
Thanks: 0
Thanked 0 Times in 0 Posts
I did do a search, and I did read about the brake switch. But the conditions are different.
Anybody has any suggestions?
avb777 is offline   Reply With Quote
Old 09-08-2006, 03:25 PM   #4
MBWorld Fanatic!
 
Join Date: Apr 2006
Location: Arizona
Posts: 2,767
Drives: BMW FTW
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by avb777 View Post
I did do a search, and I did read about the brake switch. But the conditions are different.
Anybody has any suggestions?
My car did the same thing that your car is doing and it was the brake switch. When I would first start it in the morning I would get the lights, then in the afternoon when I drove it again the lights would be out. Had the switch replaced under warranty and problem went away, if I remember right the part is less than $20.
AndrewAZ is offline   Reply With Quote
Old 09-12-2006, 12:34 PM   #5
Member
Thread Starter
 
Join Date: May 2005
Location: CA
Posts: 180
Drives: 09 S550
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by AndrewAZ View Post
My car did the same thing that your car is doing and it was the brake switch. When I would first start it in the morning I would get the lights, then in the afternoon when I drove it again the lights would be out. Had the switch replaced under warranty and problem went away, if I remember right the part is less than $20.
Just came back from the dealer and it turns our to be $2200 repair - control unit needs to be replaced. $1700 part. Not sure what to do now.
avb777 is offline   Reply With Quote
Old 09-13-2006, 10:30 PM   #6
MBWorld Fanatic!
 
Join Date: Apr 2006
Location: Arizona
Posts: 2,767
Drives: BMW FTW
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by avb777 View Post
Just came back from the dealer and it turns our to be $2200 repair - control unit needs to be replaced. $1700 part. Not sure what to do now.
Ouch. That is probably the worst thing to go bad. Its not like a guessing game when they plug the computer in and it says the unit is not working so my guess is they are 100% right. Its up to you if you want to replace it or not but i dont think ESP or BAS work without it, you dont need either but they are safety features you might want especially for an SUV.
AndrewAZ is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad Alternator or Voltage Regulator? MTV10 W211 AMG 20 03-07-2016 03:12 PM
2012 vs. 2014 C250 2014 C250 C-Class (W204) 9 10-04-2015 08:54 PM
:: ECS Tuning :: EBC Front Brake Pads ECSTuning MB Sedan Vendor Classifieds 2 09-03-2015 05:17 PM
Fog Light Install help-C300 4Matic 2009 alexfirth91 C-Class (W204) 5 09-03-2015 04:50 PM
FS: 2005 E320 4matic Estate marc hanna Mercedes Vehicles 0 09-02-2015 08:16 AM


Tags
2006, brake, class, dash, dashboard, light, lights, mercedes, ml430, problem, s550, switch


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 03:50 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.