Go Back   MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > M-Class (W163)
Sign in using an external account
Register Forgot Password?


M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 01-20-2008, 11:39 PM   #1
Newbie
 
Join Date: Dec 2007
Posts: 5
Drives: 1998 ML320
P0170 and P0173 codes

Hello,

My 98 ML320 has been giving me P0170 and P0173 codes. It has 78,000 miles. I cleaned the MAF and reset codes. They immediately came back. Then replaced the MAF and the CEL went out and codes went away temporarily, now they're back. Any suggestions on the next course of action. Truck seems to run fine.

Thanks! I have gained incredible knowledge about this truck from this forum. Much appreciated!
To remove this ad, register today or login if you already are registered!

dms58 is offline   Reply With Quote
Old 01-21-2008, 02:57 AM   #2
Super Member
 
Join Date: Apr 2003
Location: Bay area - California
Posts: 560
Drives: 2000 ML320 2006 SLK 350
P0173 & P0170 are general fuel adaptation codes...

Quote:
Originally Posted by dms58 View Post
Hello,

My 98 ML320 has been giving me P0170 and P0173 codes. It has 78,000 miles. I cleaned the MAF and reset codes. They immediately came back. Then replaced the MAF and the CEL went out and codes went away temporarily, now they're back. Any suggestions on the next course of action. Truck seems to run fine.

Thanks! I have gained incredible knowledge about this truck from this forum. Much appreciated!
99% of the times it is the MAF that causes these codes, but if its not the MAF, it could be also the oxygen sensors or spark plugs. They all play a role in fuel adaptation...
__________________
Silver 2000 ML320 - Fender Flares, Chrome Grill Guard, Chrome side steps, Hella Fog Lights, GPS, Bose, Skyview Roof,M1 & M5 convinience packages.

2006 SLK 350
mihir_d is offline   Reply With Quote
Old 01-21-2008, 06:03 AM   #3
Super Member
 
PaulX608's Avatar
 
Join Date: Jul 2005
Location: Manassas, VA, USA
Posts: 718
Drives: 2001 740iL, 2004 ML350
paul.x.danner
Send a message via AIM to PaulX608
Don't forget the fuel filter. You can't expect fuel to be metered consistently if it can't be delivered consistently.
__________________
Paul X Danner
NRA Life Member
M-B Owners Gun Club, Member #13
Email

2001 ML430(sold)
1993 400E(totaled)
1999 C230(sold)
2004 ML350(the mrs.)
2001 BMW 740iL(mine)
PaulX608 is offline   Reply With Quote
Old 01-21-2008, 01:35 PM   #4
Super Member
 
Join Date: Apr 2003
Location: Bay area - California
Posts: 560
Drives: 2000 ML320 2006 SLK 350
That's true..

Quote:
Originally Posted by PaulX608 View Post
Don't forget the fuel filter. You can't expect fuel to be metered consistently if it can't be delivered consistently.
Fuel filter, Fuel pump & Fuel pump relay/fuse...check all of those...
__________________
Silver 2000 ML320 - Fender Flares, Chrome Grill Guard, Chrome side steps, Hella Fog Lights, GPS, Bose, Skyview Roof,M1 & M5 convinience packages.

2006 SLK 350
mihir_d is offline   Reply With Quote
Old 01-21-2008, 09:22 PM   #5
Newbie
 
Join Date: Dec 2007
Posts: 5
Drives: 1998 ML320
P0170 and P0173 codes

Thanks guys,

The spark plugs were replaced 2 years/14,000 miles ago. It's been 4 years/28,000 miles since the fuel pump and filter were replaced. I guess the fuel filter would be a good place to start. Then I'll probably replace the O2 sensors.

Anyone know how difficult the Fuel Filter replacement is? The fuel pump has been upgraded.
dms58 is offline   Reply With Quote
Old 01-21-2008, 10:39 PM   #6
Super Member
 
PaulX608's Avatar
 
Join Date: Jul 2005
Location: Manassas, VA, USA
Posts: 718
Drives: 2001 740iL, 2004 ML350
paul.x.danner
Send a message via AIM to PaulX608
Do a search, it's been discussed quite a few times. Remove the left rear wheel and plastic fender liner, you'll see it.
__________________
Paul X Danner
NRA Life Member
M-B Owners Gun Club, Member #13
Email

2001 ML430(sold)
1993 400E(totaled)
1999 C230(sold)
2004 ML350(the mrs.)
2001 BMW 740iL(mine)
PaulX608 is offline   Reply With Quote
Old 01-22-2008, 04:17 PM   #7
Junior Member
 
Join Date: Jun 2006
Posts: 25
Drives: 2000 ml320 1986 560sel 1973 280se4.5
You are sure of the quality of the replacement MAF sensor? Is it rebuilt, a proper insert, or OEM complete piece?
roberthelfrick is offline   Reply With Quote
Old 10-15-2009, 12:13 PM   #8
Newbie
 
Join Date: Oct 2009
Posts: 1
Drives: ML 320
Smile P0170 and P0173 on ML320

Dear Friends,
I had same codes come up on my 2001 ML320, which has 72,000 miles on it. It was kindda on and off, it will come on for a day or two and then automatically go off for a day or two. i drove about 1500 miles in this conditions. Then finally one day took it to autozone to read the codes. They said P0170 and P0173.
I searched on this site and found that many had tryed MAF cleaner, i thought to give it first try. I went to Merc. dealer and brought a new airfilter and then a MAF cleaner from autozone. and it just took me few minutes to change the airfilter on ML. Then i took out MAF sensor and sprayed almost half bottle of MAF claener on it. Let it dry for 20 minutes and fixed everything back.
Started car and check engine light was there, i shut engine 3 times and restarted 3 times, but Check Engine light was still there. I thought may be something else is wrong. But next day after about 3 trips of 5 miles, Check engine light went off. and it has not come back since last 15 days now. I noticed ML also increased pick up because of new airfilter. So i would sugest that please before you spend lots of money on expensive MAF sensor, just give try to new airfilter and clean your MAF sensor with it's cleaner available in autozone. I will keep posting here in future, may be after 1 more month to notify that light has come up again or not. But for now i am very happy that it has not come again since 15 days.... touch wood.
Thank you,
Dhaval Katharotiya
ML320 and BMW 750iL.
Dhaval Katharot is offline   Reply With Quote
Old 03-13-2014, 12:35 PM   #9
Newbie
 
barnett898's Avatar
 
Join Date: Mar 2014
Posts: 1
Drives: 2008 ML63 AMG
thanks for the help.
barnett898 is offline   Reply With Quote
Old 07-25-2014, 02:13 PM   #10
Newbie
 
Join Date: Jul 2014
Location: Toronto, Canada
Posts: 8
Drives: 2001 Mercedes C240 Base
I just wanted to add my experience to the P0170/P0173 problem.


I have a 2001 Mercedes C240 base (W203) from Canada. At around 88,000 km; it started throwing out check engine light errors.

My non-mercedes mechanic ended up changing spark plugs without benefit.

So... fast forward a few years and I finally run the codes through google and it points to the MAF sensor.


By now, the car has 115,000 km.

First thing I tried was to take out the MAF and cleaning it with electrical contact cleaner. No success.

So... bit the bullet and ordered a Bosch MAF sensor from rockauto for about $150.

I'm glad that I didn't order an ebay one (thanks to everyone for their feedback) as that was my first instinct but the reports of bad sensors wasn't worth the time experimenting.

swapped out the MAF sensor and the check engine light has been off for the last 3 days and 160 km of driving so far.

Will try to keep this updated but for now; just wanted to give you my feedback and expand the knowledge base.


ALSO, I see that the sensors have date codes stamped on them, the original failed sensor was an OEM bosch manufactured from Dec 2000.

DO we know when they may have fixed the sensor problem or if it's still a problem with the new sensors?
garbage911 is offline   Reply With Quote
Old 07-25-2014, 02:13 PM
 
 
 
Reply

Tags
2000, 98ml320, 99, bumper, c230, change, code, filter, fuel, guard, mercedes, ml, ml320, p0170, p0173, rear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 03:22 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details