Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W126)
Sign in using an external account
Register Forgot Password?


S-Class (W126) 1979-1991: 300 SE, 300 SEL, 380 SE, 380 SEL, 420 SEL, 500 SEL, 560 SEL, 360 SEC, 500 SEC, 580 SEC, 300 SD TURBODIESEL, 300 SDL TURBO, 350 SD TURBO, 350 SDL TURBO

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 09-28-2009, 08:17 PM   #1
Newbie
 
Join Date: Sep 2009
Posts: 4
Drives: 1991 Mercedes 300SE
Will not Shift out of 2nd gear

I am the owner of a 1991 300se that I bought in Oct. 1990. It has always had a little hesitancy to shift to Drive. The dealer always told us that it was normal until the car warmed up. Since my exwife always drove this car and on my rare instances of driving it, I did not persue the issue. Recently, I was driving the car and after waiting at a stop light, the car would not accelerate out of 2nd Gear. The car now has 201000 miles. I do not know the history during the last 7 yeaqrs. She lived in a town that did not have a MB dealer and she had it serviced at a shop that specilizes in Mercedes. I have read threads looking for similiar problems and have not found a common problem. Even though the car still has a beautiful exterior and interior, I do not want to incur the expense of a dealer fix. It is not a daily driver. I can do my own repairs, but I do not have a manual for this car. Any ideas?
To remove this ad, register today or login if you already are registered!

Rhine is offline   Reply With Quote
Old 10-14-2009, 12:49 PM   #2
Newbie
 
Durbo20vT's Avatar
 
Join Date: Oct 2006
Location: CT
Posts: 14
Drives: 03 VW GTi 20vT & 89 300SEL
check the transmission fluid. back when i had my 420sel, this would happen when the trans fluid was low. filling it to proper levels temporarily cured the issue.
Durbo20vT is offline   Reply With Quote
Old 10-14-2009, 01:33 PM   #3
Newbie
 
Join Date: Sep 2009
Posts: 4
Drives: 1991 Mercedes 300SE
Thanks for your reply. I checked and changed the transmission fluid. There was no change in the shifting. I did more research and my symton seem to match those of a faulty b2 piston. I have found a few sites that describe the replacement of this piston. Moreover, they describe a procedure for its replacement while the transmission is still on the car. I am now trying to decide if I want to undertake this project. Again, thanks for your response.
Rhine is offline   Reply With Quote
Old 10-14-2009, 01:33 PM
 
 
 
Reply

Tags
2001, 2nd, 350, accelerating, benz, car, gear, mercedes, ml, shift, trans, transmission, turbo, w126, wont



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 06:16 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details