Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W220)
Sign in using an external account
Register Forgot Password?


S-Class (W220) 1999-2006: S 320 CDI, S 320, S430, S 500, S 600

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 03-09-2009, 10:38 PM   #1
Banned
 
Join Date: Mar 2009
Location: BK
Posts: 58
Drives: Lorinser 5.5
Add 1 Liter Oil??

Toward the end of every month my car is reading that it needs 1.0 liter of oil.

Is something leaking in the engine?? whats going on??
To remove this ad, register today or login if you already are registered!

Lorinser55 is offline   Reply With Quote
Old 03-09-2009, 11:42 PM   #2
MBWorld Fanatic!
 
m4xm1l10n's Avatar
 
Join Date: Oct 2008
Posts: 1,745
Drives: BMW F02 (750Li) F10 (550i)
Quote:
Originally Posted by Lorinser55 View Post
Toward the end of every month my car is reading that it needs 1.0 liter of oil.

Is something leaking in the engine?? whats going on??
What W220 do you have ? usually is normal and how often do you change your oil ?
__________________
(N54 E82 135i) M Sport, Alpine White/ Coral Red .
lightly Modded :)
434whp & 470wtq / Run Conditions 90.28 *F
(N63 F02 750Li) Sport & Every Single option.
BMS S1 431whp/479wtq 93 Oct / Run Conditions 91*F
m4xm1l10n is offline   Reply With Quote
Old 03-10-2009, 12:05 AM   #3
MBWorld Fanatic!
 
ssonss1's Avatar
 
Join Date: Oct 2006
Location: Vancouver BC
Posts: 1,203
Drives: Flying Spur
i get that every month or two...i guess its normal...more so in the summer months...no leaks here tho
ssonss1 is offline   Reply With Quote
Old 03-10-2009, 12:35 AM   #4
Banned
 
Join Date: Jun 2007
Location: Brooklyn
Posts: 2,051
Drives: 02 S500 Sport
Quote:
Originally Posted by Lorinser55 View Post
Toward the end of every month my car is reading that it needs 1.0 liter of oil.

Is something leaking in the engine?? whats going on??
Take a big crap into the Oil Pipe that should fix it

Yea you got an Oil Leak !
Gondon is offline   Reply With Quote
Old 03-10-2009, 12:50 AM   #5
Banned
 
Join Date: Mar 2009
Location: BK
Posts: 58
Drives: Lorinser 5.5
gondon your such a dikfor. Post crap thats useful not what you do to stop your problems lol.
Lorinser55 is offline   Reply With Quote
Old 03-10-2009, 12:52 AM   #6
Banned
 
Join Date: Jun 2007
Location: Brooklyn
Posts: 2,051
Drives: 02 S500 Sport
HAHAH
Gondon is offline   Reply With Quote
Old 03-10-2009, 12:57 AM   #7
MBWorld Fanatic!
 
m4xm1l10n's Avatar
 
Join Date: Oct 2008
Posts: 1,745
Drives: BMW F02 (750Li) F10 (550i)
Quote:
Originally Posted by Gondon View Post
Take a big crap into the Oil Pipe that should fix it

Yea you got an Oil Leak !
U nuts man lol !!! R u coming down to CT or Boston this weekend for the Meet ?
__________________
(N54 E82 135i) M Sport, Alpine White/ Coral Red .
lightly Modded :)
434whp & 470wtq / Run Conditions 90.28 *F
(N63 F02 750Li) Sport & Every Single option.
BMS S1 431whp/479wtq 93 Oct / Run Conditions 91*F
m4xm1l10n is offline   Reply With Quote
Old 03-10-2009, 01:31 AM   #8
Banned
 
Join Date: Jun 2007
Location: Brooklyn
Posts: 2,051
Drives: 02 S500 Sport
Quote:
Originally Posted by m4xm1l10n View Post
U nuts man lol !!! R u coming down to CT or Boston this weekend for the Meet ?
wat meet?

People come to me , I dont come to people !

We should have another meet this sunday in LI haha.
Gondon is offline   Reply With Quote
Old 10-08-2010, 10:55 AM   #9
MBWorld Fanatic!
 
Join Date: May 2009
Location: NoVa
Posts: 1,069
Drives: 2004 S55 (for sale, makes me cry!), 2009 GL550
bring this post back from the dead

my 2004 S55 popped up the same message, which stayed on for about 10 seconds then went away:

Add 1.0 liter oil at filling station

I've not seen this in the 17 months and 21K miles I've had the car. It's due for a Service A in about 1,200 miles.

It happened during WOT acceleration.

Normal?
i_am_amused is offline   Reply With Quote
Old 10-08-2010, 11:49 AM   #10
Senior Member
 
Join Date: Jan 2009
Posts: 311
Drives: Mercedes S600TT, LX470 SuperCharged, QX4, BMW 750IL
Happens to me every 4-5 months. Put oil in and it goes away. I was told to use 0W40. When it says add 1 Liter it usually means your engine is out of oil. I have never had any oil leaks... I think MB engines drink a lot of oil.
__________________
2005 S600 V12TT
Reckless is offline   Reply With Quote
Old 10-08-2010, 12:57 PM   #11
MBWorld Fanatic!
 
Oxygen's Avatar
 
Join Date: Mar 2005
Location: Long Island, NY
Posts: 3,454
Drives: W220 S65 AMG
Send a message via AIM to Oxygen
Yeah guys... supercharged and turbocharged engines are going to burn oil... so um... add oil when it tells you to!
__________________

https://www.facebook.com/v12TT

| Past Cars: Photos

| M275 V12 biturbo technical resources (under construction): www.v12tt.com / www.v12biturbo.com

| YouTube: S65 AMG Video
Oxygen is offline   Reply With Quote
Old 10-08-2010, 01:34 PM   #12
Super Member
 
Join Date: Jul 2008
Location: New York
Posts: 769
Drives: Mercedes S55 AMG
I get this too on mine, after an oil change 1-3 months, it will tell me to add 1 to 2 quarts of oil. I do have a minor oil leak in the rear seal, so it may be that as well.
rondocap is offline   Reply With Quote
Old 10-08-2010, 03:58 PM   #13
MBWorld Fanatic!
 
Join Date: Dec 2006
Location: Clifton, NJ
Posts: 4,487
Drives: 05 S500 4m
id get a dipstick and actually make sure you need oil before actually adding it.
__________________
05 S500 4m & 96 993TT
Quadcammer is offline   Reply With Quote
Old 10-08-2010, 05:44 PM   #14
Super Member
 
Join Date: Jul 2008
Location: New York
Posts: 769
Drives: Mercedes S55 AMG
Oliverk, actually I was just about to say that. The onboard computer can and sometimes is wrong. You definitely need to manually check the oil as well.

Start the car up and warm it, then turn it off, wait 5 minutes, and check the oil with the dipstick. That's the best way, since the onboard computer can sometimes be a bit off. Also make sure the car is on level ground.
rondocap is offline   Reply With Quote
Old 10-08-2010, 05:48 PM   #15
Super Member
 
Join Date: Sep 2009
Location: California USA
Posts: 554
Drives: 2004 S55 ///AMG, 2007 E350
Funny, I just got that same message yesterday, for the first time. I took it to my MB dealer and they topped it off.

During the last Service B, they put in too much, manual says 7.9 quarts, they put in 9 quarts, so they had remove some, possibly took out too much resulting in this error this time.

Anyway, they say 1 quart every 1,000 mile is normal, but should look out for leaks or burning oil.
Corsa9000 is offline   Reply With Quote
Old 10-09-2010, 06:52 PM   #16
Senior Member
 
Join Date: Dec 2008
Posts: 312
Drives: C350 Elegance
If there are no leaks, the oil lost is just a sacrificial film in the cylinder wall that is pushed out the exhaust pipe with the fumes of the combustion chamber. This loss is a result of the extraordinary lubricating protection given by synthetic oils which manage to penetrate even through the oil ring of the piston. A true benefit which helps extend the life of the engine about 25% by comparison to engines lubed with fossil oils.

So, if there is no trace of leak, leave it alone. However, I agree that the oil should be measured to check how much is needed to fill the system without going over the normal quantity.

__________________
To establish a love raport with your car:
DEFENSIVE DRIVING-Never having to say you're sorry.
PREVENTIVE MAINTENANCE-Never will leave you stranded.
JoeVal is offline   Reply With Quote
Old 10-09-2010, 06:52 PM
 
 
 
Reply

Tags
05, 10, add, burning, filling, liter, lost, mercedes, oil, quarts, s320, s430, s500, s600, station, w220



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 07:37 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details