Go Back   MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W220)
Sign in using an external account
Register Forgot Password?

S-Class (W220) 1999-2006: S 320 CDI, S 320, S430, S 500, S 600

Sponsored by : My Mercedes Parts
Click Here

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 11-03-2011, 02:30 AM   #1
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
S430 airmatic problem please help :(((

Hi,

Im new here & need help asap. I own a 2000 s430 & recently my boyfriend messed with the airmatic button which has two lights that turn on ( I guess they are for sports1 & sports2) after he messed with it- the same day .. Stop car too low message came on and car has been sitting on the front end , tires leveled with the fenders - and the tires touch the fenders when turning. The left shock was replaced less than a.year ago.. So I know its nothing with the shocks.. But the right side is kind of lower than the left. Also the button he was playing with lights turn on and off quickly when starting the car. Can this problem occur from playing with the button.. And what can I do!!???!!
To remove this ad, register today or login if you already are registered!

Benziechicago is offline   Reply With Quote
Old 11-03-2011, 07:21 AM   #2
Out Of Control!!
 
hyperion667's Avatar
 
Join Date: Jul 2010
Location: North Carolina
Posts: 10,419
Drives: '12 CLSAMG,'14 S550V4
face what?? lame ??? gamers get lives what??
go visit the dealer......
__________________







please watch!!!:
http://www.youtube.com/watch?v=zVN7I...yer_detailpage
hyperion667 is offline   Reply With Quote
Old 11-03-2011, 12:09 PM   #3
Member
 
Join Date: Jul 2010
Location: Miami Florida
Posts: 78
Drives: S500
Sounds you might need to replace the pump that makes the vehicle rise I forgot the technical name. It is located under the bumpers passenger side. It has failed to lift your vehicle when it has dropped. You will need to take it to a Benz specialist and they will confirm it is that. Approx $400-$550 repair job
envymesukas is offline   Reply With Quote
Old 11-03-2011, 01:46 PM   #4
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
I can hear the pump working trying to.raise the vehicle. !??
Benziechicago is offline   Reply With Quote
Old 11-03-2011, 08:00 PM   #5
Member
 
Join Date: Jul 2010
Location: Miami Florida
Posts: 78
Drives: S500
The pump might attempt to raise the vehicle although it does not have the potential to do so. Also wmhave you noticed your car when you turn it off and while exiting the car a hissing out like psssshhhh like if the air has been released, loudrr than normal?
envymesukas is offline   Reply With Quote
Old 11-03-2011, 10:17 PM   #6
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
Well I dont know I dont usually listen to it as I have been the couple of days.. I would say it might be louder .. When I unlock the car I hear the pump trying to work though. This problem started after playing w the button when I was on the freeway driving from ny to ill .. im wondering if it was my right shock would the left side be low also!?? Cause left side was replaced less than a yr ago & righ might be blown.. But would one side being damaged affect both of them on the front end!???
Benziechicago is offline   Reply With Quote
Old 11-03-2011, 11:33 PM   #7
Member
 
Join Date: Jul 2010
Location: Miami Florida
Posts: 78
Drives: S500
If the entire vehicle is dropped it has nothing to do with your strut leaking. The vehicle had the pressure to keep the vehicle leveled, Once he put it into sport mode the vehicle drops therefor the vehicle is not rising because the pump is not working so therefor your vehicle is not rising to its level.
envymesukas is offline   Reply With Quote
Old 11-04-2011, 02:42 AM   #8
MBWorld Fanatic!
 
vdubpower's Avatar
 
Join Date: Dec 2003
Location: OC
Posts: 4,662
Drives: i drive them all, fast and hard
visit the dealer and bring 2000$
__________________

1985 500SEL Euro Nautic Blue - A Classic Beauty
2012 E63 AMG Iridium Silver - Performance Package


vdubpower is online now   Reply With Quote
Old 11-04-2011, 03:03 AM   #9
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
Will never go to the dealer those ppl are crooks!! Last time I took my car for ac problem they said I.need a new compressor, turns out it was electrical. @envy- is there a way to check the pump
Benziechicago is offline   Reply With Quote
Old 11-04-2011, 10:04 AM   #10
Member
 
Join Date: Jul 2010
Location: Miami Florida
Posts: 78
Drives: S500
No, you will need to take it to a Benz specialist I am 99% sure that is your problem. Do not drive your vehicle much if you hit a pot hole you will cause a nasty fender damage.
envymesukas is offline   Reply With Quote
Old 11-04-2011, 06:46 PM   #11
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
Went to the shop had the shock put in and its fixed! The right shock was so bad it wouldnt let the left one up either. Thank god I had the shock in hand. thanks for ur help
Benziechicago is offline   Reply With Quote
Old 11-05-2011, 12:58 AM   #12
Member
 
Join Date: Jul 2010
Location: Miami Florida
Posts: 78
Drives: S500
I am glad to hear!!!, So just the front was dropped after all.. Lol not the entire car
envymesukas is offline   Reply With Quote
Old 11-05-2011, 04:51 PM   #13
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
Yea the front end but now my baby is all good ! I was pretty happy it was a quick fix.
Benziechicago is offline   Reply With Quote
Old 11-07-2011, 08:37 AM   #14
Junior Member
 
Join Date: Oct 2008
Location: Minneapolis, St. Paul, MN
Posts: 41
Drives: 2000 S500(Sold); 2008 E350 4Matic; 2007 ML350 4Matic
Quote:
Originally Posted by Benziechicago View Post
Yea the front end but now my baby is all good ! I was pretty happy it was a quick fix.
Did you replace both shocks or just one side? You mind to tell us how much did it cost you? Thanks.
__________________
2000, S500(SOLD)
2008, E350, 4MATIC
2007, ML350 4MATIC
klvaleri is offline   Reply With Quote
Old 11-07-2011, 07:23 PM   #15
Newbie
 
Join Date: Nov 2011
Posts: 14
Drives: S430
Only replaced the right side, but both were down since the right shock was blown it wasnt letting the left side up either. I bought two shocks via ebay almost a year ago at 400each. Labor to put it in was 150. Good luck
Benziechicago is offline   Reply With Quote
Old 01-15-2012, 10:15 PM   #16
Junior Member
 
ghostwatcherz's Avatar
 
Join Date: Oct 2010
Location: Florida
Posts: 31
Drives: 01 S500
robingreeve
I have a 2001 S500 with Airmatic. I noticed about a week ago, when I get out of the car, after shutting it off, I can hear a "pissing" sound of air being released. I got back in the car, started it and hit the airmatic button to raise the car, and it raised it fine. It levelled and worked fine. Today, driving home on the highway, i hit a bump and heard the rear tire HIT the inside fender wall... It got worse, then eventually all 4 tires were up to the fenders. I was driving ON the wheels. I pulled over and called AAA. They towed the car and will be trying to fix tomorrow. I tried the airmatic button, and nothing works. It says it is "rising" but obviously it does.t All 4 sides are ON the tires completely. IDEAS? I figure it cant be the entire system as ALL 4 sides are evenly on the ground. Could it be a fuse, relay or pump, and how do I narrow it down?
__________________
Living life in the sunshine state
ghostwatcherz is offline   Reply With Quote
Old 01-16-2012, 06:27 AM   #17
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 2,072
Drives: Mercedes
probably an air leak in a hose or the compressor
tusabes is offline   Reply With Quote
Old 01-16-2012, 08:40 PM   #18
Super Member
 
DL_AMG's Avatar
 
Join Date: Aug 2002
Location: SoCal - SaMo & West SFV
Posts: 554
Drives: 2011 C63, 2004 S500, 2013 E350, 2013 Ody Elite
Send a message via AIM to DL_AMG
If instant dropped on the tire on all 4 wheels, sounds like major leak in a hose or pump blowup. You should got Airmatic error on your dash with car logo and a arrow pointing up or car is too low error in RED.
I just had my airmatic fixed today for $385. The airmatic arrow pointing up error shown up about 3 weeks ago and I was like who care coz the car seem to in the right high. Well, it slowly lower until last week that it just look too low. So I bring the car in this morning to my local MB specialist. While driving to fix, on one up hill, the RED car too low warning pop up but after the car on flat, the warning disappear.
My specialist said my pump is fine but just not pumping and he fixed with old parts and also replace the relay and blown fuse. 3 hrs of labor and parts, $385. My 2004 S500 is back to aerobed.
__________________
MY2011 C63 AMG
MY2004 S500
MY2013 E350 Luxury
MY2013 Odyssey Touring Elite
--------------------------------------------------
OUT:2012 C250, 2001 C320, 2007 E350, 2010 R350, 2003 C32 AMG, 1987 300E
DL_AMG is offline   Reply With Quote
Old 01-16-2012, 10:29 PM   #19
Junior Member
 
ghostwatcherz's Avatar
 
Join Date: Oct 2010
Location: Florida
Posts: 31
Drives: 01 S500
robingreeve
I had the car checked today by local guy. He said the Fuse was good and the relay seemed fine. The module under the hood on drivers side is getting power, but nothing coming out of it. Maybe the module itself is dead? He pointed to my drivers side, under the hood, up near the windshield to a silver box, under a black cover with a million wires going in to it. I assume thats the module that controls the Airmatic? I also heard their may be a recall on this system, but haven't had time to contact MB. Anyone else heard of a recall??
__________________
Living life in the sunshine state
ghostwatcherz is offline   Reply With Quote
Old 01-17-2012, 03:07 PM   #20
Junior Member
 
ghostwatcherz's Avatar
 
Join Date: Oct 2010
Location: Florida
Posts: 31
Drives: 01 S500
robingreeve
OK, here is the new update: The benz IS getting power to the Module (Silver box up near drivers dash under the windshield). We checked the fuses and they are all good. We also, per another member, switched the "O" relay with the "F" relay under the hood to test and nothing. The car sits on its tires. I started the car, pushed the Airmatic button, nothing. No clicks, no noise, no pump, nothing. To me this sounds like electrical problem somewhere. If it was the pump, wouldnt you hear noises or it starting or trying to pump?
We are going to have the car towed to a shop so they can scan it with mercedes tools. I was trying to self diag so I could avoid big labor charges if it was a fuse or something.

Ideas?
__________________
Living life in the sunshine state
ghostwatcherz is offline   Reply With Quote
Old 01-18-2012, 08:11 PM   #21
Senior Member
 
cool_lagoon's Avatar
 
Join Date: Jun 2004
Location: LI, NY
Posts: 375
Drives: (1960) 300d, S550 AMG S500 S600 560SEL
chicago did you retain the old shocks which were replaced? Those shocks are repairable with a repair kit available to us authorized resale and service shop and it can only cost a fraction of the whole shocks price, i presume yours is a pneumatic system?
__________________
cool_lagoon is offline   Reply With Quote
Old 02-03-2012, 05:04 PM   #22
Junior Member
 
ghostwatcherz's Avatar
 
Join Date: Oct 2010
Location: Florida
Posts: 31
Drives: 01 S500
robingreeve
Ok, so now that my car was on the ground, really, sitting on all 4 wheel wells, they installed a new pump and new 40amp fuse. Now the rear of the car is off the ground. They are telling me the front passenger needs a new strut, since the original exploded. $1855. Now, they also said It is an ABC strut, but I know I have Airmatic. Is it possible to have an Airmatic AND ABC, I thought it was one or the other??
__________________
Living life in the sunshine state
ghostwatcherz is offline   Reply With Quote
Old 02-03-2012, 06:01 PM   #23
Senior Member
 
cool_lagoon's Avatar
 
Join Date: Jun 2004
Location: LI, NY
Posts: 375
Drives: (1960) 300d, S550 AMG S500 S600 560SEL
Quote:
Originally Posted by ghostwatcherz View Post
Ok, so now that my car was on the ground, really, sitting on all 4 wheel wells, they installed a new pump and new 40amp fuse. Now the rear of the car is off the ground. They are telling me the front passenger needs a new strut, since the original exploded. $1855. Now, they also said It is an ABC strut, but I know I have Airmatic. Is it possible to have an Airmatic AND ABC, I thought it was one or the other??
take a picture of the front strut from the top (open hooed and picture the left and rights side close to the fire wall and the fender and we'll help you identify your suspension strut and post it.
__________________
cool_lagoon is offline   Reply With Quote
Old 02-03-2012, 06:11 PM   #24
Junior Member
 
ghostwatcherz's Avatar
 
Join Date: Oct 2010
Location: Florida
Posts: 31
Drives: 01 S500
robingreeve
Crap, dont have access. its at a dealer (not Mercedes, but a Euro place). I dont have direct access. How can I tell if I have ABC from interior controls? I know I have the airmatic button that raises the car automatically and I know I have another button next to it to adjust the sway stiffness during turns. Looks like this -> (I) and it has 2 lights on it.
__________________
Living life in the sunshine state
ghostwatcherz is offline   Reply With Quote
Old 02-03-2012, 06:22 PM   #25
Senior Member
 
cool_lagoon's Avatar
 
Join Date: Jun 2004
Location: LI, NY
Posts: 375
Drives: (1960) 300d, S550 AMG S500 S600 560SEL
Quote:
Originally Posted by ghostwatcherz View Post
Crap, dont have access. its at a dealer (not Mercedes, but a Euro place). I dont have direct access. How can I tell if I have ABC from interior controls? I know I have the airmatic button that raises the car automatically and I know I have another button next to it to adjust the sway stiffness during turns. Looks like this -> (I) and it has 2 lights on it.
i don't guess and won't be able to help you unless you show some picture, don't want you to get confuse either.
__________________
cool_lagoon is offline   Reply With Quote
Old 02-03-2012, 06:22 PM
 
 
 
Reply

Tags
airmatic, benz, button, car, drive, end, front, low, mbworld, mercedes, passed, s430, sits, tires, w220



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 08:57 PM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details

SEO by vBSEO 3.5.2