Go Back   MBWorld.org Forums > Mercedes-Benz SLR & SL Roadsters > SL-Class (R129)
Sign in using an external account
Register Forgot Password?

SL-Class (R129) 1990-2002: SL 280, SL 300, SL 320, SL 500, SL 600, SL 60 AMG

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 11-13-2012, 05:03 AM   #1
Newbie
 
Join Date: Feb 2010
Posts: 11
Drives: 1991 Mercedes Benz 500SL
1991 SL500 ASR/ABS Light problem

My car has just returned from a service and these lights will come on 5 secs after the vehicle starts moving.After reading several possible causes on the forum on this problem I carried out an inspection on the following as advised:
Checked the sensors on the front wheels and cleaned them.
The brake lights come on when peddal depressed so I don't think it is the brake switch .
My speed control works.
I have tried the turning of the steering left and right trick.
I have charged the battery.
I have disconnected the battery hoping the fault will reset itself.
I don't have a code reader to check code faults.
Are there any other possible causes for this problem.
With the lights on everything seems to work.
Any assistance would be greatly appreciated
To remove this ad, register today or login if you already are registered!

vivijiv is offline   Reply With Quote
Old 12-16-2012, 01:26 AM   #2
Newbie
 
Join Date: Feb 2010
Posts: 11
Drives: 1991 Mercedes Benz 500SL
Quote:
Originally Posted by vivijiv View Post
My car has just returned from a service and these lights will come on 5 secs after the vehicle starts moving.After reading several possible causes on the forum on this problem I carried out an inspection on the following as advised:
Checked the sensors on the front wheels and cleaned them.
The brake lights come on when peddal depressed so I don't think it is the brake switch .
My speed control works.
I have tried the turning of the steering left and right trick.
I have charged the battery.
I have disconnected the battery hoping the fault will reset itself.
I don't have a code reader to check code faults.
Are there any other possible causes for this problem.
With the lights on everything seems to work.
Any assistance would be greatly appreciated
I have a further developement on the above problem.All of a sudden the lights for no reason do not come on when driving as before,but now my brakes are behaving strange in that when NORMALLY applying they shudder as if the ABS is coming in when not required.
Is there a reason for this .can anybody offer some guidance it would be greatly appreciated
vivijiv is offline   Reply With Quote
Old 12-16-2012, 01:26 AM
 
 
 
Reply

Tags
1991, 500, 500sl, 91, abs, asr, light, mercedes, problems, r129, recall, sl, sl500, speed, top



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 12:13 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details

SEO by vBSEO 3.5.2