Why would the "High Mount Brake Light" be replaced... twice? - MBWorld.org Forums

Log In 


SL-Class (R230) 2003 -- 2012: Discussion on the SL500, SL550, SL600

Why would the "High Mount Brake Light" be replaced... twice?

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 04-01-2010, 03:24 AM   #1
Newbie
Thread Starter
 
Join Date: Mar 2010
Posts: 6
Drives: Looking for a White SL55 or SL600
Thanks: 0
Thanked 0 Times in 0 Posts
Why would the "High Mount Brake Light" be replaced... twice?

You guys are a wealth of knowledge and I was hoping someone could shed some light on why a car would have the "High Mount Brake Light Assembly" replaced twice in two years? It's a 2004 SL600 with 20,000 miles. Everything else on the car looks perfect and the carfax is clean (one with all maintenance done by selling dealer), but why does this part need to be replaced so often? Is this common?

The dealer did a SDS "Short Test" and replaced the batteries at the same time too. ???

Any thoughts are much appreciated.
C O D Y is offline   Reply With Quote
Old 04-01-2010, 11:33 AM   #2
Super Member
 
VendettaMB's Avatar
 
Join Date: May 2009
Location: In a VAN down by the river
Posts: 644
Drives: His wifes head hard into the headboard nightly!!
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by C O D Y View Post
You guys are a wealth of knowledge and I was hoping someone could shed some light on why a car would have the "High Mount Brake Light Assembly" replaced twice in two years? It's a 2004 SL600 with 20,000 miles. Everything else on the car looks perfect and the carfax is clean (one with all maintenance done by selling dealer), but why does this part need to be replaced so often? Is this common?

The dealer did a SDS "Short Test" and replaced the batteries at the same time too. ???

Any thoughts are much appreciated.
leaky seal for some reason..they might have discovered it by a fried rear $AM or other CO$TLY issues that are cause by water getting into through rear 3rd brake light
VendettaMB is offline   Reply With Quote
Old 04-01-2010, 04:55 PM   #3
Senior Member
 
Television's Avatar
 
Join Date: Oct 2006
Location: Southcoast England
Posts: 379
Drives: CL500 216
Thanks: 0
Thanked 0 Times in 0 Posts
Maybe there was water in it, or a group of LEDs was out
Television is offline   Reply With Quote
Old 04-01-2010, 04:58 PM   #4
Newbie
Thread Starter
 
Join Date: Mar 2010
Posts: 6
Drives: Looking for a White SL55 or SL600
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks!
C O D Y is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New supercharged toy, pics inside dllhg W211 AMG 17 09-09-2015 02:35 PM
Engine mount question caperss S-Class (W221) 2 09-08-2015 08:12 PM
DIY Notes - Front and Rear Brake Pad and Rotor replacement, Brake Fluid Bleed, Flush DFac Boy C32 AMG, C55 AMG (W203) 1 09-07-2015 04:32 AM
4000 km owner report - likes/dislikes thunderMB AMG GT/GTS 4 09-05-2015 12:10 PM
FS: 2005 E320 4matic Estate marc hanna Mercedes Vehicles 0 09-02-2015 08:16 AM


Tags
2003, 3rd, 500sl, assemly, brake, car, guys, high, lens, light, lights, mercedes, replacement, sl55, upper


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 06:20 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.