Go Back   MBWorld.org Forums > Mercedes-Benz AMG Vehicles > SL55 AMG, SL63 AMG, SL65 AMG (R230)
Sign in using an external account
Register Forgot Password?


SL55 AMG, SL63 AMG, SL65 AMG (R230) Discuss the SL55, SL63 and SL65 AMG.

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 07-14-2009, 12:01 AM   #1
Senior Member
 
G_KATS's Avatar
 
Join Date: Jun 2007
Location: Toronto Ontario Canada
Posts: 356
Drives: SL 55 AMG
MY SHIFTER GETS STUCK IN PARK SOMETIMES

Is this bad ? theres days where its fine and then theres days where i have to shake it too bring it down too Drive .
To remove this ad, register today or login if you already are registered!

G_KATS is offline   Reply With Quote
Old 07-14-2009, 08:59 AM   #2
MBWorld Fanatic!
 
rsr911's Avatar
 
Join Date: Dec 2005
Location: Indiana
Posts: 1,222
Drives: 2003 AMG SL55, 2002 AMG CLK55, 2005 ML350, 1995 S320 LWB - totaled
Sounds like the switch for the break pedal is failing. This switch tells the shifter it is safe to move from park to drive.
__________________
2003 AMG SL55
2002 AMG CLK55
2005 ML350
1995 E320 wagon
AMG Orphans Club International member #5
Mercedes Benz Owner's Gun Club, Member #26
1995 S320 LWB (totaled 5/25/09)
2003 C240 4matic (sold)
1986 Porsche 911 (sold)
2002 Subaru WRX (track car) (sold)
1999 230 SLK (sold)
1973 450 SL (sold)
1973 450SLC (sold)
"Time is too precious to keep it on an inexpensive watch"
rsr911 is offline   Reply With Quote
Old 07-14-2009, 09:08 AM   #3
Senior Member
 
OUTCAST's Avatar
 
Join Date: May 2008
Location: Oklahoma
Posts: 411
Drives: SLK55AMG, SL600
Mine did the same thing so I took it to the MB dealer. They had to replace the whole shifting assembly.
__________________

Capo regime Interior Highlands (member #13)
OUTCAST is offline   Reply With Quote
Old 07-14-2009, 09:33 AM   #4
Senior Member
 
BeltFedBob's Avatar
 
Join Date: Oct 2006
Location: Mukilteo in summer, Fountain Hills during the rainy season in Wa.
Posts: 375
Drives: 2008 Maserati QP EGT, 2005 SL55AMG , 2002 CLK55AMG 2002 C230K Coupe
Try pushing a little harder on the brake when moving the shifter from park to drive.
BeltFedBob is offline   Reply With Quote
Old 07-14-2009, 02:24 PM   #5
Senior Member
 
G_KATS's Avatar
 
Join Date: Jun 2007
Location: Toronto Ontario Canada
Posts: 356
Drives: SL 55 AMG
Quote:
Originally Posted by OUTCAST View Post
Mine did the same thing so I took it to the MB dealer. They had to replace the whole shifting assembly.
wow!! wat did that cost you ?
G_KATS is offline   Reply With Quote
Old 07-14-2009, 07:46 PM   #6
Member
 
Join Date: Aug 2008
Location: Plano, TX
Posts: 220
Drives: AMG
Reminds me of the time when I was trying to go from drive to park and it wouldn't do it.. until I realized by cell phone was in the way

could be a major transmission problem or a simple brake switch fix
__________________


Vimeo
sikhkd is offline   Reply With Quote
Old 07-14-2009, 10:19 PM   #7
Newbie
 
Join Date: Jul 2009
Location: Tallinn, Estonia
Posts: 9
Drives: SL55 SL600 BMW850
Hi, my 03 sl55 had the same problem 2 years ago.
Shifter would not move from P, stroking brakes repeatedly usually helped and I always got the shifter to move, even if sometimes it took a minute or so. Then one day it just would not move, after 15 minutes of vigourous stroking I called a tow truck, friend of mine at Tallinn MB dealership sorted it out in less than an hour.. it was the switch at break.
Cost was minimal, they cleaned the switch since there was no replacement in stock, guy told me to come back and replace the switch if this was to happen again. It has been 2 summers now, everything is fine, never replaced the switch.
valgehiir is offline   Reply With Quote
Old 07-14-2009, 11:12 PM   #8
MBWorld Fanatic!
 
DAGREEKNYC's Avatar
 
Join Date: Mar 2008
Location: ny
Posts: 1,169
Drives: 2013 S350 Bluetec
MY OLD 2004 CLK AND E430 DID THE SAME .I REALIZED AFTERWARDS EVER TIME I GOT THE CAR FULLY DETAILED IT WOULD HAPPEN . WATER WOULD GET INTO A MODULE AND SHORT IT OUT .
DAGREEKNYC is offline   Reply With Quote
Old 07-15-2009, 12:45 AM   #9
Senior Member
 
G_KATS's Avatar
 
Join Date: Jun 2007
Location: Toronto Ontario Canada
Posts: 356
Drives: SL 55 AMG
Quote:
Originally Posted by valgehiir View Post
Hi, my 03 sl55 had the same problem 2 years ago.
Shifter would not move from P, stroking brakes repeatedly usually helped and I always got the shifter to move, even if sometimes it took a minute or so. Then one day it just would not move, after 15 minutes of vigourous stroking I called a tow truck, friend of mine at Tallinn MB dealership sorted it out in less than an hour.. it was the switch at break.
Cost was minimal, they cleaned the switch since there was no replacement in stock, guy told me to come back and replace the switch if this was to happen again. It has been 2 summers now, everything is fine, never replaced the switch.

where is the break switch located ???
G_KATS is offline   Reply With Quote
Old 07-15-2009, 01:10 AM   #10
Newbie
 
Join Date: Jul 2009
Location: Tallinn, Estonia
Posts: 9
Drives: SL55 SL600 BMW850
Sadly, I do not know. I do know where the gear shifter is located, if that would be of any help!

Thank you!
valgehiir is offline   Reply With Quote
Old 07-15-2009, 09:58 AM   #11
Super Member
 
TopEndS62's Avatar
 
Join Date: Jul 2008
Location: Brooklyn, NY/Tampa, FL
Posts: 829
Drives: 2005 BLK/BLK E-Double Nickel.
Quote:
Originally Posted by G_KATS View Post
where is the break switch located ???

I would think it should be under the brake pedal.. i could be wrong
__________________
<a href="http://s591.photobucket.com/albums/ss353/1sicm5/2005%20Mercedes%20Benz%20E55%20AMG/?action=view&current=e33twinkies.jpg" target="_blank"><img src="http://i591.photobucket.com/albums/ss353/1sicm5/2005%20Mercedes%20Benz%20E55%20AMG/e33twinkies.jpg" border="0" alt="Photobucket"></a>

2005 M. BENZ E55 AMG(Lifetime labor warranty(ME))
2006 M. BENZ R500 Saks 5TH AVE EDITION
A BUNCH OF BMWs(SOLD)
Alot of ACURAS(SOLD)
TopEndS62 is offline   Reply With Quote
Old 07-15-2009, 01:32 PM   #12
Senior Member
 
Join Date: Sep 2008
Location: Rocklin, CA
Posts: 431
Drives: 2003 SL55, 2006 CLK500, 1998 Vette
I had the same thing happen to me but with me I waited until the last minute and the car finally give out and would not shift out of park at all. This happened at the grocery store. I had the car towed to MB and they ended replacing the entire shifter. I had warranty but parts and labor were about $700 or so.

They told me it is a silonoid switch in the shifter that is due to a bad design of the shifter which does release when it senses the parking brake pressed. It stopped working. They also said the new shifter would eventually have the same problem in about 5-7 years which is rediculous to me. According to the dealer the design was not chnaged on the new shifter assembly at all.
mig1980 is offline   Reply With Quote
Old 07-15-2009, 04:21 PM   #13
Senior Member
 
OUTCAST's Avatar
 
Join Date: May 2008
Location: Oklahoma
Posts: 411
Drives: SLK55AMG, SL600
Quote:
Originally Posted by G_KATS View Post
wow!! wat did that cost you ?

I will look at the paperwork when I get home from work. I have all the paperwork for anything that is done or I buy for the car.
__________________

Capo regime Interior Highlands (member #13)
OUTCAST is offline   Reply With Quote
Old 07-15-2009, 10:04 PM   #14
Super Member
 
Join Date: Sep 2008
Location: Puerto Rico
Posts: 730
Drives: 2005 SL55 AMG, 1986 Porsche 930S, 1996 Porsche 993tt
Quote:
Originally Posted by TopEndS62 View Post
I would think it should be under the brake pedal.. i could be wrong

Yes is under the brake pedal. The switch is cheap.
__________________
2005 SL55 AMG
Powerchip Group, K&N filters, PTE thermostat, BBS CH-R, Reus Audio
Rick SL55 is offline   Reply With Quote
Old 07-16-2009, 04:02 AM   #15
Senior Member
 
G_KATS's Avatar
 
Join Date: Jun 2007
Location: Toronto Ontario Canada
Posts: 356
Drives: SL 55 AMG
well just now i was playing with the break pedal and shifter and i can hear a sound everytime i press the break .... like a clicking sound, CLICK!!! it works .... i press the break again, CLICK!!! it works again ..... then i push the break again NO CLICK ... doesnt move . till i hear the CLICK! thats when it always works ...

Also i notice when i hold the shifter more too the right and dont let it sit towards the left side of the track, it works PERFECT. the minute i let it sit on the left side in PARK the shifter then has problems clicking . I kinda figured out how to make it always work .. but im scared if i do take this benz for a long distance trip and it doesnt work. then im screwed ... ugh!!!

this is my 1st real problem since buying the car lastyear .
G_KATS is offline   Reply With Quote
Old 07-16-2009, 07:59 AM   #16
Super Member
 
TopEndS62's Avatar
 
Join Date: Jul 2008
Location: Brooklyn, NY/Tampa, FL
Posts: 829
Drives: 2005 BLK/BLK E-Double Nickel.
Quote:
Originally Posted by G_KATS View Post
but im scared if i do take this benz for a long distance trip and it doesnt work. then im screwed ... ugh!!!

this is my 1st real problem since buying the car lastyear .

Yeah I would feel the same exact way!!! Go get it checked out maybe by a independent mercedes tech in your area. This has also happened to my boy with a sl55 in his case they changed the whole shifter assembly. It seems 50/50 on the switch and 50/50 on the assembly. whatever it is, you should deal with it asap, you would hate for an emergency situation to occur and you can't make moves... good luck with it.....`
__________________
<a href="http://s591.photobucket.com/albums/ss353/1sicm5/2005%20Mercedes%20Benz%20E55%20AMG/?action=view&current=e33twinkies.jpg" target="_blank"><img src="http://i591.photobucket.com/albums/ss353/1sicm5/2005%20Mercedes%20Benz%20E55%20AMG/e33twinkies.jpg" border="0" alt="Photobucket"></a>

2005 M. BENZ E55 AMG(Lifetime labor warranty(ME))
2006 M. BENZ R500 Saks 5TH AVE EDITION
A BUNCH OF BMWs(SOLD)
Alot of ACURAS(SOLD)
TopEndS62 is offline   Reply With Quote
Old 07-20-2009, 06:24 PM   #17
Senior Member
 
G_KATS's Avatar
 
Join Date: Jun 2007
Location: Toronto Ontario Canada
Posts: 356
Drives: SL 55 AMG
so i went in too see wat was wrong..... they hooked my car up too a computer and it said my shifter box was shot . so now i have to replace my whole shifter. its gonna cost me 1200 .
G_KATS is offline   Reply With Quote
Old 07-21-2009, 08:40 AM   #18
Super Member
 
TopEndS62's Avatar
 
Join Date: Jul 2008
Location: Brooklyn, NY/Tampa, FL
Posts: 829
Drives: 2005 BLK/BLK E-Double Nickel.
Quote:
Originally Posted by G_KATS View Post
so i went in too see wat was wrong..... they hooked my car up too a computer and it said my shifter box was shot . so now i have to replace my whole shifter. its gonna cost me 1200 .
ouch!!! is that parts and labor???
__________________
<a href="http://s591.photobucket.com/albums/ss353/1sicm5/2005%20Mercedes%20Benz%20E55%20AMG/?action=view&current=e33twinkies.jpg" target="_blank"><img src="http://i591.photobucket.com/albums/ss353/1sicm5/2005%20Mercedes%20Benz%20E55%20AMG/e33twinkies.jpg" border="0" alt="Photobucket"></a>

2005 M. BENZ E55 AMG(Lifetime labor warranty(ME))
2006 M. BENZ R500 Saks 5TH AVE EDITION
A BUNCH OF BMWs(SOLD)
Alot of ACURAS(SOLD)
TopEndS62 is offline   Reply With Quote
Old 07-21-2009, 04:37 PM   #19
Senior Member
 
G_KATS's Avatar
 
Join Date: Jun 2007
Location: Toronto Ontario Canada
Posts: 356
Drives: SL 55 AMG
ya all together ..... tommorow i get the car and next week i pick up my new rims .
G_KATS is offline   Reply With Quote
Old 07-31-2009, 07:51 PM   #20
Newbie
 
Join Date: Jul 2009
Location: NH
Posts: 14
Drives: SL55 amg
shifty

Yeah, I had an SL500 before I had my SL55, same issue. Plastic ring on inside of shifter broke.....wouldn't happen if they put a better one there,

$10 part....$561 labor...


My SL55 has a warranty to prevent such random issues now
NHSL55 is offline   Reply With Quote
Old 08-01-2009, 03:28 AM   #21
Junior Member
 
roberthechter's Avatar
 
Join Date: Feb 2009
Location: Las Vegas, Nevada
Posts: 23
Drives: 2006 SL55 AMG
Just push on the brake pedal first, before you try to move the shifter
roberthechter is offline   Reply With Quote
Old 11-04-2009, 05:04 PM   #22
Junior Member
 
MrStyle25's Avatar
 
Join Date: Sep 2009
Location: U S A
Posts: 48
Drives: CL55 AMG
SoulTaker
My CL55 AMG is in the Dealership right now, they called back and said it was the Shifter Assembly and it needs to be replaced. Approximately $1,100.00, they are calling my warranty company now, it should be a covered component. I've had the car a month and day and it's been in the shop every week for something. last time was 1,000 in labor, $80 for 6 parts, including belt. Their labor is ridiculous. Since they didn't know how to install my bluetooth module I am nervouse they are just replacing parts versus making a real diagnosis. I hope there are no loopholes in my extended warranty, they ahve got to hate they sold me one!
__________________
_____________________
Zoom Zoom!!
MrStyle25 is offline   Reply With Quote
Old 06-16-2010, 12:08 AM   #23
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,101
Drives: 2012 C250 Coupe
jctevere
I am having the same problem on my r230 SL500 right now. Takes me like 20 tries to get it out of park. I hear that it could be the solenoid in the shifter, the plastic piece that breaks, or the brake pedal switch. Why would the car have 2 things to tell the brake is depressed. If it was the brake pedal switch this would mean that the taillights would not go on, correct? If it was the solenoid, the brake lights would go on, but the car shifter will still not shift out of park? I will diagnose the problem later.

However, does anyone have a DIY or pictures for replacing either? Thanks so much!
jctevere is offline   Reply With Quote
Old 06-17-2010, 08:42 AM   #24
Junior Member
 
nylefty31's Avatar
 
Join Date: Sep 2009
Location: new york
Posts: 62
Drives: 2004 sl500
Just picked my sl up yesterday from mb service. I was having the same problem where it kept getting stuck in park until one night when out to dinner it totaly locked and would not come out no matter what i tried(pushing brake harder,hammer,etc. So what I did was order the plastic gear select lever and attempted to replace it myself. The problem is the car needs to be in neutral to remove the console, So i cut the stem of the shifter with plans to have it welded. Once the console was removed you need to remove 3 screws holding the shifter, that are in awkward positions. I ended up stripping one, by then i was fed up and sent it to MB. I have a hook there where i was charged $500 for a whole new shifter and installation since MB does not change the plastic piece inside. I would definitly address the problem asap before it locks in park and not only will the shifter be stuck but you as well. Good luck
nylefty31 is offline   Reply With Quote
Old 06-17-2010, 10:31 AM   #25
Member
 
damian155's Avatar
 
Join Date: Jul 2004
Location: Jersey
Posts: 249
Drives: SL55
Quote:
Originally Posted by G_KATS View Post
Is this bad ? theres days where its fine and then theres days where i have to shake it too bring it down too Drive .
decided not to sell your 55?
damian155 is offline   Reply With Quote
Old 06-17-2010, 10:31 AM
 
 
 
Reply

Tags
2006, 55, amg, automatic, benz, bmw, car, charger, dodge, mercedes, park, shift, shifter, sl55, stuck, transmission



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 07:58 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details