Go Back   MBWorld.org Forums > Mercedes-Benz SLR & SL Roadsters > SLK-Class (R171)
Sign in using an external account
Register Forgot Password?

SLK-Class (R171) 2004-2010: SLK200K, SLK280, SLK350, SLK55, SLK55 Black Series

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 06-09-2005, 03:26 PM   #1
Member
 
Join Date: Feb 2005
Location: San Francisco, CA
Posts: 158
Drives: 06' CLS 500
SLK Electrical Problems

Wanted to know if my fellow SLK owners have been having any electrical problems with their cars as of late. So far I have taken in my car to have the SRS checked since the light came on and found out that my cigarette lighter does not work. Yesterday, I tried to plug in my cellular phone charger and the light wouldn't come on so I proceeded to push the cigarette lighter in, but to no power. Anyone experience similar problems? Thanks and have a great day.
To remove this ad, register today or login if you already are registered!

MASA is offline   Reply With Quote
Old 06-09-2005, 07:56 PM   #2
Newbie
 
Join Date: Apr 2005
Posts: 8
Only electrical problem I have had was with Tele-Aid. Took the dealership three times to finally get it right.
StevoDaDevo is offline   Reply With Quote
Old 06-10-2005, 04:27 AM   #3
Super Member
 
Shinigami's Avatar
 
Join Date: Dec 2002
Location: Lausanne, Switzerland
Posts: 761
Drives: SLK 55 AMG
When I brake hard, the cigarette lighter plops in a bit... lol

But no, no electrical problems.
__________________
New car: 2005 SLK 55 AMG
Additional: Chromed door lock pins, K&N Filters, Piecha roof control module

Old car: 1998 SLK 230K, Linarite blue.
Brabus: Front spoiler, side skirts, rear apron, Sports Exhaust, gear shift + hand brake, 17" Monoblock IV rims, hubcaps/wheel locks, Aluminium doorlock pins, polished safety roll bars, Brabus logo.
Digit-Power: +30bhp and +50nm torque.
Additional: Chromed side indicator frames, Chromed DJH SRS badges, Aluminium DJH grill wings, Lorinser Wing.
Shinigami is offline   Reply With Quote
Old 06-22-2005, 02:22 AM   #4
Newbie
 
Phantomenace's Avatar
 
Join Date: Jun 2005
Location: Los Angeles, CA, USA
Posts: 12
Drives: SLK350
If the AC is set on OFF and I push the button again to turn it on, it will not come on until I shut off the fans completely and start again. Gonna show my technician at my free 1k-3k mile check up.
Phantomenace is offline   Reply With Quote
Old 06-22-2005, 02:58 AM   #5
Member
 
Join Date: Mar 2005
Posts: 125
My cruise control does not work at all.
__________________
06 SLK 350 Metallic Black/ Black Auto, AMG PKG, Premium PKG, Heat PKG, Xenon's, Alloy Hood Fins,Rear Spoiler, Chrome Nose Wings, 3M Chip Protect on all forward facing areas. MB replaced my 05' "oil burner"- Not easy or a good first experience with MB. Love the car and my last was a Z06.
redvettx2 is offline   Reply With Quote
Old 06-23-2005, 04:46 PM   #6
Newbie
 
Join Date: May 2005
Location: Miami
Posts: 12
Drives: SLK350 LE
My SLK350 4400 miles has been to shop 2 x this week. ESP Malfunction.

9 Steering sensors later, still messed up!

LEMON LAW soon
__________________
Cheers,
Sergioinmiami
'05 SLK350 LE
sergioinmiami is offline   Reply With Quote
Old 06-23-2005, 07:24 PM   #7
Member
 
Join Date: Feb 2005
Location: canada
Posts: 107
Quote:
Originally Posted by MASA
Wanted to know if my fellow SLK owners have been having any electrical problems with their cars as of late. So far I have taken in my car to have the SRS checked since the light came on and found out that my cigarette lighter does not work. Yesterday, I tried to plug in my cellular phone charger and the light wouldn't come on so I proceeded to push the cigarette lighter in, but to no power. Anyone experience similar problems? Thanks and have a great day.
i have posted somewhere (i think in the slk55 forum) that my srs malfunction warning came on and have been to the dealer since to have it repaired. took two trips as they had to order a part.
__________________
'05 slk55 with: plexiglass wind screen; sealed paint; 3-m protection;aluminium lock pins, chrome front grill inserts, short antenna, 20's all around; '69 280 sl (original)
blkslk55 is offline   Reply With Quote
Old 07-27-2005, 04:08 PM   #8
Member
 
Join Date: Nov 2004
Location: NY Long Island
Posts: 77
Drives: 2010 E 550 Coupe
Other than my outside temp thermostat reading 140F none.
ecb5983 is offline   Reply With Quote
Old 07-27-2005, 04:53 PM   #9
Newbie
 
Join Date: Apr 2005
Posts: 2
Radio Electrical Problems

Only problem i have seen is with my radio... Tuner or CD doesn't matter... power is on, screen is lit, sound... MISSING.... then if I turn it off and on again a few times, randomly it will come back on again. At least it did the first time this happened, we'll see what happens this time!
DJ KJ is offline   Reply With Quote
Old 07-28-2005, 01:53 AM   #10
Almost a Member!
 
Join Date: Mar 2004
Location: Los Angeles, CA
Posts: 58
Drives: '05 SLK350
Send a message via AIM to dwei42 Send a message via MSN to dwei42
esp malfuntion. had to replace part. 1 month later, esp malfunction again...
__________________
2005 MB SLK350 6 speed
2000 BMW 323ci
2001 Yamaha Yzf-R1 (Sold)
2000 Yamaha Yzf-R6 (Sold)
1999 Yamaha Yzf-R6 (RIP)
dwei42 is offline   Reply With Quote
Old 07-29-2005, 12:38 PM   #11
Newbie
 
Join Date: Dec 2004
Location: nyc/bergen county nj
Posts: 5
Drives: slk350
Send a message via AIM to ivy350
my cigarette lighter doesnt pop out, the whole navi/entertainment system shuts off and doesnt come back on till later, check oil level comes on too often and when i take it to dealer they tell me not to fill oil even when its empty cuz it will void warranty even i if i put in manual instructed oil...took it in 3 times already and they supposedly patched up the leak...
check engine light came on 2 days ago..hopefully its gas cap

now my driver side door sounds like its gonna break everytime i open it and close it, and my windows slide down about 4inches after i press the auto up
i got the 350 in dec 04 and just passed 10,000 miles yesterday...so many problems but i still love it~

Last edited by ivy350; 07-29-2005 at 12:41 PM.
ivy350 is offline   Reply With Quote
Old 08-16-2005, 07:31 AM   #12
Almost a Member!
 
Join Date: Apr 2003
Posts: 42
Drives: 2001 SLK320
Got my 350 at the end of March and it now has 2,700 miles on it. Got an ESP malfunction last week. Dealer said it's a bad sensor and is waiting for the part to arrive. Cruise control has stopped working (related issue perhaps?) and yesterday got an SRS malfunction. Quite concerning.

Had a 2001 SLK 320 for 3 years with zero problems....
__________________
05 SLK350 Iridium Silver
dc_320 is offline   Reply With Quote
Old 08-16-2005, 12:14 PM   #13
Newbie
 
Join Date: Jun 2005
Posts: 17
Lightbulb Survey

I don't know if its possible to organize, but it would be nice to take a sort of consumer reports style survey to see what fraction of 171s have what kind of problems.
mhsherman is offline   Reply With Quote
Old 08-16-2005, 01:08 PM   #14
CP1
Member
 
Join Date: Nov 2004
Location: Spring, in the Republic of Texas
Posts: 151
Drives: SLK 55 AMG
I don't think you have a proper sample on this forum.
CP1 is offline   Reply With Quote
Old 08-16-2005, 01:29 PM   #15
Member
 
AC556F's Avatar
 
Join Date: Mar 2004
Location: Scottsdale, AZ
Posts: 151
Drives: '08 SL65
Quote:
Originally Posted by ecb5983
Other than my outside temp thermostat reading 140F none.
Mine reads that... but it's CORRECT!!!
AC556F is offline   Reply With Quote
Old 08-16-2005, 01:40 PM   #16
Almost a Member!
 
Join Date: Jun 2005
Posts: 32
SRS light has come on twice in 3 days. Of course I had to replace the front bumper after the accident and it started after that. Back to the stealer for another round of frustration. I just do not have the time or patience for this kind of stuff. I wonder if there is a way just to turn off the light.
doccyber is offline   Reply With Quote
Old 08-19-2005, 04:40 PM   #17
Almost a Member!
 
Join Date: Apr 2003
Posts: 42
Drives: 2001 SLK320
The bad sensor that was supposed to be in Monday still hasn't shown up. When I was finally able to get through to the service folks they said they were backordered from Mercedes, currently were waiting on 5 of those sensors and have no idea when they will show up...not good.

I'm in Huntsville, Alabama and singularly unimpressed with the level of service from the local dealer. First time I called the phone rang 20 times before I finally gave up. Called a couple of hours later and was told that they had 3 calls waiting for service and took my name and number. Never got a call back...pitiful...
__________________
05 SLK350 Iridium Silver
dc_320 is offline   Reply With Quote
Old 08-22-2005, 11:36 AM   #18
Newbie
 
Join Date: Feb 2005
Posts: 7
In Engine Compartment

Quote:
Originally Posted by ecb5983
Other than my outside temp thermostat reading 140F none.
I had the same problem. Your thermostat has disconnected from its mooring and has fallen into your engine compartment. Dealer should remedy this in no time flat!
flaslk is offline   Reply With Quote
Old 08-26-2005, 09:13 PM   #19
Member
 
Join Date: Sep 2004
Location: Chapel Hill, North Carolina
Posts: 173
Drives: 2005 SLK350
Send a message via Yahoo to wil_sutton
Within two days of picking mine up last September, my SRS light came on. My outside air temp read 140 and my airscarf/heated seats would not work with the top down, but worked perfectly with the top up. All of those problems were PROMPTLY addressed and fixed. Also, the car came with the wrong Navi DVD, but that's not an electrical issue...

Since then, my A/C controls have intermittently stopped working. In other words, every once in a while it will start blowing out warm air when it's 104 outside. My dealer ordered the part to fix that over a month ago, but I just haven't had the time to take it in.

Otherwise, no electrical problems. And once again, I have to emphasize that mine was one of the very first delivered, so a few problems were expected. Further, my dealer has been AWESOME at taking care of every little issue I have.
__________________
Take it easy...
Wil
wil_sutton@yahoo.com

2005 SLK350
2003 Jaguar X-Type
2002 ML430
2000 VW Jetta VR6 (Hopefully Sold. Will Know Wednesday. If not, anybody interested? Great first car for a 16 year old!!!)
wil_sutton is offline   Reply With Quote
Old 08-26-2005, 09:13 PM
 
 
 
Reply

Tags
1998, 2005, 320, 350, bad, control, cruise, electrical, electronic, failure, mercedes, problems, slk, stereo, thermostat, works



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SLK problems hantzis SLK55 (R171) 5 06-04-2005 09:36 PM
Problems with SLK roof FernandoSLK SLK-Class (R170) 4 04-16-2005 10:44 PM
Help Electrical Problems...03 230k Sedan andy28 C-Class (W203) 3 12-18-2004 10:35 AM
SLK Review from carsguide.com (AU) moekuan SLK-Class (R171) 1 12-05-2004 02:43 AM
Ongoing Electrical Problems, anyone else seen this? rleander W211 AMG 3 09-30-2004 02:16 PM



All times are GMT -4. The time now is 06:53 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details