Go Back   MBWorld.org Forums > Mercedes-Benz AMG Vehicles > E55 AMG, E63 AMG (W210, W211, W212) > W210 AMG
Sign in using an external account
Register Forgot Password?


W210 AMG Discuss the W210 AMG's such as the E50, E55, and E60

Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 09-24-2010, 11:44 PM   #1
MBWorld Fanatic!
 
MBFLO's Avatar
 
Join Date: Jan 2010
Location: Detroit
Posts: 1,071
Drives: 01e55blk/blk
Just installed L7 10" and 750.1

Man did it give this piece shyt system what it was missing .. Overall .. After adding the sub and amp wish i woulda gone the full route and swapped out everything but . Im not too picky tho . Got brand new amp<kicker 750.1> and kicker solobaric L7 with box wires and install $700 .. Not bad the jl setup i was lookin at for one speaker and amp was 1300 minus install and wires and adapters so dunno how much better it woulda sounded but im happy for now ..

Installed the bass controller in the ashtray looks nice n flush , ripped out the foam in the two holes under the rear deck and that let alot of bass into the cabin but can also smell the amp when i gets got .. Also roof was rattling when i listened to some bone thug harmony<sorry im old school> so i took out rear dome lights shoved some foam strips , did a little but will reinforce better tomorrow .. They put some stuff between my plate and bracket and no more rattle .. Think i got a good deal for some decent stuff . And my 750.1 birthsheet read 929 watts
To remove this ad, register today or login if you already are registered!

__________________

Last edited by MBFLO; 09-24-2010 at 11:46 PM. Reason: yea
MBFLO is offline   Reply With Quote
Old 09-24-2010, 11:59 PM   #2
MBWorld Fanatic!
 
M-bENZ's Avatar
 
Join Date: Sep 2007
Posts: 7,154
Drives: 04 CLK 320 (Gone) , 01 GS 300 "Plat. Series", 05 CLK500 , 89 EF-Si(Gone) .. 00 DC2 now
Any pics of your setup ?

Andy
__________________
Andy
M-bENZ is offline   Reply With Quote
Old 09-25-2010, 12:21 AM   #3
MBWorld Fanatic!
 
MBFLO's Avatar
 
Join Date: Jan 2010
Location: Detroit
Posts: 1,071
Drives: 01e55blk/blk
will get some tomorrow . wont look anything custom just 10 inch in factory box .
__________________
MBFLO is offline   Reply With Quote
Old 10-08-2010, 01:57 AM   #4
Esh
Super Member
 
Join Date: Apr 2008
Location: Glendale, AZ
Posts: 919
Drives: E55
I'm running an Alpine Type-X 12 with 1159 RMS (birthsheet) Watts to it. I still haven't removed the factory woofers in the back but did replace all the doors.

Congrats on the setup.
Esh is offline   Reply With Quote
Old 11-06-2010, 12:25 AM   #5
Member
 
marroquin38's Avatar
 
Join Date: Oct 2010
Location: Maryland
Posts: 79
Drives: w211
did you ever get pics?
marroquin38 is offline   Reply With Quote
Old 11-06-2010, 07:20 PM   #6
MBWorld Fanatic!
 
MBFLO's Avatar
 
Join Date: Jan 2010
Location: Detroit
Posts: 1,071
Drives: 01e55blk/blk
something like that

i had put one ten inch L7 and didnt know if i was gonna add another or not so this is how it looked right after install . decided to stay with one ten and have since mounted the amp on back of the box and shoved it into the corner . It knocks hard for one ten . 2 would be just right to even it out . Its not a sound quality sub IMO but more of a low boom boom hitting sound but thats what i wanted just a little more bass . At first it sounded ok then ripped out the foam or whatever that was in the holes next to the rear deck subs and made it sound alot better . only drawback is somtimes when knock the shyt out the system the smell of amp kind of lingers into cabin .
Click the image to open in full size.

mounted the bass boost **** where the ashtray used to be , they wanted to mount it right by my knee under the dash but i said nah put it somwhere where it doesnt stick out
Click the image to open in full size.
__________________
MBFLO is offline   Reply With Quote
Old 11-06-2010, 08:03 PM   #7
Senior Member
 
Join Date: Nov 2007
Location: Toronto
Posts: 423
Drives: E55
Yeah, the system in the 55 is weak without an added sub, I got a 12" Mmatts and it knocks good
MR888 is offline   Reply With Quote
Old 11-06-2010, 10:46 PM   #8
Member
 
marroquin38's Avatar
 
Join Date: Oct 2010
Location: Maryland
Posts: 79
Drives: w211
looks good
marroquin38 is offline   Reply With Quote
Old 11-06-2010, 10:46 PM
 
 
 
Reply

Tags
10, 7501, baric, bass, birth, boost, inch, install, kicker, l7, sheet, solo, w, wtb, zx



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 11:33 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details