Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
loose dashboard part causes noise/vibration. (+ back to dealer for multiple issues) >

loose dashboard part causes noise/vibration. (+ back to dealer for multiple issues)

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

loose dashboard part causes noise/vibration. (+ back to dealer for multiple issues)

 
Old 11-29-2008, 02:06 PM
  #1  
MBWorld Fanatic!
Thread Starter
 
Egonvdv's Avatar
 
Join Date: Apr 2008
Location: A Dutchy Living in Marseille, France
Posts: 1,270
Received 116 Likes on 93 Posts
W213 200CDI -Fascination
Question loose dashboard part causes noise/vibration. (+ back to dealer for multiple issues)

I'm going to make an appointment next week to have multiple issues fixed:

- auto gearbox not shifting smoothly when driving at speeds below 60kms.

- wipers/rainsensors working very erratically + no difference between
position 1 (operation with low sensitivity) & 2 (high)

- left wiper (ball bearing?) making a squeeking noise

- wind noise left rear window (2nd visit..)


the latest problem is a loose panel which vibrates (usually when the engine
and or interior is cold).

It's the bottom part of the hood which hangs above the display.
(ie; not the "rubber" top part, but the plastic part)

this part is well fixed on the right side (see red dot on pic)
but on the left side it is SLIGHTLY loose, causing it to vibrate.

Before taking it in, i would like to know if anybody else has/had this problem
and if it's jus a matter of tightening a screw...?



Cheers,
Egon

Last edited by Egonvdv; 11-29-2008 at 02:12 PM.
Egonvdv is offline  
Old 12-01-2008, 11:58 AM
  #2  
MBWorld Fanatic!
Thread Starter
 
Egonvdv's Avatar
 
Join Date: Apr 2008
Location: A Dutchy Living in Marseille, France
Posts: 1,270
Received 116 Likes on 93 Posts
W213 200CDI -Fascination
reeally nobody here who had a similar issue with their dash...?
Egonvdv is offline  
Old 12-01-2008, 01:00 PM
  #3  
Member
 
C300PO's Avatar
 
Join Date: Nov 2008
Location: North San Diego Coastal
Posts: 110
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport
I have a similar issue with a dash rattle on the left side. It is intermittent and only happens on very rough roads but it is there. I couldn't exactly locate it but I took the C300 Sport to the dealer and of course they "couldn't duplicate the issue". Now that I read your post I'm going to try and locate the rattle in the hood. It is definitly a "plastic" sound.
C300PO is offline  
Old 12-01-2008, 02:13 PM
  #4  
MBWorld Fanatic!
Thread Starter
 
Egonvdv's Avatar
 
Join Date: Apr 2008
Location: A Dutchy Living in Marseille, France
Posts: 1,270
Received 116 Likes on 93 Posts
W213 200CDI -Fascination
tap a bit on top of the hood,
you should be able to hear the vibration/ratle
Egonvdv is offline  
Old 12-01-2008, 02:16 PM
  #5  
Member
 
Join Date: Aug 2008
Location: Toronto
Posts: 93
Likes: 0
Received 0 Likes on 0 Posts
C300 6speed
ya i have the same rattle in the dash, have no idea where and it only happens sometimes.
mikestyle is offline  
Old 12-01-2008, 02:17 PM
  #6  
Member
 
Kieffer's Avatar
 
Join Date: Sep 2007
Location: Colorado
Posts: 201
Likes: 0
Received 0 Likes on 0 Posts
2008 C350 Sport, 2007 ML320 CDI
I had that exact rattle / buzz over the gauges when the car was new. They put double-sided felt on the inside of that panel, and it's never made a noise again. Good luck!
Kieffer is offline  
Old 12-01-2008, 02:18 PM
  #7  
Member
 
C300PO's Avatar
 
Join Date: Nov 2008
Location: North San Diego Coastal
Posts: 110
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport
Originally Posted by Egonvdv View Post
tap a bit on top of the hood,
you should be able to hear the vibration/ratle
thanks for the info. I will check it out later today.
I would love to live in Marseille... But I have to settle for San Diego.
C300PO is offline  
Old 12-01-2008, 03:25 PM
  #8  
Member
 
Join Date: Mar 2008
Posts: 197
Likes: 0
Received 0 Likes on 0 Posts
2008 C300
I have had a rattle/noise that has been driving me crazy lately..and dammit if it only happens in the morning when I am headed to work...and it is cold outside. It is driving me NUTS...I thought it was my keys...or some kind of "static" coming thru the speakers.....but I will check it out on my way home tonight. (I am at my desk). I HOPE that this is the problem, because the noise seemed to be coming from the dashboard somewhere on the left side...and it was TRULY making me nuts. I couldn't duplicate it....but will sure check it out.

Thanks for posting.
Hazemonster is offline  
Old 12-01-2008, 03:32 PM
  #9  
MBWorld Fanatic!
 
chilledbenz's Avatar
 
Join Date: Oct 2007
Location: United States
Posts: 1,828
Likes: 0
Received 0 Likes on 0 Posts
2008 R350 & 2008 C300
[QUOTE=Egonvdv;3193140]

- wipers/rainsensors working very erratically + no difference between
position 1 (operation with low sensitivity) & 2 (high)

/QUOTE]

The very erratic part is normal, every Benz I've owned has been that way. Drive under a tree after a rain storm and a few drops can kick them into high mode, but a sudden down pour doing 65mph and they stay in low. The no difference between position 1 and 2 seems odd though.
chilledbenz is offline  
Old 12-07-2008, 05:45 PM
  #10  
MBWorld Fanatic!
Thread Starter
 
Egonvdv's Avatar
 
Join Date: Apr 2008
Location: A Dutchy Living in Marseille, France
Posts: 1,270
Received 116 Likes on 93 Posts
W213 200CDI -Fascination
/QUOTE]

The very erratic part is normal, every Benz I've owned has been that way. Drive under a tree after a rain storm and a few drops can kick them into high mode, but a sudden down pour doing 65mph and they stay in low. [/QUOTE]

Really?

Well then it's a pretty **** system....
Egonvdv is offline  
Old 12-07-2008, 06:05 PM
  #11  
lug
Junior Member
 
lug's Avatar
 
Join Date: Mar 2008
Location: Gibraltar
Posts: 58
Likes: 0
Received 0 Likes on 0 Posts
C320 CDI 4matic Brabus D6(III), Black, with lots of extras ;-)
[QUOTE=chilledbenz;3195827]
Originally Posted by Egonvdv View Post

- wipers/rainsensors working very erratically + no difference between
position 1 (operation with low sensitivity) & 2 (high)

/QUOTE]

The very erratic part is normal, every Benz I've owned has been that way. Drive under a tree after a rain storm and a few drops can kick them into high mode, but a sudden down pour doing 65mph and they stay in low. The no difference between position 1 and 2 seems odd though.
I've had my car for under one week and it has been raining for most of it. One thing I noticed was that every now and then the wipers would go beserk when I braked even when there was a light rain. At first I thought that the system was faulty and it was a while before I realised that the water droplets from the roof would stream down over the sensor every time I braked sending the wipers into a frenzy.
lug is offline  
Old 12-07-2008, 06:26 PM
  #12  
Junior Member
 
inactiveuser1019's Avatar
 
Join Date: Apr 2008
Posts: 68
Likes: 0
Received 0 Likes on 0 Posts
2015 Iridium Silver Luxury Edition C300 4Matic
I had the same intermittent rattle. Dealer removed top covering and installed some padding. Never happened afterwards.
inactiveuser1019 is offline  
Old 02-16-2009, 12:15 AM
  #13  
Member
 
Join Date: Mar 2004
Posts: 245
Received 0 Likes on 0 Posts
2008 C350, 2005 C230k Coupe
Same rattle here, only when temp outside is below 50 degrees. It disappears either when I push slightly down on top, or when I push slightly against the clear platic cover over the instruments. Dealer has been "unable to replicate" thus far.

Also have a creak from the rear in similar low temps. Rattle disappears when my son pushes on the headrests, of all things. Any suggestions?
ayilar is offline  
Old 03-29-2009, 08:13 PM
  #14  
Newbie
 
Join Date: Mar 2009
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Mercedes Benz C 300 sport
Angry thump in glove box

the day after i brought mine home it sounded like there was something sliding around in the glove box. so i took everything out (my insurance and registration they must have weighted 20 lb, by the sound they were making). Guess what, 5 minutes later thump!!!! anybody know what this could be or anyone else have this problem?
willierw is offline  
Old 04-01-2009, 12:22 PM
  #15  
Senior Member
 
benzo-boi's Avatar
 
Join Date: Jun 2003
Location: Los Angeles
Posts: 433
Likes: 0
Received 0 Likes on 0 Posts
2008 C300 Sport Sedan: Panarama Roof, P2, Multimedia
i have the exact same rattle by the speedometer. Have you brought it in yet? Rattles are tough cause it's hard for the dealers to replicate it. Let me know how it works out.
benzo-boi is offline  
Old 04-01-2009, 01:33 PM
  #16  
Senior Member
 
Bokx_350's Avatar
 
Join Date: Sep 2007
Location: Boston, MA
Posts: 430
Likes: 0
Received 0 Likes on 0 Posts
C350
It has happened to me too.... It is very annoying!!
It happens only when the car is in idle, and it is comming from that exact place, the instrument cluster. If I tap on the hood it will sound more.

It is not always there, so i'm affraid I will lose my time if I take it to the dealer for this; also, they might give me crap about me messing around the center console because of my COMAND retrofit.

Anyone figured how to fix this without taking it to the dealer??
Bokx_350 is offline  
Old 04-01-2009, 07:44 PM
  #17  
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,905
Received 94 Likes on 77 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Proper rain sensor operation requires the screen to be free of silicone or any hint of salt or mineral deposit in the sensor area or it messes with defraction. Clean the screen properly with a very light abrasive in the sensor area. - DO NOT SCRATCH.
Glyn M Ruck is offline  
Old 06-08-2009, 12:40 PM
  #18  
MBWorld Fanatic!
Thread Starter
 
Egonvdv's Avatar
 
Join Date: Apr 2008
Location: A Dutchy Living in Marseille, France
Posts: 1,270
Received 116 Likes on 93 Posts
W213 200CDI -Fascination
Originally Posted by Kieffer View Post
I had that exact rattle / buzz over the gauges when the car was new. They put double-sided felt on the inside of that panel, and it's never made a noise again. Good luck!
1st they changed the whole panel, which made the noise worse.

took it back again & explained them about the above technique.
i actually told them: just stuff toilet paper in there, i don't care,
as long as it works

What they did the 2nd time i don't know, but probably nothing...;

New appointment in 2 weeks (insert smiley banging it's head against a wall)
Egonvdv is offline  
Old 06-28-2010, 05:07 PM
  #19  
Newbie
 
Join Date: Jan 2010
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
w204 180K
I have exactly the same noise in my w204 2010. How have you guys solve the problem? My car's 15,000 km Service is only 1,500km away. Shall I have it fixed at the service, or is there any practical solution to it, which I can apply by myself? Thank you.
w204tr is offline  
Old 06-29-2010, 01:07 PM
  #20  
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,108
Likes: 0
Received 3 Likes on 3 Posts
2012 C250 Coupe
I have a two rattles, one would be either the passenger speaker, or glovebox (or both at different times) and then the other rattle comes from the rear passenger side, could be the headrest as someone else mentioned? But it is driving me NUTS!

Secondly, I also have the wind noise coming from my rear driver side window or somewhere near. Of course, the dealer is "unable to replicate." PLEASE let me know how you make out, lol!
jctevere is offline  
Old 06-29-2010, 01:35 PM
  #21  
Super Member
 
Join Date: Apr 2010
Posts: 771
Likes: 0
Received 6 Likes on 5 Posts
2017 C43
Originally Posted by jctevere View Post
I have a two rattles, one would be either the passenger speaker, or glovebox (or both at different times) and then the other rattle comes from the rear passenger side, could be the headrest as someone else mentioned? But it is driving me NUTS!

Secondly, I also have the wind noise coming from my rear driver side window or somewhere near. Of course, the dealer is "unable to replicate." PLEASE let me know how you make out, lol!
have the same wind noise right by my left ear when driving.. makes me nuts!
blue00r6 is offline  
Old 06-29-2010, 01:56 PM
  #22  
MBWorld Fanatic!
 
Sportstick's Avatar
 
Join Date: Jan 2009
Location: Southeast Michigan
Posts: 4,975
Likes: 0
Received 2 Likes on 2 Posts
2015 228i
For wind noise, check this thread and examine your car for this potential issue.

https://mbworld.org/forums/c-class-w...e-windows.html

The fix helped a lot, and now the noise seems primarily to be from the 09 style side mirrors.
Sportstick is offline  
Old 07-14-2010, 09:04 AM
  #23  
Member
 
Join Date: Feb 2008
Location: INA
Posts: 104
Likes: 0
Received 0 Likes on 0 Posts
Serpent S966
Originally Posted by jctevere View Post
I have a two rattles, one would be either the passenger speaker, or glovebox (or both at different times) and then the other rattle comes from the rear passenger side, could be the headrest as someone else mentioned? But it is driving me NUTS!

Secondly, I also have the wind noise coming from my rear driver side window or somewhere near. Of course, the dealer is "unable to replicate." PLEASE let me know how you make out, lol!
The one you hear from the passenger speaker or as if it is behind a glove box, it is actually the engine hood that is not adjusted correctly. That is what I found out today from my service manager. Try to push/slide your hood forward and backward to make sure if you hear the same sound.

How? Stand by passenger vender side facing toward the other vender. Grab the engine hood top side (toward windshield side) by the edge with one of you hand. Then put the other hand on top of the hood bottom side (near front light). Now grab hard and try to move the hood forward (toward windshield) and backward (towards the front of the car). I hear the exact same creaking sounds as I heard from interior.

This also happened to the new E.
pwidjaja is offline  
Old 11-09-2010, 11:21 AM
  #24  
Senior Member
 
Join Date: Nov 2009
Posts: 285
Likes: 0
Received 0 Likes on 0 Posts
2008 C350 Sport
I too have this buzzing plastic sound coming from the dash that has progressively worsened in the last 4-6 months. Thanks to this thread I was able to track it to the dash but not sure if it's the instrument cluster or not... I initially thought that it sounded like a buzzing with the intake since I only hear the buzzing during acceleration. IT IS STARTING TO DRIVE ME CRAZY THOUGH so going to have the dealership look at it on Thursday when they replacing that rubber "truss" in front of the radio display that is peeling up.

Has anyone who had this problem, had it fixed successfully? One of you noted that it was fixed by installing some padding. Is there a TSB for this as it seems to be a very common problem on this car. It really takes away from the great engine sound during hard acceleration when all I can think of is that damn buzzing sound. I sure hope that they fix it this week.
MBnewby is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: loose dashboard part causes noise/vibration. (+ back to dealer for multiple issues)


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: