Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
'11 W204 running cold >

'11 W204 running cold

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

'11 W204 running cold

 
Old 02-09-2019, 02:02 PM
  #1  
Junior Member
Thread Starter
 
'11W204's Avatar
 
Join Date: Feb 2018
Location: Boston MA
Posts: 65
Liked 4 Times in 4 Posts
2011 W204
'11 W204 running cold

Subject car; 2011 C300 4MATIC Sport, 70,000 miles

Guys, I don't drive the car often, but was out today and noticed the temperature gage never moved about 62C. It's about 35F today so not crazy cold. I've got good cabin heat, car appears to produce heat quickly. I just noticed the temp gage was real low. During warm months car settles right in at 82C where it should. I see the thermostat is electronically controlled. Is this component problematic? No warning lights, MIL, CEL.

Thanks for any suggestions.
'11W204 is offline  
Old 03-11-2019, 11:30 AM
  #2  
Junior Member
Thread Starter
 
'11W204's Avatar
 
Join Date: Feb 2018
Location: Boston MA
Posts: 65
Liked 4 Times in 4 Posts
2011 W204
CEL utimately did come on. Thermostat replaced and problem appears to be cured. Lots of heat in cabin now, car gets up to normal operating temperature, just above 80C.

Replaced a couple of idlers, serp belt and did new plugs.
'11W204 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: '11 W204 running cold


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: