Supercharger problem - MBWorld.org Forums



C32 AMG, C55 AMG (W203) Discuss the C32 and C55 AMG.
Sponsored by:
Sponsored by:

Supercharger problem

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 04-26-2017, 10:02 PM   #1
Member
Thread Starter
 
Join Date: Apr 2011
Posts: 165
Drives: c32 amg
Thanked 0 Times in 0 Posts
Supercharger problem

I just reemplace the intercooler supercharger, i fix the leak, everething good not leak more, but now after 20 minutes to run fast, the supercharger shout down, , and on , shount down , i conect the obd2 Edu, and show the iat sensor , i change for new one run better , but today again the problem with the charger iré sometimes

please what problem you think its
super-amg is offline   Reply With Quote
Old 05-07-2017, 10:25 AM   #2
Member
 
Join Date: Jun 2015
Posts: 92
Drives: c32 amg
Thanks: 0
Thanked 1 Time in 1 Post
check your thread from above. i have explained how to check your electric water pump. same problem I had. might as well replace your heat exchanger with a plm and get rid of the the tiny oem
kramykram is offline   Reply With Quote
Old 05-20-2017, 12:30 AM   #3
Member
 
Join Date: Jun 2015
Posts: 92
Drives: c32 amg
Thanks: 0
Thanked 1 Time in 1 Post
did you get this sorted man??
kramykram is offline   Reply With Quote
 
 
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:20 PM.


Copyright © 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
What's your question?
Send