Notices
CL55 AMG, CL65 AMG, CL63 AMG (W215, W216) Discuss the CL55, CL65, and the CL63 AMG.

Bought a CL55, throttle body questions

 
Old 02-11-2019, 02:34 PM
  #1  
Member
Thread Starter
 
Agent-A01's Avatar
 
Join Date: May 2013
Posts: 81
Liked 4 Times in 4 Posts
Phat
Bought a CL55, throttle body questions

I bought a 139k mile 03 in great condition(visually)

So basically I saw how cheap it was and thought to myself I couldn't pass it up,
4K is cheap. Once fixed KBB is worth about 5K more.

The car needs a throttle body. Dealer did not want to mess with it.
The other issue it has is no sound, fiber optic break.
That's no big deal, I have star for that.

So the plan is to order a throttle body today and drive to get it; replace the TB and drive it home.
It's about a 4 hour drive so I need to have everything lined up.

My questions are:

1. Is this part number correct for the TB? 2751410086
2. Won't i need gaskets of some sort? What are the P/Ns on those?
3. Is there any alternative TB P/N. The ones i see are all around 170-200 USD
4. I assume TB is relatively easy. Probably need to remove SC to get to it then it's straight forward after that.

Any insight would be appreciated

Edit: Ebay seller said there were 2 TBs and I should know which one I need.
I wasn't aware there were 2?

He said The second one is right after the supercharger and before the intercooler.

Last edited by Agent-A01; 02-11-2019 at 03:53 PM.
Agent-A01 is offline  
Old 02-25-2019, 06:05 PM
  #2  
Super Member
 
Join Date: Jul 2012
Posts: 662
Likes: 0
Liked 18 Times in 18 Posts
2002 CL500 to CL55 conversion
Iíve never worked on an m113k but youíll almost certainly need to pull the supercharger

if it was me i I wouldnít rush this job, in order to get the throttle body on to get home, take another car and take your time disconnecting all that stuff to do it right, too many plastic clips/fragile wiring on these cars to rush them
ctravis595 is online now  
Old 02-27-2019, 04:03 PM
  #3  
PLATINUM SPONSOR
 
Exotic-metal55's Avatar
 
Join Date: Jun 2008
Location: Texas
Posts: 3,480
Liked 10 Times in 10 Posts
2003 CL55
I do not recall the part number but most the m113K TB`s will work. You do not need to remove the SC to change TB out. Just, air box , 4 star headed bolts and couple hoses. The gaskets hardly ever break and you can use silicone gasket if you do not have a gasket. I have changed many of these and removed my engine several times from my 03 CL55.
__________________



E63 Biturbo, UPD Cold Air induction kit, UPD performance crank pulley and UPD adjustable rear suspension with ride height adjustment.

CL55 UPD Cold Air Boost kit, UPD 3000 stall converter, UPD 77mm SC clutched pulley and beltwrap kit, Custom long tubes, UPD crank pulley , UPD suspension kit, UPD SC pulley, Aux. HE, Trunk tank w/rule 2000 pump, Mezeire pump, UPD 5pc idler set, Aluminum rotor hats.

www.ultimatepd.com
instagram @ultimate_pd
facebook.com/ultimatepd
Exotic-metal55 is offline  
Old 02-27-2019, 07:00 PM
  #4  
Member
Thread Starter
 
Agent-A01's Avatar
 
Join Date: May 2013
Posts: 81
Liked 4 Times in 4 Posts
Phat
Originally Posted by Exotic-metal55 View Post
I do not recall the part number but most the m113K TB`s will work. You do not need to remove the SC to change TB out. Just, air box , 4 star headed bolts and couple hoses. The gaskets hardly ever break and you can use silicone gasket if you do not have a gasket. I have changed many of these and removed my engine several times from my 03 CL55.
Since Iíve gotten quite a few replies here Iíll give an update

I bought the car and drove it home, carefully. About 4 hours.

The dealer had put in the incorrect TB and the car would stall after being started. I installed the correct TB from a forum member here. The car was still hesitant but did not stall. Upon giving the car half throttle or so it would go limp mode instantly.

I had to ease into throttle to get it home. Cruised at 75mph and it was ok. It would have slight hiccups, bad throttle body symptoms.

Anyways got the car home and scanned with Star.
Got current and stored codes of deflection of throttle body, stored short circuit etc.

the throttle body cable cable coming from the engine harness has a lot of slack, I assume dealer pulled it all up.

As as for the codes, my guess is the main engine harness connector/ harness is faulty. Iíve played with the harness and the car will act very stuttery. Sprayed connector with electrical contact cleaner. The car idled fine after that.

Gonna try a new cable harness and see if I can solder a new one on the engine harness.

The car also has interior can fault short.

The abc, esp and the esm modules will not communicate.
Working in figuring that out now.
Agent-A01 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Bought a CL55, throttle body questions


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: