Go Back  MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > CLK-Class (W208)
PLEASE help diagnose my clk engine prob... >

PLEASE help diagnose my clk engine prob...

Notices
CLK-Class (W208) 1998-2002: CLK 200, CLK 230K, CLK 320, CLK 430 [Coupes & Cabriolets]

PLEASE help diagnose my clk engine prob...

 
Old 12-13-2007, 12:45 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
2000 clk w208
PLEASE help diagnose my clk engine prob...

Hi everyone...
Basically, i changed my car battery today and a few problems happend.

The first prob was that my electric windows dont go up and down by them selves automatically, so i have to hold the buttons down! what should i do?

Secondly and the big prob...
Went to drive the car after i changed the battery, and i let the car warm up etc...
I then put my foot down but didnt floor it, i then realised the car wasnt moving as it should. As if the clutch was slipping or something. But thats not it.

The car at idle is very low and is shaking all over the place. When i accelerate it sounds like a heavy diesal. And it sounds as if the engine is misfiring etc...

But then if i turn the car off and then on again, the car is normal. And i have driven it around slowly and all is gd. Then the same happens if i floor it again.

The weather has changed drastically over here in london and it has just got very cold all of a sudden, and thats why my battery had to be changed as it died.

Could this prob be related to the weather or me changing the battery?

PLEASE HELP ASAP, i need to use my car!

THANKS

Josh
joshh is offline  
Old 12-13-2007, 05:31 PM
  #2  
MBWorld Fanatic!
 
sick430's Avatar
 
Join Date: Sep 2006
Location: So Cal
Posts: 1,946
Received 18 Likes on 18 Posts
CLK Cabrio
hey sounds like your mass air sensor is gone. if you go to ebay and look around you should be able to pick one up for around 150-200 U.S. dollars. this is a comman problem on these cars. what engine do you have?
sick430 is offline  
Old 12-14-2007, 04:09 AM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
2000 clk w208
thansk for the help...
Do you know where the sensor is on a clk 200? roughly where would it be? near the inlet mani around the air intake?
joshh is offline  
Old 12-14-2007, 09:20 AM
  #4  
MBWorld Fanatic!
 
Chappy's Avatar
 
Join Date: Jul 2002
Location: Hotlanta
Posts: 9,640
Received 33 Likes on 27 Posts
AMG
Pulling the error codes and posting them may assist us in learning what your issues are.
Chappy is offline  
Old 12-14-2007, 12:17 PM
  #5  
Member
 
Join Date: Jan 2007
Location: Anaheim Hills, CA
Posts: 112
Likes: 0
Received 0 Likes on 0 Posts
CLK430, SC430, RX330
If it is the MAF sensor here's a good set of instructions to follow for cleaning it...

http://www.panchogun.com/FVWebPhotos...-MAF-5x100.jpg

Cleaning it didn't really work for me so I just replaced it.. Got a new Bosch MAF sensor (insert only/ not the entire plastic cylinder) off ebay for about $95. The stealership will usually get you for at least twice as much.

If you buy from ebay make sure the sensor is new and not just a cleaned off used one. Also make sure it is Bosch instead of a cheap imitation.

Pull the codes on your car to make sure the MAF is actually the problem. When mine had a bad MAF sensor on it, the code was P0170 and P0173 (Fuel trim malfunction in bank 1 and bank 2).

Good luck. Hope that helps.
ratha67 is offline  
Old 12-14-2007, 07:31 PM
  #6  
Senior Member
 
Jessica90's Avatar
 
Join Date: Sep 2006
Location: NorCal
Posts: 303
Likes: 0
Received 0 Likes on 0 Posts
CLK430
The MAF should be located at the back of the airbox/engine close to the firewall.

I was experiencing the same problem about 4 months ago. My car had similar symptoms; the check engine light would constantly blink if I tried to floor the car (misfiring), after flooring the car, my car would violently shake, and the only way to stop the shaking was by restarting the car, also some of the times when the car was cold, it struggled to get to 2k rpms and it took a while to get past 20 mph.

However, I was convinced it was the MAF, but in my case it was a broken left motor mount.
Jessica90 is offline  
Old 12-16-2007, 01:03 PM
  #7  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
2000 clk w208
hmm i completly forgot about pulling the codes... Is there a type of device i would need? where does it plug in. Sorry but i dont know much about mercs, as one has never gone wrong on me.
joshh is offline  
Old 12-16-2007, 01:33 PM
  #8  
Senior Member
 
tpick23's Avatar
 
Join Date: Jan 2007
Location: Wilmington,NC
Posts: 352
Likes: 0
Received 0 Likes on 0 Posts
E63
Smile Reset the windows

Try starting with the window up, hold the button down to make the window go all the way down then release. Then, hold the button up so the window goes all the way up. Take care to not press the button far enough to go into the auto up/down. I had a C55 that the windows acted up in. The dealer told me they just needed reseting. Also works for the sunroof.
tpick23 is offline  
Old 12-16-2007, 09:01 PM
  #9  
Senior Member
 
Jessica90's Avatar
 
Join Date: Sep 2006
Location: NorCal
Posts: 303
Likes: 0
Received 0 Likes on 0 Posts
CLK430
Originally Posted by joshh View Post
hmm i completly forgot about pulling the codes... Is there a type of device i would need? where does it plug in. Sorry but i dont know much about mercs, as one has never gone wrong on me.
You need the OBDII code reader. If you have an autozone near you, you can go over there and they can help you pull the codes.

The plug in (OBDII connector) should be under the instrument panel on the drivers side. I believe the plug is under a flap (a cover) that you must pull down to have the connector displayed.
Jessica90 is offline  
Old 12-18-2007, 08:12 AM
  #10  
Member
 
Join Date: Oct 2007
Location: Denmark
Posts: 107
Likes: 0
Received 0 Likes on 0 Posts
Happy owner of '98 CLK 320
Ah the horrors of changing battery on an MB.
I recently bought a clk320, had some problems that where corrected by a new battery... which then gave me more problems

Symptoms:
BAS alarm on dashboard
ABS alarm on dashboard
Sidewindows that would come down, but not up, nomatter what i tried
Sluggish drive

Cause:
Sometimes when changing the battery on a MB, system codes return errors, or are locked to certain values.

Solutions:
Reset the system codes

How to:
Start the engine
Turn the wheel all the way to the left
Turn the wheel all the way to the right
Turn the wheel back to center position
Turn of the ignition, pull out key
Start the engine

The above worked for me. I really thought the dealer was pulling my leg or something like that, but it truly worked.

Perhaps the above procedure can help eliviate some of your problems too
(if you didn't do this allready ofc)
Wobert is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: PLEASE help diagnose my clk engine prob...


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: