Notices
CLS Coupe (C219) Discuss the CLS Coupe.

Heater issue

 
Old 03-15-2019, 12:29 AM
  #1  
Newbie
Thread Starter
 
Join Date: May 2018
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
cls 350 w219
Heater issue

I have a 05 cls w219, the heater was not working for 3 years so this year i decide to replace all the necessary parts. The first year when I send it in for repair the mechanic just override the system by cutting of the supply hose from the duo valve to the engine. I replaced all the pipes and the auxiliary pump as well as the duo valve. Still I'm not getting any heat. There is no heat at alll even after setting max temp set on the climate system. Anything else do I have to check to solve this matter? I still have tons of restoration to be done to the car and I dnt want the car to get stuck in the workshop just for that matter.
Thaya60 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Heater issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: