Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
E500 (lack of) brake feel. Is this normal? >

E500 (lack of) brake feel. Is this normal?

Notices
E-Class (W211) 2003-2009

E500 (lack of) brake feel. Is this normal?

 
Old 06-16-2015, 02:18 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Location: San Francisco
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
'06 E500 Wagon, BMW Z4 M Coupe, Mini
E500 (lack of) brake feel. Is this normal?

The stopping power is quite good, but I don't like the feedback at all. Basically, in the area of travel before engagement, the pedal movement is so firm that you can't really detect with your foot when the brakes engage. This is kind of disconcerting, and I often end up over-breaking a little in light braking situations. I'm used to being able to feel with my foot as the pads contact the rotor before they really grab. This feedback enables you to better modulate. Is this natural for these cars, or should I get it checked? If this is the typical, is there a way to alter it?

Last edited by funkle; 06-16-2015 at 02:22 PM.
funkle is offline  
Old 06-16-2015, 02:25 PM
  #2  
Super Member
 
Join Date: Nov 2009
Posts: 712
Thanked 23 Times in 22 Posts
Car free at the moment
This car has the SBC brake-by-wire system. The feedback is completely artificial. And yes, that is normal, there isn't anything to be done about it.
Shadow5501 is offline  
Old 06-16-2015, 04:57 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Location: San Francisco
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
'06 E500 Wagon, BMW Z4 M Coupe, Mini
Originally Posted by Shadow5501 View Post
This car has the SBC brake-by-wire system. The feedback is completely artificial. And yes, that is normal, there isn't anything to be done about it.
Thanks, I guess I need to come to terms with the death of the analogue car.
funkle is offline  
Old 06-16-2015, 05:16 PM
  #4  
MBWorld Fanatic!
 
cetialpha5's Avatar
 
Join Date: Feb 2014
Location: MA
Posts: 3,301
Thanked 346 Times in 309 Posts
2008 E350 4Matic, 2011 E350 4matic
Originally Posted by funkle View Post
Thanks, I guess I need to come to terms with the death of the analogue car.
Not really, they got rid of SBC after 2006. So if you got a 2007-2009+ model, it wouldn't have SBC and you'd be somewhat back to normal.
cetialpha5 is offline  
Old 06-16-2015, 05:31 PM
  #5  
Member
 
Join Date: Sep 2012
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
W211
I have the 04 and also the SBC, but my brakes have a "Mercedes" feel to it. It is no different from the other cars I have so if you are having issues with brake feel, have it checked. The SBC unit's warranty was extended to 10 years so you should still be covered.
2.7Tallroader is offline  
Old 06-16-2015, 06:23 PM
  #6  
Super Member
 
Join Date: Nov 2009
Posts: 712
Thanked 23 Times in 22 Posts
Car free at the moment
Originally Posted by cetialpha5 View Post
Not really, they got rid of SBC after 2006. So if you got a 2007-2009+ model, it wouldn't have SBC and you'd be somewhat back to normal.


Ironically enough, the later w211 cars are worse. I own a 2008 Bluetec and have driven many an E350 and E550. There is a large no-feel no-effort zone before the pedal firms up. It feels like air in the brake lines, but persists after a brake bleed. It is not very Mercedes-like.
Shadow5501 is offline  
Old 06-22-2015, 11:37 AM
  #7  
MBWorld Fanatic!
 
BagMan's Avatar
 
Join Date: Jan 2010
Location: SWFL
Posts: 1,057
Thanked 16 Times in 12 Posts
E55, E320 CDI , CLA250, Jag XJ Supersport
I replaced the pads on all three of my w211s with Akebono.

Not only do they reduce dust to practically nothing, they really smooth out the initial grab vs the stock pads. Feels like normal brakes now.

They also don't compromise emergency stopping power. If I give the brakes a quick jab, the car drops anchor.
BagMan is offline  
Old 06-22-2015, 09:47 PM
  #8  
Member
 
JP500's Avatar
 
Join Date: Feb 2010
Location: New York City
Posts: 116
Thanks: 0
Thanked 1 Time in 1 Post
2003 E500 sport (sold), 2009 GL450, w213 E63 (waiting for ordering guide)
I have SBC on my '500 and I conpletely have feel on my breaking. Been driving it for 7 years now. The only time I had the issue that you are describing was when it was time for new pads/rotors.
JP500 is offline  
Old 06-24-2015, 10:06 AM
  #9  
Junior Member
 
Join Date: Jan 2015
Location: Los Angeles
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
2004 E500
I'm with funkle, my 04 feels/does exactly what he is describing.

Its a bit deceiving sometimes.
Surfer69E500 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: E500 (lack of) brake feel. Is this normal?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: