Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Transmission jerks when I put in D or R >

Transmission jerks when I put in D or R

Notices
E-Class (W211) 2003-2009

Transmission jerks when I put in D or R

 
Old 05-19-2019, 08:20 PM
  #1  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Transmission jerks when I put in D or R

Clunks violently when I put it into drive or reverse pulled some codes off of carly but cant find anything on google.
Malek Hussein is offline  
Old 05-20-2019, 09:00 PM
  #2  
Senior Member
 
Join Date: Aug 2004
Location: Southern California
Posts: 255
Likes: 0
Received 10 Likes on 10 Posts
Transmission mount needs to be replaced?
F1Fan is offline  
Old 05-20-2019, 09:01 PM
  #3  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Thats what i thought but i took it for a spin today and the car doesnt get out of 1st gear even if i try shifting manually
Malek Hussein is offline  
Old 05-21-2019, 08:15 AM
  #4  
Newbie
 
Join Date: Apr 2019
Location: Vermont, USA
Posts: 8
Received 2 Likes on 1 Post
01 clk430, 05 e500 4matic
Were you able to clear the codes you posted above? Seems you have an unhappy TCU and are in "limp home" mode.
scotterikson is offline  
Old 05-21-2019, 09:08 AM
  #5  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
I used Carly to clear the codes and the car is still in limp mode and I can't find out how to get it out.
Malek Hussein is offline  
Old 05-23-2019, 11:01 PM
  #6  
Member
 
Join Date: Feb 2007
Location: Republic of Texas
Posts: 171
Likes: 0
Received 31 Likes on 29 Posts
W203 W212 MINI
You will need a conductor plate. Most likely a malfunction of an internal speed sensor. It's in safe mode.
MBENZTECH is offline  
Old 05-23-2019, 11:44 PM
  #7  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by Malek Hussein View Post
I used Carly to clear the codes and the car is still in limp mode and I can't find out how to get it out.
Carly can only read codes from the ECU not the TCM. Your car is stuck in limp home mode. You need a scan tool that will talk to the TCM. Limp home mode can be caused by any number of issues and without reading codes you won't be able to find out what it is or bring it out of limp home mode. Your options are find a shop with MB star, I carsoft or Foxwell. Good luck.
tjts1 is offline  
Old 05-24-2019, 12:10 AM
  #8  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
I bought a icarsoft what would i look for using it?
Malek Hussein is offline  
Old 05-24-2019, 12:17 AM
  #9  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by Malek Hussein View Post
I bought a icarsoft what would i look for using it?
What transmission codes do you have?
tjts1 is offline  
Old 05-24-2019, 12:22 AM
  #10  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
I got 0513 and 0562
Malek Hussein is offline  
Old 05-24-2019, 12:40 AM
  #11  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Originally Posted by tjts1 View Post
What transmission codes do you have?
Cleared the codes and 0513 is the only one that keeps popping up
Malek Hussein is offline  
Old 05-24-2019, 12:49 AM
  #12  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by Malek Hussein View Post
Cleared the codes and 0513 is the only one that keeps popping up
Ok and what's the description attached to those? Are you reading these codes from the TCM with the icarsoft tool? Do you have a 5spd or a 7spd?

Last edited by tjts1; 05-24-2019 at 12:52 AM.
tjts1 is offline  
Old 05-24-2019, 12:53 AM
  #13  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Originally Posted by tjts1 View Post
Ok and what's the description attached to those? Are you reading these codes from the TCM with the icarsoft tool? Do you have a 5spd or a 7spd?
0513 is "The CAN signal for start enable sent to the drive authorization system by transmission control is missing or invalid."

0562 is "The voltage supply of circuit 87 has undervoltage."
Malek Hussein is offline  
Old 05-24-2019, 12:55 AM
  #14  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by Malek Hussein View Post
0513 is "The CAN signal for start enable sent to the drive authorization system by transmission control is missing or invalid."

0562 is "The voltage supply of circuit 87 has undervoltage."
Well it depends on which transmission you have. You can try resetting the codes in the TCM and see if it pops out of limp home mode. If it does that's only a temporary fix.
tjts1 is offline  
Old 05-24-2019, 12:59 AM
  #15  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
It's the 722.9 transmission. I clear the codes but nothing changes. Can't switch it from comfort to sport and wont go through gears when i manually shift it. It just stays in first gear.
Malek Hussein is offline  
Old 05-24-2019, 01:03 AM
  #16  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by Malek Hussein View Post
It's the 722.9 transmission. I clear the codes but nothing changes. Can't switch it from comfort to sport and wont go through gears when i manually shift it. It just stays in first gear.
Well the most likely failure on a 722.9 is a bad conductor plate. The 722.9 conductor plate contains the TCM and the TCM is coded to the car. You need to find a transmission shop that can get a new conductor plate from MB. They won't sell it to just anybody since they need to know the vin of your car to make you specifically for it.
tjts1 is offline  
Old 05-24-2019, 01:12 AM
  #17  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Originally Posted by tjts1 View Post
Well the most likely failure on a 722.9 is a bad conductor plate. The 722.9 conductor plate contains the TCM and the TCM is coded to the car. You need to find a transmission shop that can get a new conductor plate from MB. They won't sell it to just anybody since they need to know the vin of your car to make you specifically for it.
Couldn't it be due low voltage from the battery?
Malek Hussein is offline  
Old 05-24-2019, 01:15 AM
  #18  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by Malek Hussein View Post
Couldn't it be due low voltage from the battery?
If that was the issue and you fixed the low voltage problem and cleared the codes the transmission would operate normally again. Once the engine is running the operating voltage is determined by the alternator's voltage regulator, not the battery.
tjts1 is offline  
Old 05-24-2019, 05:09 AM
  #19  
Member
 
Maroc_Specops's Avatar
 
Join Date: Jun 2017
Location: Netherlands
Posts: 199
Received 13 Likes on 13 Posts
W211 E320 CDI Sportpackage With Carlsson CD32 Chip 2004
Either ur battery is weak
Or ur tcu needs replacement
Or anything from solenoids to transmission filter clogged.

It's one of the most frequent occurring errors.

Personally, I think ur speedsensor 1 or 2 is gone. Most likely by a broken transmission unit.
Maroc_Specops is offline  
Old 05-24-2019, 08:14 AM
  #20  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Originally Posted by Maroc_Specops View Post
Either ur battery is weak
Or ur tcu needs replacement
Or anything from solenoids to transmission filter clogged.

It's one of the most frequent occurring errors.

Personally, I think ur speedsensor 1 or 2 is gone. Most likely by a broken transmission unit.
I'm going to check on the battery tomorrow and have it tested and shouldn't I be getting codes for the speed sensor? So weird how there weren't any warning signs of this happening.
Malek Hussein is offline  
Old 05-25-2019, 02:08 AM
  #21  
Senior Member
 
benznyc's Avatar
 
Join Date: Aug 2009
Location: suffolk longisland newyork
Posts: 463
Likes: 0
Received 0 Likes on 0 Posts
ml/e420/others
transmission
benznyc is offline  
Old 05-25-2019, 10:43 PM
  #22  
Newbie
Thread Starter
 
Join Date: May 2019
Posts: 11
Likes: 0
Received 1 Like on 1 Post
2006 Mercedes E350
Originally Posted by benznyc View Post
transmission
Great answer!!
Malek Hussein is offline  
The following users liked this post:
scotterikson (05-26-2019)
Old 05-28-2019, 08:54 PM
  #23  
Senior Member
 
benznyc's Avatar
 
Join Date: Aug 2009
Location: suffolk longisland newyork
Posts: 463
Likes: 0
Received 0 Likes on 0 Posts
ml/e420/others
Originally Posted by Malek Hussein View Post
Great answer!!
yes replace the transmission.had the same problem on my old ml and clk.
benznyc is offline  
Old 05-28-2019, 08:56 PM
  #24  
Super Member
 
Join Date: May 2017
Posts: 869
Received 73 Likes on 69 Posts
C320
Originally Posted by benznyc View Post
yes replace the transmission.had the same problem on my old ml and clk.
LOL you fool.
tjts1 is offline  
Old 05-28-2019, 09:10 PM
  #25  
Senior Member
 
benznyc's Avatar
 
Join Date: Aug 2009
Location: suffolk longisland newyork
Posts: 463
Likes: 0
Received 0 Likes on 0 Posts
ml/e420/others
was cheaper to change the transmission moron!
benznyc is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Transmission jerks when I put in D or R


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: