Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
New Project: MB E300 NTG4.5 CarPlay Proxy Kit >

New Project: MB E300 NTG4.5 CarPlay Proxy Kit

Notices
E-Class (W212) 2010 - 2016: E 350, E 550

New Project: MB E300 NTG4.5 CarPlay Proxy Kit

 
Old 02-04-2019, 07:09 PM
  #26  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
If you have any question regarding the installation, please let me know.
MO. is offline  
The Following User Says Thank You to MO. For This Useful Post:
morganbjorn (02-25-2019)
Old 02-25-2019, 08:28 AM
  #27  
Newbie
 
Join Date: Jul 2013
Posts: 3
Thanked 0 Times in 0 Posts
2012 CLS550
Install

Originally Posted by MO. View Post
If you have any question regarding the installation, please let me know.
I was wondering how/where you were able to squeeze the adapted in the dash?
From all the "install" videos, the adapted is left on the drivers leg and in many threads and install video for a replacement screen (where original screen is removed and there is no additional electronic box needed to be added behind the comand), they often have problems just finding space for the added wire harness.

Did you happen to take pics of wire harness and adapted install in the dash?

Thanks
Tunes is offline  
Old 02-25-2019, 11:02 AM
  #28  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by Tunes View Post


I was wondering how/where you were able to squeeze the adapted in the dash?
From all the "install" videos, the adapted is left on the drivers leg and in many threads and install video for a replacement screen (where original screen is removed and there is no additional electronic box needed to be added behind the comand), they often have problems just finding space for the added wire harness.

Did you happen to take pics of wire harness and adapted install in the dash?

Thanks

Adapt. location

You are absolutely right! It is quite difficult to just squeeze the harness in the back of the head unit. I squeezed it at the back/ under the Head UNIT (you will need to keep trying, but you will succeed). There is no space at all to install the Adapter under the dash. I installed it under the side carpet ( passenger side), see the attached picture. Please let me know if you still need help!
MO. is offline  
The Following User Says Thank You to MO. For This Useful Post:
Tunes (02-25-2019)
Old 02-25-2019, 12:21 PM
  #29  
Newbie
 
Join Date: Jul 2013
Posts: 3
Thanked 0 Times in 0 Posts
2012 CLS550
Thanks for the quick reply.
The install and ability to hide this unit is the deciding factor between this and the android screen replacement option. Wanting to keep the install looking stock, I am leaning towards this over the "android" look of the other option.
Cheers
Tunes is offline  
Old 02-25-2019, 05:01 PM
  #30  
Newbie
 
Join Date: Jan 2019
Location: VA, USA
Posts: 6
Thanked 0 Times in 0 Posts
2015 GLA 250
I was looking into installing this into my 2015 GLA with NTG4.7 and I was wondering if the steering wheel voice control button works with Android Auto?
Also, did you connect using AUX or Bluetooth for audio connection? If you used AUX, how is the audio quality?

Thanks in advance
morganbjorn is offline  
Old 02-25-2019, 05:22 PM
  #31  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by morganbjorn View Post
I was looking into installing this into my 2015 GLA with NTG4.7 and I was wondering if the steering wheel voice control button works with Android Auto?
Also, did you connect using AUX or Bluetooth for audio connection? If you used AUX, how is the audio quality?

Thanks in advance
I have installed CARTIZAN (not sure how unichip works); No, as all you need to do is to say"ok google" then say the voice command( while with iPhone, a steering wheel button works)
Yes, but you have to activate it first in the ENGINEERING MENU. you will find many videos on the Utube on how to activate it.
EXCELLENT Quality.
MO. is offline  
Old 02-25-2019, 06:07 PM
  #32  
Newbie
 
Join Date: Jan 2019
Location: VA, USA
Posts: 6
Thanked 0 Times in 0 Posts
2015 GLA 250
Thumbs up

Thank you for super quick reply. The reason I asked about the steering wheel button is that I tend to have my music so loud that google can't hear me
I will use the mute button instead. Ordering it now.
morganbjorn is offline  
Old 02-25-2019, 06:13 PM
  #33  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by morganbjorn View Post
Thank you for super quick reply. The reason I asked about the steering wheel button is that I tend to have my music so loud that google can't hear me
I will use the mute button instead. Ordering it now.
Before you order check both Cartizan and Unichip and decide what you want to buy. Also check compatibility. Good luck!
MO. is offline  
Old 02-25-2019, 10:53 PM
  #34  
Newbie
 
Join Date: Jul 2013
Posts: 3
Thanked 0 Times in 0 Posts
2012 CLS550


I took a screen shot from an install video t hat I just found which is the first I've seen that shows where to put the adapter.
It looks like they removed the panel under the glove box (above the passenger's knees) and installed it on this panel. If it doesn't rattle, it might allow for better cooling than under the carpet.
Tunes is offline  
Old 02-25-2019, 11:19 PM
  #35  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by Tunes View Post


I took a screen shot from an install video t hat I just found which is the first I've seen that shows where to put the adapter.
It looks like they removed the panel under the glove box (above the passenger's knees) and installed it on this panel. If it doesn't rattle, it might allow for better cooling than under the carpet.
I agree with you, but I am not sure how easy to remove the panel under the glove box!!!!!! Also not sure if the screen cable ( from adapter to car screen) is long enough (I think it is NOT long enough, but don't remember). For me, it was easy to install it under the carpet (I used 3M mounting squares). Try and let me know.
I also want to mention something that is not mentioned anywhere in the installation manual. THERE ARE 2 OPTICAL FIBER CABLES CONNECTED TO THE MAIN HARNESS. YOU NEED TO REMOVE THEM FROM THE MAIN HARNESS (REMOVE THEIR SOCKET FROM THE HARNESS) AND CONNECT THEM TO THE PROVIDED HARNESS THAT GOES TO THE HEAD UNIT.
see this
https://youtu.be/lmldVyeoz08

Last edited by MO.; 02-26-2019 at 12:01 AM.
MO. is offline  
Old 03-10-2019, 09:29 AM
  #36  
Newbie
 
Join Date: Jan 2019
Location: VA, USA
Posts: 6
Thanked 0 Times in 0 Posts
2015 GLA 250
Is this safe/compatible with the HK option/amp?

I installed in my car and either coincidentally or accidentally did something to break my amp and needed it replaced. Before I retry I want to make sure it was something I did wrong not a straight up incompatibility.
morganbjorn is offline  
Old 03-10-2019, 02:11 PM
  #37  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by morganbjorn View Post
Is this safe/compatible with the HK option/amp?

I installed in my car and either coincidentally or accidentally did something to break my amp and needed it replaced. Before I retry I want to make sure it was something I did wrong not a straight up incompatibility.
How did you know that you break your amp?
MO. is offline  
Old 03-10-2019, 04:55 PM
  #38  
Newbie
 
Join Date: Jan 2019
Location: VA, USA
Posts: 6
Thanked 0 Times in 0 Posts
2015 GLA 250
Car is under warranty so I removed the box, put everything back together and took it to the dealer that spent all week trying to fix it.

I got it back yesterday, retried the install, got it working but the audio is all ****ed up. Totally distorted, and static like an untuned radio or something. Totally unusable. Sending it back.

I'll have to just use my phone screen
morganbjorn is offline  
Old 03-10-2019, 05:57 PM
  #39  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by morganbjorn View Post
Car is under warranty so I removed the box, put everything back together and took it to the dealer that spent all week trying to fix it.

I got it back yesterday, retried the install, got it working but the audio is all ****ed up. Totally distorted, and static like an untuned radio or something. Totally unusable. Sending it back.

I'll have to just use my phone screen
Cartizan? or Unichip?
I have installed CARTIZAN, and initially had the same audio issue (only when using the Adapter) the reason was that I didn't connect the 2 BLACK wires of the adapter together. (earth wires). You need to contact the seller and ask him/ her!
MO. is offline  
Old 03-11-2019, 04:35 AM
  #40  
Newbie
 
Join Date: Jan 2019
Location: VA, USA
Posts: 6
Thanked 0 Times in 0 Posts
2015 GLA 250
Originally Posted by MO. View Post
Cartizan? or Unichip?
I have installed CARTIZAN, and initially had the same audio issue (only when using the Adapter) the reason was that I didn't connect the 2 BLACK wires of the adapter together. (earth wires). You need to contact the seller and ask him/ her!
I have the CARTIZAN unit. I have contacted the seller a couple of times but had no reply. The 2 black wires you connected together, are those the loose ones on the adapter that are just capped off and not connected to anything?
morganbjorn is offline  
Old 03-11-2019, 09:16 AM
  #41  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by morganbjorn View Post
I have the CARTIZAN unit. I have contacted the seller a couple of times but had no reply. The 2 black wires you connected together, are those the loose ones on the adapter that are just capped off and not connected to anything?
Yes.
MO. is offline  
Old 03-11-2019, 06:44 PM
  #42  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by MO. View Post
Yes.
One is the earth wire of your adapter box, and the other is the earth wire of your vehicle. You will get a noisy audio if you don't connect them together.
MO. is offline  
Old 03-14-2019, 06:45 PM
  #43  
MO.
Junior Member
 
Join Date: Dec 2018
Posts: 31
Thanks: 0
Thanked 2 Times in 2 Posts
E350
Originally Posted by morganbjorn View Post
I have the CARTIZAN unit. I have contacted the seller a couple of times but had no reply. The 2 black wires you connected together, are those the loose ones on the adapter that are just capped off and not connected to anything?
Have you succeeded to overcome this problem?
MO. is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: New Project: MB E300 NTG4.5 CarPlay Proxy Kit


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: