Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
2010 E550 cooling fan running full speed at start up >

2010 E550 cooling fan running full speed at start up

Notices
E-Class (W212) 2010 - 2016: E 350, E 550

2010 E550 cooling fan running full speed at start up

 
Old 05-31-2018, 12:12 PM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Liked 0 Times in 0 Posts
2010 E550
2010 E550 cooling fan running full speed at start up

Car had been working fine until last night and the ac started blowing hot air now this morning the engine cooling fan is running wide open at start up ac is working now though
Tmaxxman is offline  
Old 06-07-2018, 09:14 PM
  #2  
Member
 
Join Date: Feb 2007
Location: Republic of Texas
Posts: 83
Likes: 0
Liked 16 Times in 15 Posts
W210 W203 W212
It sounds like you have a problem with your engine control module. They fail internally and send the wrong voltage to the fan controller, causing the fan to operate at 100%. But it could also be the fan getting the correct voltage but the controller doesn't operate the fan motor. Have to do some diagnostic before replacing parts.
MBENZTECH is offline  
Old 06-09-2018, 04:02 PM
  #3  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,066
Liked 301 Times in 260 Posts
2011 E550 P2 4M Sedan
There is a bulletin about radiator fan issues. Check out the stick and search for fan.
thefisch is offline  
Old 08-13-2018, 03:37 PM
  #4  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Liked 0 Times in 0 Posts
2010 E550
what do you mean check out the stick
Tmaxxman is offline  
Old 08-13-2018, 04:08 PM
  #5  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,308
Liked 363 Times in 340 Posts
2014 E550 4Matic Designo Diamond White and loaded up
The bulletin sticky notes at the top of the forum. My friend thinks everyone is hip and sometimes gets carried away.
Are you still fighting this issue after such a long time between posts??
KEY08 is offline  
The following users liked this post: KEY08
thefisch (08-13-2018)
Old 08-13-2018, 04:30 PM
  #6  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,066
Liked 301 Times in 260 Posts
2011 E550 P2 4M Sedan
You give me too much credit. I just forgot the 'y'.
thefisch is offline  
The following users liked this post: thefisch
KEY08 (08-13-2018)
Old 08-14-2018, 12:49 PM
  #7  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Liked 0 Times in 0 Posts
2010 E550
yes have not been driving the car due to the air ride has now quit working this is one problem after another with this car . I owned a 1999 C230 Kompressor for 11 years with not one issue I give it to my daughter and buy this and it is one issue after another
Tmaxxman is offline  
Old 09-08-2018, 02:50 PM
  #8  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Liked 0 Times in 0 Posts
2010 E550
Where is the fan relay located
Tmaxxman is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: 2010 E550 cooling fan running full speed at start up


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: