MBWorld.org Forums

MBWorld.org Forums (https://mbworld.org/forums/)
-   E-Class (W212) (https://mbworld.org/forums/e-class-w212-109/)
-   -   GOT AN AUXILIARY BATTERY? (https://mbworld.org/forums/e-class-w212/725216-got-auxiliary-battery.html)

stemags 10-25-2018 10:20 PM

GOT AN AUXILIARY BATTERY?
 
Well I didn't know I had one until the Economy feature started messing up,,that feature that shuts off the engine at a stop light when the car is warmed up.It also has something to do with the brake hold feature,because that started acting up too,...Car has 36K miles... And my CPO warranty doesn't cover it,,they consider it like a light bulb or some wear and tear item.Dealer said they started using them in 2014,,so beware.
Long story short,,they fixed it free,a 500$ part,plus labor,,holy crap.

Sarang 10-25-2018 11:02 PM

i changed the auxiliary battery in a 2010 E350 behind the dashboard it cost me an overpriced $75 for the part but i changed it myself easily. glad they fixed it for free but theres lots of DIY on it in the forums

Lolxa 10-25-2018 11:25 PM

my 2010 e550 cost me $25 bucks, a piece of electrical tape and 2 hours. $500 this is theft.

stemags 10-26-2018 12:37 AM

Guys,,was it the size of a motorcycle battery?

ItalianJoe1 10-26-2018 02:01 AM

Started after 2012 I believe using the larger battery in the trunk. The part should be no more than about $150 at a dealer, but yes they are not covered once out of bumper to bumper warranty, as batteries are a maintenance item. Same with the main battery.

This is super common though, there are literally dozens of posts about them failing and replacement. Not something new.

KEY08 10-26-2018 09:10 AM

Lots of posts regarding this.

stemags 10-26-2018 11:17 AM

OK,,didn't know about the common issue,,my 4th Benz and never had to deal with it,,,also explains why my trunk was all messed up when I got the car back.,,thanks for the info.

Lolxa 10-26-2018 12:01 PM

Mine started failing when the car was left outside for a couple hours in -35c weather, but was fine during the day or left in garage. Mine lasted 8 years. Battery was about the size a normal 355ml can.

KEY08 10-26-2018 02:15 PM


Originally Posted by Lolxa (Post 7586925)
Mine started failing when the car was left outside for a couple hours in -35c weather, but was fine during the day or left in garage. Mine lasted 8 years. Battery was about the size a normal 355ml can.

huh? This battery is considerably larger than a can of pop.
https://cimg6.ibsrv.net/gimg/www.mbw...1ff974a6a.jpeg

Lolxa 10-26-2018 02:18 PM


Originally Posted by KEY08 (Post 7587045)


huh? This battery is considerably larger than a can of pop.
https://cimg6.ibsrv.net/gimg/www.mbw...1ff974a6a.jpeg


Isn't that the main battery? In depending what year, its either up front beside the engine or in the trunk beside the spare tire. There's a secondary battery located below the instrument cluster in the driver seat. The secondary battery would be the auxiliary and powers secondary features such as blind spot assist and brake hold.

Edit: I was partially correct, depending on year auxiliary battery can be a bigger size in the rear.

KEY08 10-26-2018 02:36 PM

That photo is the auxiliary battery for several functions, including Eco start/stop which is what this entire thread is about. Not the dash battery for supporting your gear shift. That is my trunk

ItalianJoe1 10-26-2018 03:11 PM


Originally Posted by Lolxa (Post 7586925)
Mine started failing when the car was left outside for a couple hours in -35c weather, but was fine during the day or left in garage. Mine lasted 8 years. Battery was about the size a normal 355ml can.

Your early car has the tiny dash battery, the later ones have a larger battery in the trunk and no more battery in the dash.

stemags 10-26-2018 03:16 PM

Wtg Key,,that's the aux,,like I said,,like a mcy battery,,and same size as my grandson electric jeep.����.Thanks again to all.
BTW, where did they put the main batt,,under the seat?I haven't really looked around cause its been fine otherwise.

KEY08 10-26-2018 04:01 PM

Main battery is under the hood, passenger side by the firewall.

stemags 10-26-2018 04:09 PM

Awesome,,tx again.

Arrie 10-27-2018 01:32 AM

36k miles and CPO does not cover it. You should be under factory warranty unless you timed out on years. What year is your car?

stemags 10-27-2018 07:38 PM

Yes I get that now,,its a 14 with 36k miles.Basically the dealer felt ashamed that they sold me a CPO car with a weak ass Aux battery. So they did a good will repair, realizing I'm a loyal customer. Its supposed to be like new when u buy one of these cars,,they stepped up.

ygmn 10-28-2018 05:18 PM

CPO warranty covered mine TWICE in 1 year....

stemags 10-30-2018 02:19 PM

How did u kill that battery twice?

ygmn 10-30-2018 03:44 PM


Originally Posted by stemags (Post 7590370)
How did u kill that battery twice?

I figure the first one was a dud from sitting on dealer lot for year and not being driven before I bought car as CPO.

Second I figure was just bad battery or something unlucky as another dealer checked everything out in another state as I was traveling 1000 miles from home.

All I know is when they go out you lose all the cool features of the car and for me losing Distronic w/steering assist+ SUCKS as that is my favorite feature.

raja777m 10-30-2018 05:01 PM

does the aux batt. malfunction causes adaptive headlights to not work?

ygmn 10-30-2018 05:08 PM


Originally Posted by raja777m (Post 7590513)
does the aux batt. malfunction causes adaptive headlights to not work?

I do not remember on headlights

HOLD does not work; that I remember - another I like.
I wonder if those special BRAKING ones do not work?

Neither Dealer could explain 2 batteries failing within 9 months.
I did ask is it properly charging and they both stated yes.... so I write it off to bad batteries...

If it happens again though my volume will go up.

raja777m 10-30-2018 05:09 PM


Originally Posted by ygmn (Post 7590516)
I do not remember on headlights

HOLD does not work; that I remember - another I like.
I wonder if those special BRAKING ones do not work?

Neither Dealer could explain 2 batteries failing within 9 months.
I did ask is it properly charging and they both stated yes.... so I write it off to bad batteries...

If it happens again though my volume will go up.

yeah, distronic plus features, lane departure warning and HOLD feature won't work. Today I got Adaptive Highbeam doesn't work error message.

KEY08 10-31-2018 03:16 PM


Originally Posted by raja777m (Post 7590517)
Today I got Adaptive Highbeam doesn't work error message.

Highly possible this is related to the accident.

raja777m 11-01-2018 11:21 AM


Originally Posted by KEY08 (Post 7591399)
Highly possible this is related to the accident.

on the other hand, I'm skeptical I may need to replace my Aux battery.
https://www.eeuroparts.com/Parts/740...ry-SBC-S6590B/
or
https://www.fcpeuro.com/products/mer...hoCLNYQAvD_BwE

1. Is this the correct part?
2. This website provides lifetime warranty, just called them, and the lady on the phone said,
eEuroparts.com:
"if the battery doesn't hold the charge down the road 3 or 4 years after, order a new one and we will refund you once we receive your old/non-working one. "

and

"Bosch doesn't provide lifetime, but the warranty would go through us, no extra cost."


Does it seem legit? Mercedes dealer asked 150$ probably including installation, with 2 year warranty.
Which route to take?

Just dropped off my vehicle for hard 3rd gear shifting (the one that happened at 47k Miles) and they sent me with a loaner vehicle until that.


All times are GMT -4. The time now is 07:05 PM.


© 2019 MH Sub I, LLC dba Internet Brands