Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W213)
Mercedes Me Connect - General User Questions and Tips Thread >

Mercedes Me Connect - General User Questions and Tips Thread

Notices
E-Class (W213) 2016 -

Mercedes Me Connect - General User Questions and Tips Thread

 
Old 01-19-2019, 12:53 AM
  #76  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,630
Liked 146 Times in 131 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
I did talk with Tech support the other day and she was telling me they are going to issue a whole new update for the app as they were having a lot of problems and had to start from scratch with a lot of things. I think they released this stuff too early. I really question the security of the whole app thing too? It really seems it just was not ready for prime time yet.
2012 merc amg is offline  
Old 01-19-2019, 01:56 AM
  #77  
Member
 
Join Date: Oct 2018
Location: UK
Posts: 151
Liked 17 Times in 15 Posts
E Class Estate S213
Originally Posted by rbrylaw View Post
Since last night, I haven't been able to open or use the Me Connect app. Mercedes Me works fine for the E400, but the Me Connect app, just spins and spins. Are any of you not able to get the app to do anything?
i have been in touch with Mercedes Me Technical pretty much every day since November! I know they are updating a lot of the software and yesterday they did a shutdown for a period of time forvtechnical updates.

Might just need time time for real-activationon some models. Keep trying!
JDPEClassUK is offline  
The following users liked this post: JDPEClassUK
rbrylaw (01-19-2019)
Old 01-19-2019, 04:48 AM
  #78  
Senior Member
 
Join Date: Jan 2015
Posts: 350
Likes: 0
Liked 22 Times in 20 Posts
C class s205 250 bluetec executive line 4matic
It is morning here and it is working fine but i do find it inaccessible quite often. For that reason i keep a link to the web portal on my phone. It is not as clear but does do the same functions well for me we do not have remote start here and i do not have the remote parking.
i think sadly that mercedes is not quite there yet in its on line services and is playing catch up but i suspect they will eventually reach the same higher than mainstream abilities as they have in engineering terms with their on line software engineering. I suspect that they can attract some of the best talent to work for them.....
parkwood is offline  
The following users liked this post: parkwood
rbrylaw (01-19-2019)
Old 01-19-2019, 09:32 AM
  #79  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
I think Mercedes should have hired an outside App Developer to make these apps. They've never really had one that just works. Or at least works easily.

I was able to login again this morning. The two features I use the most are lock my car remotely and send an address to my car. I do like getting a notification on my Apple Watch if somehow I forgot to lock my car. I wish I could lock it from the watch though. To lock it, I have to go to my iPhone and hold the lock button there. Since I have a Cellular Apple Watch, there are some situations, where I don't have my phone with me.

For our friends in the Northeast, I hope the snow storm isn't too bad this weekend. It's going to sunny and 78 in Tampa, today!

Last edited by rbrylaw; 01-21-2019 at 11:14 AM.
rbrylaw is offline  
Old 01-21-2019, 11:10 AM
  #80  
Senior Member
 
stephos's Avatar
 
Join Date: Nov 2018
Location: UK
Posts: 492
Liked 46 Times in 45 Posts
MY19 E450 4MATIC Coupé
Yeah, I also mainly use the app to send addresses to the car. In fact, I just did it now and it worked as expected.
stephos is offline  
Old 01-21-2019, 01:00 PM
  #81  
Junior Member
 
Join Date: Dec 2009
Posts: 61
Likes: 0
Liked 2 Times in 2 Posts
Lexus LS600hL
This note from Mercedes in the Apple App Store:

They acknowledge that the remote start function is problematic and are working on it.....

Last edited by Helmar; 01-21-2019 at 01:02 PM.
Helmar is online now  
Old 01-21-2019, 01:16 PM
  #82  
Member
 
Join Date: Sep 2018
Location: Southern California
Posts: 125
Liked 14 Times in 13 Posts
E450 Coupe
Originally Posted by Helmar View Post
This note from Mercedes in the Apple App Store:

They acknowledge that the remote start function is problematic and are working on it.....
Interesting. I created up a Pin Number and tried Remote Start for the first time yesterday. It worked fine. Maybe its functionality comes and goes? I'll try it some more as time permits.
lensjack is offline  
Old 01-24-2019, 02:46 PM
  #83  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
FYI, on iPhone there is an update today for the Mercedes Me Connect App. It just says bug fixes and performance improvements, but doesn't list anything specific it addresses.
rbrylaw is offline  
Old 01-24-2019, 03:26 PM
  #84  
Member
 
mike82212's Avatar
 
Join Date: Jan 2014
Location: Baltimore, MD
Posts: 173
Liked 2 Times in 2 Posts
2018 E300 Luxury w/P2
I’m having some of the same problems with Mercedes Me. I am missing the “ Send to Benz” on my app. iPhone 8, iOS 12.1


after speaking to a number of people they said it’s a known problem but no fix in sight! Maybe with the next update?


mike82212 is offline  
Old 01-24-2019, 03:29 PM
  #85  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mike82212 View Post
I’m having some of the same problems with Mercedes Me. I am missing the “ Send to Benz” on my app. iPhone 8, iOS 12.1


after speaking to a number of people they said it’s a known problem but no fix in sight! Maybe with the next update?


Not sure what to tell you, but we have an E400, which uses Mercedes Me and an E450, which uses Mercedes Me Connect. I just opened the Mercedes Me app on my iPhone, running iOS 12.1.3 and Send2Benz is there and working just fine.

Maybe delete the App and then reinstall it.
rbrylaw is offline  
Old 01-24-2019, 03:33 PM
  #86  
Member
 
mike82212's Avatar
 
Join Date: Jan 2014
Location: Baltimore, MD
Posts: 173
Liked 2 Times in 2 Posts
2018 E300 Luxury w/P2
Thanks, done that, deleted the app and the cache, loaded on my wife’s phone all no luck!
mike82212 is offline  
Old 01-24-2019, 03:39 PM
  #87  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
I don't understand at all how the feature can be missing from your app, but is clearly on my app and functioning on my app? I could see if it was on the app, but not working, but to not even be on the main screen isn't logical. Take a screen shot of the main page of the Mercedes Me app and post it, if you don't mind.

Here's one from my iPhone, clearly showing Send2Benz




Last edited by rbrylaw; 01-24-2019 at 03:45 PM.
rbrylaw is offline  
Old 01-24-2019, 03:40 PM
  #88  
Senior Member
 
Join Date: Jan 2015
Posts: 350
Likes: 0
Liked 22 Times in 20 Posts
C class s205 250 bluetec executive line 4matic
Thanks for heads up. App kept crashing all day when i tried to open it so i have uninstalled and reinstalled and its working fine now.

do not have remote start but everything is working fine.
parkwood is offline  
The following users liked this post: parkwood
rbrylaw (01-24-2019)
Old 01-24-2019, 03:48 PM
  #89  
Member
 
mike82212's Avatar
 
Join Date: Jan 2014
Location: Baltimore, MD
Posts: 173
Liked 2 Times in 2 Posts
2018 E300 Luxury w/P2
Originally Posted by mike82212 View Post
Thanks, done that, deleted the app and the cache, loaded on my wife’s phone all no luck!

See, not there! Amazing, right?
mike82212 is offline  
Old 01-24-2019, 03:55 PM
  #90  
Senior Member
 
Join Date: Jan 2015
Posts: 350
Likes: 0
Liked 22 Times in 20 Posts
C class s205 250 bluetec executive line 4matic
I am using android on a samsung S9 maybe it is the apple iteration that is having probs.

the app in the screenshot has a very different look to my european android look.
parkwood is offline  
Old 01-24-2019, 04:06 PM
  #91  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mike82212 View Post



See, not there! Amazing, right?
Well that's just bizarre. The version on my iPhone as can be clearly seen, has the Send2Benz button. And it works. I have no clue why you don't have it. Do you have an active MBrace Account?
rbrylaw is offline  
Old 01-24-2019, 04:15 PM
  #92  
Member
 
mike82212's Avatar
 
Join Date: Jan 2014
Location: Baltimore, MD
Posts: 173
Liked 2 Times in 2 Posts
2018 E300 Luxury w/P2
Yes I have a active account. The remote start works,lock and unlock and locate my car. One of the reps I spoke to said “Mmmm, never seen that before “
mike82212 is offline  
Old 01-24-2019, 04:16 PM
  #93  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
Since as users we have no ability to add or remove anything inside an app such as Mercedes Me, it's a complete mystery your app is missing a key button. Do you feel special yet? (sorry)
rbrylaw is offline  
Old 01-24-2019, 04:18 PM
  #94  
Member
 
mike82212's Avatar
 
Join Date: Jan 2014
Location: Baltimore, MD
Posts: 173
Liked 2 Times in 2 Posts
2018 E300 Luxury w/P2
I feel left out!! Lol
mike82212 is offline  
Old 01-24-2019, 04:19 PM
  #95  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mike82212 View Post
I feel left out!! Lol
I can understand why. Sending an address to either our E400 or E450 is the absolute most used function we have.
rbrylaw is offline  
Old 01-24-2019, 04:24 PM
  #96  
Member
 
mike82212's Avatar
 
Join Date: Jan 2014
Location: Baltimore, MD
Posts: 173
Liked 2 Times in 2 Posts
2018 E300 Luxury w/P2
I agee, had it on my C300 and my Lexus and it’s so helpful. Can send a list from home and have it waiting for me. So I really miss it
mike82212 is offline  
Old 01-24-2019, 04:30 PM
  #97  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mike82212 View Post
I agee, had it on my C300 and my Lexus and it’s so helpful. Can send a list from home and have it waiting for me. So I really miss it
When I got my E450 and couldn't get the Me Connect App to connect with my car, I called MBUSA daily and bugged them to death until they got some programmer, sitting in a basement in some remote city in Germany (literally) to figure out why my car wouldn't connect and get it connected. I'd recommend you call MBUSA and have them elevate this issue and complain until they resolve it. There's simply no reason on an iPhone using the very same app I use, you shouldn't have the Send2Benz button. Complain, Complain, Complain. Have them create a ticket number. Refer to that ticket number every time you call. Sad to say, but being a thorn in their side does get results.
rbrylaw is offline  
Old 01-24-2019, 05:33 PM
  #98  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,630
Liked 146 Times in 131 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
Still no luck on my e450 wagon getting it to remote start or unlock/lock doors. Works fine on the same app on my e450 Cabriolet, very strange. Got a complaint into mercedes, so far they are doing nothing. Had me take a couple screen shots of the app page where it's not working. It seems like it must be something within the car like the hermes module. I asked the rep I spoke with at mercedes connect if I should set up an appointment at the dealer, he said not yet. Strange because everything else on the wagon works within the app such as tire pressure readings and showing all other functions, it's just that I cannot get the car to do anything remotely. Tried everything I can think of, loading and unloading app, signing in and out, etc. Cannot control anything on the car from the computer portal either on that car, the Cabrio is fine. I should probably delete everything and try the app just using the wagon, maybe there is some kind of bug when using two cars on the app. Strange though because it worked fine for around a month, the last month it has been kaput.

Last edited by 2012 merc amg; 01-24-2019 at 05:37 PM.
2012 merc amg is offline  
Old 01-24-2019, 06:44 PM
  #99  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,325
Liked 268 Times in 223 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by 2012 merc amg View Post
Still no luck on my e450 wagon getting it to remote start or unlock/lock doors. Works fine on the same app on my e450 Cabriolet, very strange. Got a complaint into mercedes, so far they are doing nothing. Had me take a couple screen shots of the app page where it's not working. It seems like it must be something within the car like the hermes module. I asked the rep I spoke with at mercedes connect if I should set up an appointment at the dealer, he said not yet. Strange because everything else on the wagon works within the app such as tire pressure readings and showing all other functions, it's just that I cannot get the car to do anything remotely. Tried everything I can think of, loading and unloading app, signing in and out, etc. Cannot control anything on the car from the computer portal either on that car, the Cabrio is fine. I should probably delete everything and try the app just using the wagon, maybe there is some kind of bug when using two cars on the app. Strange though because it worked fine for around a month, the last month it has been kaput.
Did you get a case number? Call them daily and complain. They need to elevate this to that one dude in a basement in some unnamed German City, who does the programming on the Me Connect App.
rbrylaw is offline  
Old 01-24-2019, 07:27 PM
  #100  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,630
Liked 146 Times in 131 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
Yes there is a claim number. I notice today the app is all screwed up. Taking forever to load and freezing up. Everything else with these cars is great other than this app. I had some fun in some curved roads yesterday in the wagon. It has a real nice solid feel to it in corners and is fun to drive in sport plus mode. I actually really like the sounds the twin turbo makes when revving in sport plus mode. Has some nice popping sounds to it too through the exhaust on decell. It’s kind of addicting.
2012 merc amg is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Mercedes Me Connect - General User Questions and Tips Thread


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: