Notices
GL Class (X164) 2007-2012: GL320CDI, GL420CDI, GL450, GL550

Transmission Wouldn't Shift

 
Old 11-25-2013, 02:12 PM
  #51  
MBWorld Fanatic!
 
Join Date: Aug 2003
Location: In my garage
Posts: 6,044
Received 213 Likes on 195 Posts
E55, SL600, GL450, GL63
Originally Posted by hkm2010 View Post
I have 2011 GL 350 that wouldn't shift from park to drive. Tried restarting multiple times without success. Wonder if any 2011 GL's having the same "conductor plate" problems. Will call dealer on Monday. Any input would be appreciated before dealing with dealer. Bought MB extended warranty. Hope they don't pull this on me.

*****If your car is without warranty, they will recommend to change it.*******
*****If your car is still under manufacture or extended warranty, they will try to ignore the problems.*****
It's a very well known problem. They should fix without giving you any bs.
BlownV8 is offline  
Old 11-28-2013, 12:55 PM
  #52  
Newbie
 
Join Date: Feb 2011
Location: ND
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
2011 GL 350
According to the service advisor, the problem was low voltage in the battery that caused the truck not shift. They replaced the battery and did some software update. I thought that the biggest load on battery was during starting, and once started, it shouldn't cause problems with shifting. My truck had no problem starting. Glad I still have warranty.
hkm2010 is offline  
Old 05-01-2015, 12:27 PM
  #53  
Newbie
 
nu95edo's Avatar
 
Join Date: May 2014
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
GL 450 2007
My GL 450 , 2007 is giving me a headache with transmission, I will be driving, then it will slow down. Will have to turn off the engine and back on, Then it go for another 30 days.
Now its stuck in 1st gear. Check engine light came on. The mechanic is saying its not the Transmission sensor or throttle valve, but solenoid.
Can someone help me I have spent over $2500 , on this
nu95edo is offline  
Old 08-29-2016, 05:42 PM
  #54  
Junior Member
 
Join Date: Jul 2014
Posts: 51
Likes: 0
Received 1 Like on 1 Post
2008 GL320 CDI
We drove about 45 miles on Sunday and the truck sat in a parking garage for about 3 hours. When we went to leave, I turned on the truck to get the A/C running while I loaded the kids in their seats. When I got into go, I tried putting the truck in reverse and nothing. It went to neutral, but would go anywhere else. I then saw the yellow warning arrow and knew something was wrong. After trying to put the car in park, I turned off the ignition, and when the truck was restarted I had no issue.

Based on this thread I'm going to pull out my extended warranty to ensure I'm covered, but is there going to be a code? Or do I need to guide my indy on next steps?
joshd2012 is offline  
Old 10-03-2016, 10:13 AM
  #55  
Newbie
 
Join Date: Apr 2016
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2009 GL450
I just opened a thread similar to this but wanted to piggy-back off of this thread after further searching.

My truck went to the detailer yesterday working perfectly fine but after he finished the job, the vehicle wouldn't go into reverse now. It will go into park, neutral, and drive without issue but reverse won't register like it's even being hit. I don't have any errors on the screen. He did say he had to move the steering cluster all the way in/out to clean it and then when he tried to back it out, it wouldn't go into reverse. He then moved the steering wheel out a little further (electronically) and tried again and it went into reverse. By the time I got there though it wouldn't move into reverse in any of the 100 different positions I tried moving the steering column to.

Could this be an issue with the stalk since it won't even register? Were people here able to get the truck to highlight R like you are in reverse but it just wouldn't go into reverse or does it even move the selector on the screen to R?

Any thoughts?
Sid3ways is offline  
Old 10-03-2016, 11:54 AM
  #56  
alx
MBWorld Fanatic!
 
Join Date: Dec 2004
Posts: 4,213
Received 195 Likes on 170 Posts
if screen doesnt register the gear change it is your column selector.

if screen registers gear change, but tranny doesnt engage as needed it is usually the gear selector solenoid in the tranny.

both scenarios are easily confirmed via star/das which has specific test cases for both failures.

gear selector failures are not common and usually denote previous abuse.

solenoid failures are somewhat common, but an easy replacement.
alx is offline  
Old 10-03-2016, 08:56 PM
  #57  
Newbie
 
Join Date: Apr 2016
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2009 GL450
Thank you for the reply alx. As I stated, I left the car at the shop since it wouldn't back up. Today I ran back to the truck to test it out (it sat for 24 hours). I put it in reverse after I started it and everything is now working 100% every time I attempt to go into any gear.

It makes me wonder if while cleaning they somehow sprayed moisture at the base of the stalk or something and it messed with the contacts until it dried up? Regardless, things seem to be working ok for now. It appears it is time to trade the vehicle in as I don't want to take any more chances.
Sid3ways is offline  
Old 03-01-2018, 12:27 PM
  #58  
Newbie
 
Join Date: Mar 2018
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
GL 350 Bluetech
Thank you all!

I was very happy to stumble upon this discussion thread as my beautiful GL 350 Bluetec, model year 2015, has this transmission problem and it is currently at the Mercedes Wilsonville, OR dealer for the 3rd time. The dealer while very polite and professional, they were scratching their heads on what the problem could be. I sent them this article and I trust the root cause of the problem will be remediated. I would have been really disappointed if I was forced to trade this car for something else. I love the torque of the diesel engine and I like the elegance of the interior cabin with the center display mounter inside the dashboard.

Anyway, a big 'Thank You' to all of you.
usaszerelem is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Transmission Wouldn't Shift


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: