Auto headlights pet peeve - MBWorld.org Forums

Notices
GL Class (X164) 2007-2012: GL320CDI, GL420CDI, GL450, GL550

Auto headlights pet peeve

 
Old 01-19-2019, 04:39 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 30
Thanked 3 Times in 3 Posts
GL 550
Auto headlights pet peeve

So I dont know if something is not set right or thatís just the way the Auto headlights work, but on my 2011 GL whether I have light position in Off or Auto, they still come on if it gets dark, go into a garage, etc. Kind of drives me up the wall, whats the point of having the ď0Ē position if they are not going to give me a choice and come on regardless? Am I missing something here?

Does anyone know how to change/fix this?
Iceytys is offline  
Old 01-19-2019, 04:56 PM
  #2  
Member
 
Join Date: Nov 2018
Location: Dallas Texas USA
Posts: 130
Thanks: 0
Thanked 12 Times in 11 Posts
2019 C43 Sedan
Maybe, if you are outside and the knob is in OFF and the headlights are ON then you need to make a trip to the dealer or troubleshoot it yourself. Maybe a broken headlight switch. If you have the Command system there is a setting to keep the headlights on for a certain period of time after the car is turned off and you exit. That will override the headlight switch.
Tirgoman is offline  
Old 01-19-2019, 06:14 PM
  #3  
Newbie
 
Join Date: Jan 2019
Posts: 5
Thanks: 0
Thanked 2 Times in 2 Posts
e55
I never had an issue or seen anyone when position at 0 and their headlights still auto come on. Error in wiring?
Def an issue.
savagepete is offline  
Old 01-19-2019, 06:31 PM
  #4  
Super Member
 
Join Date: May 2015
Location: Allentown, PA
Posts: 742
Thanked 42 Times in 41 Posts
'08 GL 320 CDI
Are you sure you're not getting confused with your DRL's?

Absent of that, are you saying that if you're in your driveway with the switch set to "0" that the lights are off. Then when you pull into the garage, the lights come on? That's not right. I can turn my lights completely off in the middle of the night and they stay off.
DennisG01 is offline  
Old 01-19-2019, 06:32 PM
  #5  
Super Member
 
rustybear3's Avatar
 
Join Date: Jul 2018
Location: Greater Cleveland area
Posts: 668
Thanked 58 Times in 51 Posts
2019 Dune Silver Metallic E-450 Mercedes Cabriolet
My guess is a bad switch.
rustybear3 is online now  
Old 01-19-2019, 06:52 PM
  #6  
Junior Member
 
quron_southwest's Avatar
 
Join Date: Dec 2015
Location: Los Angeles, CA
Posts: 71
Thanked 3 Times in 3 Posts
2010 GL350
Position "0" with DRLs set to ON in the instrument cluster is the same as postion "AUTO" on the headlamp switch. It's stupid IMO, but there's a 'safety reason' behind it. If you turn off the DRL function in the IC and switch the headlamp switch to "0" then all exterior lights stay off completely. Position "AUTO" still works as intended but no DRLs in bright ambient conditions. If you have a facelifted model the DRLs only turn on when the low beams turn on. Hope this helps.
quron_southwest is offline  
Old 01-19-2019, 09:07 PM
  #7  
Member
 
Join Date: Nov 2018
Location: Dallas Texas USA
Posts: 130
Thanks: 0
Thanked 12 Times in 11 Posts
2019 C43 Sedan
Cone think about it there could be a bad relay. First question, did this just start or has it been that way since 2011? If it just started then check the relay. The headlight switch doesn't actually supply power to the headlights, it powers a relay that supplies power to the headlights. The relay could be stuck. The contacts could be stuck closed. Could try tap it gently or just replace, they are cheap and just plug in. I think they're in the fuse panel. Get out the manual that body reads or the inside of the fuse panel cover should I'd it. Or the headlight switch has gone bad.
Tirgoman is offline  
Old 01-19-2019, 10:33 PM
  #8  
Super Member
 
Join Date: Nov 2017
Location: Bethesda, MD
Posts: 548
Thanked 39 Times in 38 Posts
2010 Mercedes GL450; 2000 Mercedes ML55 AMG; 2016 VW GLI SEL Stick!!!
Originally Posted by Tirgoman View Post
Cone think about it there could be a bad relay. First question, did this just start or has it been that way since 2011? If it just started then check the relay. The headlight switch doesn't actually supply power to the headlights, it powers a relay that supplies power to the headlights. The relay could be stuck. The contacts could be stuck closed. Could try tap it gently or just replace, they are cheap and just plug in. I think they're in the fuse panel. Get out the manual that body reads or the inside of the fuse panel cover should I'd it. Or the headlight switch has gone bad.

At position 0 headlights still come on. Its to stop idiots from driving around with their lights off.
(It irritates me immensely more how many people drive around with lights off at night. So I'm happy with mb choice)


If it bothers you change the knob....😝
...to the parking lights


So at least from 2010 onwards

Last edited by kombifan; 01-19-2019 at 10:36 PM.
kombifan is offline  
Old 02-10-2019, 05:58 PM
  #9  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 81
Thanked 0 Times in 0 Posts
2009 GL550 ; 2005 Lexus LS430
I definitely need to check my relay, and or switch. I noticed today that no matter what time of day and with the switch in the "0" position, my headlights come on as soon as I start my truck.
rich30769 is offline  
Old 02-10-2019, 06:08 PM
  #10  
Super Member
 
Join Date: May 2015
Location: Allentown, PA
Posts: 742
Thanked 42 Times in 41 Posts
'08 GL 320 CDI
Originally Posted by rich30769 View Post
I definitely need to check my relay, and or switch. I noticed today that no matter what time of day and with the switch in the "0" position, my headlights come on as soon as I start my truck.
Originally Posted by DennisG01 View Post
Are you sure you're not getting confused with your DRL's?
\
What setting do you have your DRL set at in the setup in the dash display info?
DennisG01 is offline  
Old 02-10-2019, 06:43 PM
  #11  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 81
Thanked 0 Times in 0 Posts
2009 GL550 ; 2005 Lexus LS430
Originally Posted by DennisG01 View Post
What setting do you have your DRL set at in the setup in the dash display info?
I will check for that first chance that I get but, it didn't do that before and I haven't changed anything so, I find this to be weird. Maybe I did change it and just didn't realize it.
rich30769 is offline  
Old 02-10-2019, 08:50 PM
  #12  
Super Member
 
Join Date: May 2015
Location: Allentown, PA
Posts: 742
Thanked 42 Times in 41 Posts
'08 GL 320 CDI
Originally Posted by rich30769 View Post
I will check for that first chance that I get but, it didn't do that before and I haven't changed anything so, I find this to be weird. Maybe I did change it and just didn't realize it.
Oh, I see. It wasn't clear from your first post. I guess check it just to be sure, but yeah, it'd be odd for it change by itself. Maybe a battery change could have reset it - I dunno.

Last edited by DennisG01; 02-11-2019 at 09:43 AM.
DennisG01 is offline  
Old 02-10-2019, 09:00 PM
  #13  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 81
Thanked 0 Times in 0 Posts
2009 GL550 ; 2005 Lexus LS430
Originally Posted by DennisG01 View Post
Oh, I see. It wasn't clear from your first post. I guess check it just to be sure, but yeah, it'd be odd for it change by itself. Maybe a battery change coudl of reset it - I dunno.
I did just disconnect the battery in order to reset the clock. That could have possibly done it.
rich30769 is offline  
Old 02-10-2019, 10:32 PM
  #14  
Super Member
 
Join Date: Jun 2010
Location: San Diego, CA, USA
Posts: 559
Thanked 57 Times in 49 Posts
2007 GL450
Originally Posted by quron_southwest View Post
Position "0" with DRLs set to ON in the instrument cluster is the same as postion "AUTO" on the headlamp switch.
Only partially correct. This only applies to the headlights. The other bulbs do not go perma-on.
eric_in_sd is offline  
Old 02-11-2019, 06:40 AM
  #15  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 81
Thanked 0 Times in 0 Posts
2009 GL550 ; 2005 Lexus LS430
Originally Posted by DennisG01 View Post
Oh, I see. It wasn't clear from your first post. I guess check it just to be sure, but yeah, it'd be odd for it change by itself. Maybe a battery change coudl of reset it - I dunno.
Problem solved, had to change it back in the dash settings, then decided to leave it on constant anyway.
rich30769 is offline  
Old 02-11-2019, 09:43 AM
  #16  
Super Member
 
Join Date: May 2015
Location: Allentown, PA
Posts: 742
Thanked 42 Times in 41 Posts
'08 GL 320 CDI
Originally Posted by rich30769 View Post
Problem solved, had to change it back in the dash settings, then decided to leave it on constant anyway.
At least that was a "freebie" fix!
DennisG01 is offline  
The Following User Says Thank You to DennisG01 For This Useful Post:
rich30769 (02-11-2019)
Old 02-11-2019, 11:00 AM
  #17  
Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 30
Thanked 3 Times in 3 Posts
GL 550
Originally Posted by DennisG01 View Post
What setting do you have your DRL set at in the setup in the dash display info?
DRL is set to On. If I turn them to off the LED units dont turn on....so assume it's the proper setting
Iceytys is offline  
Old 02-11-2019, 07:20 PM
  #18  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 1 Time in 1 Post
E550, Gl550,
Yea weird. Mine are like that too. Mercedes Benz 2011 GL550. I leave the DRLs "On" in the dash/speedometer cluster portion. If I try to turn the headlights off when I'm in a dark location, they stay on, even at the "0" portion.
Tek.To is offline  
Old 02-11-2019, 08:42 PM
  #19  
Super Member
 
Join Date: May 2015
Location: Allentown, PA
Posts: 742
Thanked 42 Times in 41 Posts
'08 GL 320 CDI
Have any of you guys checked the manual to see if there's a way to turn them off (again, mine is a '08, but they stay off if I want them to)? Maybe some sort of switch-turning combination?

Last edited by DennisG01; 02-11-2019 at 11:10 PM.
DennisG01 is offline  
Old 02-11-2019, 09:19 PM
  #20  
Super Member
 
Join Date: Nov 2017
Location: Bethesda, MD
Posts: 548
Thanked 39 Times in 38 Posts
2010 Mercedes GL450; 2000 Mercedes ML55 AMG; 2016 VW GLI SEL Stick!!!


Originally Posted by Tek.To View Post
Yea weird. Mine are like that too. Mercedes Benz 2011 GL550. I leave the DRLs "On" in the dash/speedometer cluster portion. If I try to turn the headlights off when I'm in a dark location, they stay on, even at the "0" portion.
yep.

It says they tuen off if you engage the park brake. Have yet to try that.
kombifan is offline  
Old 02-11-2019, 11:15 PM
  #21  
Super Member
 
Join Date: May 2015
Location: Allentown, PA
Posts: 742
Thanked 42 Times in 41 Posts
'08 GL 320 CDI
It appears there are different "rules" the car follows depending on whether it was originally sold in Canada or the US, as well.
DennisG01 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Auto headlights pet peeve


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: