Go Back  MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > M-Class (W163)
Ml320 (w163) Front window washer liquid doesn't work >

Ml320 (w163) Front window washer liquid doesn't work

Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Ml320 (w163) Front window washer liquid doesn't work

 
Old 03-23-2019, 07:42 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
ML 320 2001
Ml320 (w163) Front window washer liquid doesn't work

Hey everybody,

The front window washer liquid doesn't arrive. There's liquid, the sprinklers (holes) are clean, pump works (I hear the pump when I activate it), on rear window it works great, checked fuse as well. At first activation there's even small drops dripping out of sprinklers.
I don't really know what to check anymore...

Cheers, Den
Denadaen is offline  
Old 03-23-2019, 10:42 PM
  #2  
Senior Member
 
Join Date: Nov 2015
Posts: 474
Received 35 Likes on 34 Posts
02w163ML500 / 97w210E50AMG / 99w202C230k / 95w124500e-wip
Originally Posted by Denadaen View Post
Hey everybody,

The front window washer liquid doesn't arrive. There's liquid, the sprinklers (holes) are clean, pump works (I hear the pump when I activate it), on rear window it works great, checked fuse as well. At first activation there's even small drops dripping out of sprinklers.
I don't really know what to check anymore...

Cheers, Den
Did you check the lines themselves? (you didnt clarify and only mentioned the spray nozzles, I presume...)
khomer2 is offline  
Old 03-23-2019, 10:50 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
ML 320 2001
After I sent the message I actually found a post finally about a guy taking of the gril where the nozzles are and I didn't check this yet.
I did blow on one of the tubes that come start at the watertank and I didn't get to blow anything through. I thought there might be valves after that.
But I'm gonna check under the grill and disconnect over there if I get to take the grill off. Shouldn't be too complicated... 😁
Denadaen is offline  
Old 03-23-2019, 10:52 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
ML 320 2001
Just read about an eventual melted nozzle... But all of them melted is really too little of luck... 🤔
Denadaen is offline  
Old 03-24-2019, 06:48 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
ML 320 2001
So, right before the nozzles is this 'oneway' connector which was plugged. Didn't get to unplug it, so I drilled right through it.
It worked for a little while untill there was no more water....
Because on the watertank are 2 black, 10cm long things attached which are connected to the tank through a hole. There's a washer between the thing and the tank... 1 of these washer's leaking/not sealing anymore so water pours out...
So, New adventure:I have to find a new washer, well might as well change both of them while I'm at it....
Denadaen is offline  
Old 03-24-2019, 11:05 AM
  #6  
Member
 
we47b1me's Avatar
 
Join Date: Sep 2018
Location: Los Angeles, CA
Posts: 183
Received 19 Likes on 19 Posts
2015 ML250 Bluetec, 2012 C250 Sport, 2002 ML500 Sport (sold)
Originally Posted by Denadaen View Post
So, right before the nozzles is this 'oneway' connector which was plugged. Didn't get to unplug it, so I drilled right through it.
It worked for a little while untill there was no more water....
Because on the watertank are 2 black, 10cm long things attached which are connected to the tank through a hole. There's a washer between the thing and the tank... 1 of these washer's leaking/not sealing anymore so water pours out...
So, New adventure:I have to find a new washer, well might as well change both of them while I'm at it....
You're talking about the check valve and the actual pumps for the two washing systems. Get to know the truck beyond "things" 😁
we47b1me is offline  
Old 03-24-2019, 11:13 AM
  #7  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
ML 320 2001
Yes, thanks a lot, that's what I was looking for... Sorry, I didn't mean to be irrespectfull with my 'things'.
Do you happen to know where to find the washers for the pump to the tank?
Denadaen is offline  
Old 03-24-2019, 11:55 AM
  #8  
Member
 
we47b1me's Avatar
 
Join Date: Sep 2018
Location: Los Angeles, CA
Posts: 183
Received 19 Likes on 19 Posts
2015 ML250 Bluetec, 2012 C250 Sport, 2002 ML500 Sport (sold)
Originally Posted by Denadaen View Post
Yes, thanks a lot, that's what I was looking for... Sorry, I didn't mean to be irrespectfull with my 'things'.
Do you happen to know where to find the washers for the pump to the tank?
Not a washer. It's a grommet.

https://www.autohausaz.com/catalog/k.../washer%20pump
we47b1me is offline  
Old 03-24-2019, 04:10 PM
  #9  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
ML 320 2001
Thank you so much !
Only thing is that they charge me 56$ of postage for 3.26$ of grompets... bit overdone...
Denadaen is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Ml320 (w163) Front window washer liquid doesn't work


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: