MBWorld.org Forums - View Profile: ATT

Go Back  MBWorld.org Forums > Members
Reload this Page >

ATT's Profile

Notices

ATT ATT is offline

Member

About Me

  • About ATT
    Vehicle(s) I drive
    2012 C63 BS 2012 SLK 350 2014 CLA 45

Statistics

Total Posts
Visitor Messages
Total Likes
General Information
  • Last Activity: 06-23-2017 02:25 AM
  • Join Date: 01-18-2009
  • Referrals: 0

Visitor Messages

Showing Visitor Messages 1 to 4 of 4
  1. 06-15-2012 02:06 PM
    sorry.. i'm working on a 1989 300E
  2. 06-15-2012 02:05 PM
    having a fuel issue. ran it out of gas (i know, i know...) since then the check engine light came on, and it would die out, only to restart later. i replaced the fuel pump relay, the light stayed off, and it seemed fine. (it has always idled a little low/rough since i got it last summer). now it will start and shut off very soon after. i have been looking into this, and i am (only) guessing it is either the fuel pump(s), fuel filter, or am i way off? any thoughts are appreciated, thanks alot.
  3. 01-25-2012 02:50 AM
    ATT
    Sorry reply to you so late, after the replacemnt of the cam and lifters so far after 5000 km no sign of the same problem. Make sure they change both and not eithrt one.
  4. 12-07-2011 12:55 AM
    ATT, I saw on your thread that the dealer replaced your lifters and camshafts. Did that resolve the issue you were having? Were there any concerns about any other damage that may have been caused? The dealer just told me they were going to have to do the same thing with my C63 once they have parts in...
    Thanks in advance,
    Adam

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.