MBWorld.org Forums - View Profile: technsandiego

Go Back  MBWorld.org Forums > Members
Reload this Page >

technsandiego's Profile

Notices

technsandiego technsandiego is offline

Junior Member

About Me

  • About technsandiego
    Vehicle(s) I drive
    1998 Mercedes Benz E320 210
    Country of Residence
    US

Statistics

Total Posts
Visitor Messages
Total Likes
General Information
  • Last Activity: 09-27-2018 03:06 PM
  • Join Date: 05-23-2017
  • Referrals: 0

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. 09-18-2018 09:39 PM
    I was on my way home today, in stop and go traffic, when the BAS light came on followed by the Anti-Skid light. I pulled off the freeway, shut the car off, and all the prior warning lights went off. Then about 10 miles down the freeway it happened again. I drove it home and parked it, checked all the fuses and started it up again. I put my foot on the brake and the BAS light came on. I fiddled with the switch, turning it on and off but the light stayed on until I shut it off which reset the BAS light, but It continues to come on when I apply the brakes. Then to make matters worse the Check Engine light came on. I turned the key on to engage the system and a warning light came on saying that the oil level was to high. I checked the dipstick and it's right where it's always been no loss of oil and nothing to indicate that the oil was contaminated. Any ideas would be greatly appreciated.
    1989 E320
    Standard 4 Door Sedan (not 4Matic)
    238,470 miles

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.