Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > New S-Class (W222)
Climate Control AUTO Rocker Misbehaving? >

Climate Control AUTO Rocker Misbehaving?

Notices
New S-Class (W222) 2014-Present

Climate Control AUTO Rocker Misbehaving?

 
Old 07-20-2017, 01:08 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jul 2017
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2015 W222
Climate Control AUTO Rocker Misbehaving?

Hey everyone, I've been having an occasional weird glitch on my 2015 S-Class & after going to the dealership multiple times, even reaching out to corporate—they're "investigating" it, I've decided to see if anyone has experienced a similar problem. Upon starting the vehicle, the AUTO rocker for the climate control is initiated (lit red), but COMAND displays the climate control in manual mode. Even disengaging the AUTO rocker and re-engaging doesn't update the display; however, changing it programmatically through COMAND does update the display to show that it is indeed in AUTO mode. A simple restart of the vehicle solves the problem. That being said, this has been intermittently popping up for the past ~2 years, I believe it began after they updated the system during a servicing. I'll post an update once (if) I hear back from corporate. My guess is that it's a software bug since they ran their diagnostics numerous times at the dealership to no avail. Let me know if anyone has had similar issues and have hopefully had it resolved.


My problem. According to the display, it's in manual mode at the third setting. According to the rocker, AUTO is engaged.



What it should display.
big_Z is offline  
Old 07-20-2017, 08:14 AM
  #2  
Super Member
 
Join Date: Jan 2007
Posts: 764
Likes: 0
Received 44 Likes on 38 Posts
S, GL
Happens to me, too

There's a bulletin for a "fix" had it performed but issue remained, haven't taken it back a second time
jenz is offline  
Old 07-20-2017, 08:18 AM
  #3  
Super Member
 
Join Date: Apr 2016
Posts: 858
Received 85 Likes on 74 Posts
2014 S550 AMG, 2017 XT5
Was A/C Rest pushed or is that part of the problem. How is the Rear set at this time also? Make sure you go into settings and choose SYNC. If not, I know that if someone or something makes a change on the passenger side or the rear, the systems will try to keep everyone happy. In my opinion, the AC/Rest button should be changed to SYNC, this way if any passenger makes changes, by simply hitting the SYNC, all will match the Drivers Settings. The only way I know to fix this is to go into settings and manually choose SYNC.
Possibly that's it....
Nice Ride is offline  
Old 07-20-2017, 11:04 AM
  #4  
Senior Member
 
Join Date: Jan 2017
Location: Marina Del Rey, CA
Posts: 449
Received 51 Likes on 47 Posts
2015 MBZ S 550
Does it affect the way the climate control works or is it purely a " visual " thing? Seems like if it were just a visual thing it wouldn't be that big of a deal, especially if the climate control does what you ask it to do.

Am I missing something here?
Socalsteve is offline  
Old 07-20-2017, 09:30 PM
  #5  
Super Member
 
Join Date: Apr 2016
Posts: 858
Received 85 Likes on 74 Posts
2014 S550 AMG, 2017 XT5
Originally Posted by Socalsteve View Post
Does it affect the way the climate control works or is it purely a " visual " thing? Seems like if it were just a visual thing it wouldn't be that big of a deal, especially if the climate control does what you ask it to do.

Am I missing something here?
Assuming the problem is AUTO is not working properly. If you hit AUTO, it will light up. It takes full control of temp, compressor and fan speed to maintain the temp. I have Quad, one of the quirks I hate is if the passenger changes the temp to say 75, had the driver side is set to 70, the two constantly fight each other to maintain the temps in the area. Since no SYNC button exists on the dash, you need to go into settings and choose Sync so they both match and are controlled by the Driver again.

The fact that the button on the driver side has AUTO lit, you should not see a picture of a fan, you should see the word AUTO as in the photo. If you set Auto on the drivers side and you tap the fan speed lower, the temp will remain as auto but the fan will now be manual until you hit auto again and the auto light will go out.

I don't understand why the REST button is lit. I believe you only use that when you leave someone sitting in the car and you take your key
with you. It will keep the fan on low and circulate the residual heat from the engine in the cabin in the winter and the AC in the summer.

After looking at the photo again, his shows AC/REST. On my 2014, it is only REST. To turn off the compressor, you must go into settings to turn it off. Looks like they now allow you to turn the AC off from the same button without going into settings. So on cooler days, you don't have the compressor running when it is not needed, but you want the Climate Control to still work using the ambient air.

Last edited by Nice Ride; 07-20-2017 at 09:36 PM.
Nice Ride is offline  
Old 07-27-2017, 04:53 PM
  #6  
MBworld Guru
 
Rudeney's Avatar
 
Join Date: Dec 2009
Location: Birmingham, AL
Posts: 10,127
Received 765 Likes on 714 Posts
CURRENT: 2011 SL550, 2010 ML350, FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
No, iCarsoft only reads and resets diagnostic codes. To change control unit coding, you need SDS.
Rudeney is offline  
Old 07-27-2017, 05:49 PM
  #7  
Super Member
 
BeachBunny's Avatar
 
Join Date: May 2014
Location: Florida
Posts: 582
Received 38 Likes on 34 Posts
2018 E300 Luxury - P3 and more
There's definitely a service bulletin out on that:

LI82.85-P-060796 FEB15 – 222, 217, 205 w/COMAND online (code 531) and code 805 when AUTO button on A/C is pressed no change is indicated in central display. Although auto function is active (red LED) instead of AUTO there are digits for air distribution & blower. AUTO may display but disappear sporadically when vehicle is started or screen content changes. AUTO function is not impaired, software remedy expected to be available 5/15.

See: https://mbworld.org/forums/new-s-cla...ml#post6350706

I'd have the dealer re-flash it. Sounds like they may not have properly updated your car.
BeachBunny is offline  
Old 07-27-2017, 06:43 PM
  #8  
Super Member
 
Join Date: Jan 2007
Posts: 764
Likes: 0
Received 44 Likes on 38 Posts
S, GL
Originally Posted by BeachBunny View Post
There's definitely a service bulletin out on that:

LI82.85-P-060796 FEB15 – 222, 217, 205 w/COMAND online (code 531) and code 805 when AUTO button on A/C is pressed no change is indicated in central display. Although auto function is active (red LED) instead of AUTO there are digits for air distribution & blower. AUTO may display but disappear sporadically when vehicle is started or screen content changes. AUTO function is not impaired, software remedy expected to be available 5/15.

See: https://mbworld.org/forums/new-s-cla...ml#post6350706

I'd have the dealer re-flash it. Sounds like they may not have properly updated your car.
I posted this above - except the "fix" doesn't fix it, as they already performed the steps from the bulletin

I have to return to my dealer again
jenz is offline  
Old 07-27-2017, 10:04 PM
  #9  
Senior Member
 
Join Date: Mar 2017
Location: Alabama, USA
Posts: 404
Received 72 Likes on 59 Posts
2017 S63 AMG, Honda Accord, Genesis G90
I just wish there was a "sync" button so that I don't have to go to the menu section to reset it.
MBS63AMG is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: