Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > New S-Class (W222)
W222 2014 s class Horn issue >

W222 2014 s class Horn issue

Notices
New S-Class (W222) 2014-Present

W222 2014 s class Horn issue

 
Old 11-19-2018, 08:18 AM
  #1  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 6
Received 0 Likes on 0 Posts
W222
Arrow W222 2014 s class Horn issue

I own an S Slass W222 2014 Long wheelbase model.

Recently while driving the horn started going by itself without any reason, this went on for about 2-3 minutes and then horn stopped working.

Since then I have replaced the Horn relay and also checked the Horn fanfare fuse, they are both fine.

Also the horns do work when i lock the car which is very strange

The horn still doesn't work, I would prefer to diagnose and fix this issue myself, Does anyone know where are the actual horns are and how should I replace them?


Any advice would be highly appreciated

Thank you

Alan

Last edited by Illusionist; 11-19-2018 at 08:39 AM. Reason: rememembered new information
Illusionist is offline  
Old 11-19-2018, 08:37 AM
  #2  
MBWorld Fanatic!
 
1bad540's Avatar
 
Join Date: Jan 2014
Location: Newyork
Posts: 1,801
Likes: 0
Received 131 Likes on 117 Posts
s550 Diamond white amg pano
sounds like the contacts in the steering wjeel may be making contact... has the cars airbag been changed?
1bad540 is offline  
The following users liked this post:
Illusionist (11-19-2018)
Old 11-19-2018, 08:39 AM
  #3  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 6
Received 0 Likes on 0 Posts
W222
Thank you for your reply

No the airbag or the wheel have never been touched
Illusionist is offline  
Old 11-19-2018, 08:44 AM
  #4  
Out Of Control!!
 
hyperion667's Avatar
 
Join Date: Jul 2010
Location: North Carolina
Posts: 21,656
Received 736 Likes on 713 Posts
2012 CLS63
Kongnister where are you?? He's the guy with ALL the info on MB's you'll ever need. Haven't seen him around as of late. Is your car CPO or extended warranty? I had that happen on a Porsche once! You got lucky when it went off in three minutes! Mine was blowing ALL the way to the dealer LOL!

good luck.
hyperion667 is offline  
Old 11-19-2018, 11:16 AM
  #5  
Super Member
 
Join Date: Apr 2007
Location: San Diego, CA
Posts: 712
Received 117 Likes on 103 Posts
2018 E400 Coupe, 2012 SLK350
Yep, PM konigstiger to see if he can get you the relevant diagrams.
teksurv is offline  
The following 2 users liked this post by teksurv:
hyperion667 (11-19-2018), Illusionist (11-19-2018)
Old 11-19-2018, 12:14 PM
  #6  
Out Of Control!!
 
hyperion667's Avatar
 
Join Date: Jul 2010
Location: North Carolina
Posts: 21,656
Received 736 Likes on 713 Posts
2012 CLS63
Right, I's sure he'd appreciate the correct spelling more
hyperion667 is offline  
Old 11-19-2018, 04:12 PM
  #7  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 6
Received 0 Likes on 0 Posts
W222
it looks like it might be the steering wheel contacts causing this issue as the horn still works when i lock the car, anyone knows how should i go about opening and investigating the steering wheel? there is no guidance anywhere on the internet, Dealer said 168 just to investigate the failure, i would prefer not to go down the dealership path if i can help it, dont know how to contact konigstiger
Illusionist is offline  
Old 11-20-2018, 02:54 AM
  #8  
MBWorld Fanatic!
 
BenzV12's Avatar
 
Join Date: Dec 2011
Posts: 2,741
Received 29 Likes on 28 Posts
2017 BMW G30 530i XDrive
I had read an erratic horn issue that turned out to be a broken alarm module in a friend's BMW . In that instance, he said his cars horn went off in the middle of the night without any reason
BenzV12 is offline  
Old 11-20-2018, 04:31 AM
  #9  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 6
Received 0 Likes on 0 Posts
W222
Does anyone actually know how should i open the steering wheel, take the airbag out? there are no pin holes at the back, do I need to make holes by pressing into the space available? i would rather not make holes if i can help it, any help is highly appreciated
Illusionist is offline  
Old 11-24-2018, 12:36 PM
  #10  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 6
Received 0 Likes on 0 Posts
W222
a quick progress update

after disconnecting the battery I took the airbag out of the steering wheel and found nothing wrong, All cables are connected just fine, no issue with the electronic board either, i am really confused what to do next, any advice from anyone would be appreciated
Illusionist is offline  
Old 11-24-2018, 01:44 PM
  #11  
Out Of Control!!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 10,398
Received 1,167 Likes on 982 Posts
'71 Pinto
Attached wiring diagrams may help.
Attached Files
File Type: pdf
Steering wheel.pdf (389.1 KB, 28 views)
File Type: pdf
Horn.pdf (488.2 KB, 35 views)
konigstiger is offline  
Old 12-01-2018, 10:36 AM
  #12  
Newbie
Thread Starter
 
Join Date: Nov 2018
Posts: 6
Received 0 Likes on 0 Posts
W222
Problem resolved





Please see below steps I took to resolve the issue

i refuse to take it to Mercedes for them to charge me 170 just to check this tiny issue

1. I disconnected the battery which is in the boot and very simple to do after which you must wait 30 minutes to stop airbag blowing on your face.
2. I took the airbag out of the steering wheel which is very simple by pushing inside the holes with screw driver behind the steering wheel, remember you have to break the leather seal to do this.
3. Open 3 holes and take the horn plate out
4. Disconnect all of the cables from the plate which you can see in the attached picture.
5. I quickly discovered that one of the connector marked red had a tiny hole inside, after checking with multi meter I could see it was not conducting electricity.
6. Using hot soldering iron I just dropped a tiny amount of solder which resolved the issue
put everything back in the same order and your issue is fixed

Last edited by Illusionist; 12-01-2018 at 10:40 AM. Reason: Pictures were missing
Illusionist is offline  
Old 12-01-2018, 01:34 PM
  #13  
Out Of Control!!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 10,398
Received 1,167 Likes on 982 Posts
'71 Pinto
konigstiger is offline  
Old 12-01-2018, 05:52 PM
  #14  
Out Of Control!!
 
hyperion667's Avatar
 
Join Date: Jul 2010
Location: North Carolina
Posts: 21,656
Received 736 Likes on 713 Posts
2012 CLS63
Glad you worked it out, well done!
hyperion667 is offline  
Old 12-02-2018, 01:46 AM
  #15  
MBWorld Fanatic!
 
BenzV12's Avatar
 
Join Date: Dec 2011
Posts: 2,741
Received 29 Likes on 28 Posts
2017 BMW G30 530i XDrive
Great job, good to see it was fixed
BenzV12 is offline  
Old 12-02-2018, 06:39 PM
  #16  
Super Member
 
Join Date: Apr 2016
Posts: 877
Received 87 Likes on 76 Posts
2014 S550 AMG, 2017 XT5
Thumbs up

Originally Posted by Illusionist View Post




Please see below steps I took to resolve the issue

i refuse to take it to Mercedes for them to charge me 170 just to check this tiny issue

1. I disconnected the battery which is in the boot and very simple to do after which you must wait 30 minutes to stop airbag blowing on your face.
2. I took the airbag out of the steering wheel which is very simple by pushing inside the holes with screw driver behind the steering wheel, remember you have to break the leather seal to do this.
3. Open 3 holes and take the horn plate out
4. Disconnect all of the cables from the plate which you can see in the attached picture.
5. I quickly discovered that one of the connector marked red had a tiny hole inside, after checking with multi meter I could see it was not conducting electricity.
6. Using hot soldering iron I just dropped a tiny amount of solder which resolved the issue
put everything back in the same order and your issue is fixed
There may be a reason that connecter overheated to cause the original problem. Keep an eye on it..... Time will tell... Just like blowing fuses, replacing the fuse is not the fix, something is causing it blow..... Excellent DIY job !
Nice Ride is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: W222 2014 s class Horn issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: