Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > New S-Class (W222)
No Start, all looks OK but wont crank >

No Start, all looks OK but wont crank

Notices
New S-Class (W222) 2014-Present

No Start, all looks OK but wont crank

 
Old 01-25-2019, 08:39 PM
  #1  
Member
Thread Starter
 
Join Date: May 2008
Posts: 174
Liked 5 Times in 4 Posts
merdeces s320
No Start, all looks OK but wont crank

I have a W222 2015

Today I went to start it and it does not crank, does not click, dash lights do not dim.

Key moves all the way as it should

I checked in Xentry, all relevant units have DAS Start authorization

All circuits are on except circuit 50 (ignition). When I turn the key to crank, circuit 50 jumps to ON

Xentry is zhowing zero errors. Would appreciate any advice to help pinpoint,

I switched out the starter relay, made no difference. I have the wiring diagrams, all fuses seem OK.
terrymargate is offline  
Old 01-26-2019, 07:04 AM
  #2  
Senior Member
 
Join Date: Mar 2018
Location: Florida
Posts: 261
Liked 80 Times in 53 Posts
S600 Maybach, Ford econoline van, AMG GTC
Based on what you said if its possible I think I would be inclined to try to run jumper wires to the starter and see if it works......
Katie22 is offline  
Old 01-26-2019, 02:46 PM
  #3  
Member
Thread Starter
 
Join Date: May 2008
Posts: 174
Liked 5 Times in 4 Posts
merdeces s320
SOLVED

Have solved it.

Found another fuse. Initially I checked Fuse 111 which runs to the starter solenoid.

Then I checked the circuit diagram and found another fuse (129) which is just before the starter relay, turns out that was the culprit

Fuse diagram attached, hope this helps someone in future



terrymargate is offline  
Old 01-27-2019, 01:45 AM
  #4  
MBWorld Fanatic!
 
BenzV12's Avatar
 
Join Date: Dec 2011
Posts: 2,730
Liked 25 Times in 24 Posts
2017 BMW G30 530i XDrive
Good to hear you got it fixed , I thought it was a battery related issue
Happy Driving
BenzV12 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: No Start, all looks OK but wont crank


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: