S.A.M. Unit grounded out 2000 S500 Please Help - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W220)
S.A.M. Unit grounded out 2000 S500 Please Help >

S.A.M. Unit grounded out 2000 S500 Please Help

S-Class (W220) 1999-2006: S 320 CDI, S 320, S430, S 500, S 600

S.A.M. Unit grounded out 2000 S500 Please Help

Reply

 
 
 
Old 01-12-2018, 08:42 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
2000 S 500
S.A.M. Unit grounded out 2000 S500 Please Help

Today I pulled out the Right SAM Unit and without thinking to disconnect battery first "rookie mistake" I accidentally touched the main power supply to the SAM unit causing a big spark, Now when I turn the key I get nothing... but the aux fan comes on fast and wont shut off unless I unplug the battery. Also I can turn the key once but after the fan comes on it will not turn again until I unplug the battery. I am thinking a new sam? I tested the Pre Fuse and seems to be powered up have not tested the smaller red lines yet.
Pierre Sutton is offline  
Reply With Quote
Old 01-12-2018, 09:44 PM
  #2  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,180
Thanked 59 Times in 55 Posts
2003 S430
" I tested the Pre Fuse and seems to be powered up have not tested the smaller red lines yet."

Please tell us in exact detail what you checked and what you found. Be very precise and complete.
wallyp is offline  
Reply With Quote
Old 01-12-2018, 11:01 PM
  #3  
Newbie
Thread Starter
 
Join Date: Jan 2018
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
2000 S 500
Originally Posted by wallyp View Post
" I tested the Pre Fuse and seems to be powered up have not tested the smaller red lines yet."

Please tell us in exact detail what you checked and what you found. Be very precise and complete.
Ok after the Big Spark, I tested the Pre Fuse under the footwell of the pass side floor, Tested all the fuses left and right "front" boxes" tested trunk Pre fuse on right wall, all seemed to be good (but) from reading, i did not know on the front pre fuse to check every single wire! there are two smaller red wires needed to be checked. I noticed where the Hot wire touched the SAM on the aluminum was burnt, so I opened the SAM and looked at the board and nothing popped out at me as being burnt. There is a Unit right next to the Right hand SAM that I have no Idea of what it is, but tomorrow I will check for burns on that but doubt it.
Pierre Sutton is offline  
Reply With Quote
Old 01-13-2018, 10:50 AM
  #4  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,180
Thanked 59 Times in 55 Posts
2003 S430
"... the Pre Fuse under the footwell of the pass side floor..."

There is not "a" pre-fuse there, but three. (Those may be the other wires that you need to check - but there are fuses.) In addition, the wires and connections must be carefully checked.

This has happened before to other people. Go to the top of the page, find "SEARCH", go to "ADVANCED SEARCH" enter suitable search terms in the box, scroll down in the list to "W220" and search. It might help to see what other folks had to do...
Do the same search on Google and other MB forum sites.
wallyp is offline  
Reply With Quote
Old 01-14-2018, 07:31 PM
  #5  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 4,846
Thanks: 0
Thanked 148 Times in 146 Posts
Mercedes
Hello

Originally Posted by Pierre Sutton View Post
Today I pulled out the Right SAM Unit and without thinking to disconnect battery first "rookie mistake" I accidentally touched the main power supply to the SAM unit causing a big spark, Now when I turn the key I get nothing... but the aux fan comes on fast and wont shut off unless I unplug the battery. Also I can turn the key once but after the fan comes on it will not turn again until I unplug the battery. I am thinking a new sam? I tested the Pre Fuse and seems to be powered up have not tested the smaller red lines yet.
first and cheapest step is to replace the fuse box under the passenger floor with a good used unit

however I think you damaged your eCU as fan on high indicates bad eCU . So second step is to replace 4 parts - key shifter eCU and ignition switch . All must be taken from the same donor car or it will not work . Cost about $350 for matched set of 4 parts in Ebay
tusabes is offline  
Reply With Quote
Old 01-16-2018, 12:10 PM
  #6  
MBWorld Fanatic!
 
Join Date: Jun 2011
Location: Cape town
Posts: 1,049
Thanks: 0
Thanked 82 Times in 81 Posts
not a merc
Why you all getting so complicated. You know your F...up just replace the Sam and all will be happy again
Russell Ormerod is offline  
Reply With Quote
 
 
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: S.A.M. Unit grounded out 2000 S500 Please Help


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: