Go Back  MBWorld.org Forums > Mercedes-Benz SLR & SL Roadsters > SL-Class (R129)
Blower motor issue...98 sl 500 >

Blower motor issue...98 sl 500

Notices
SL-Class (R129) 1990-2002: SL 280, SL 300, SL 320, SL 500, SL 600, SL 60 AMG

Blower motor issue...98 sl 500

 
Old 01-07-2019, 09:59 AM
  #1  
Newbie
Thread Starter
 
Herbman's Avatar
 
Join Date: Aug 2014
Location: Tampa, FL
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
1998 SL500
Blower motor issue...98 sl 500

I had a battery drain about 4 weeks ago...had it re-charged everything ok except no blower motor function for AC/heater vents... AC blows out as car is moving but at standstill nothing...when in key start placement 2 you can hear a clicking noise coming from blower motor assembly section under hood..any suggestions?

Herbman is offline  
Old 01-07-2019, 05:36 PM
  #2  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,714
Thanked 574 Times in 557 Posts
1999 E300TD
Yep, blower regulator-----cheap fix,however be smarter than most and identify the part correctly with your VIN!
Plutoe is offline  
Old 01-08-2019, 08:41 AM
  #3  
Newbie
Thread Starter
 
Herbman's Avatar
 
Join Date: Aug 2014
Location: Tampa, FL
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
1998 SL500
Thanks Plutoe, I thought that may be the issue...doesn't look like fun to replace...wondering if I should just
go ahead and replace blower motor too
while I have everything torn apart...I appreciate your thoughts..
Herbman is offline  
Old 01-12-2019, 12:29 PM
  #4  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,714
Thanked 574 Times in 557 Posts
1999 E300TD
Well that is a very personal choice regarding a maintenance philosophy---aka that is your decision!
Plutoe is offline  
Old 01-24-2019, 10:30 AM
  #5  
Junior Member
 
Join Date: Jul 2017
Posts: 53
Thanked 3 Times in 3 Posts
R129/SL500
Originally Posted by Herbman View Post
Thanks Plutoe, I thought that may be the issue...doesn't look like fun to replace...wondering if I should just
go ahead and replace blower motor too
while I have everything torn apart...I appreciate your thoughts..
There is a tab that the blower motor hold down spring clips to. They break allowing the blower motor to move preventing it from spinning. I am not saying that is your problem, just that it could be. I did my resistor a couple of years ago and found the broken spring clip as many have. I replaced the resistor (have to go aftermarket the Mercedes ones are no longer available and were $500). I purchased a Bosch blower motor and the part that houses everything that the latch broke off of in case I ever have to go in there again, I haven't had to?

Look on you tube for blower motor resistor and for broken blower motor hold down. The aftermarket blower motor resistors are not a direct bolt on. You have to remove the old epoxied and screwed on resistor from the mount/fins and grind off a tab (easy). It is then recommended that you use a thermal paste when mounting the resistor.

Check this thread scroll down for pictures
thealien is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Blower motor issue...98 sl 500


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: