Notices
SL-Class (R230) 2003 -- 2012: Discussion on the SL500, SL550, SL600

1999 SL500 will not start.

 
Old 03-14-2019, 07:54 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
SL500
1999 SL500 will not start.

'99 Sl500 Fuel pump ticking, new fuel filter, fuses/relays ok, but will not start. Ran fine until stored for one year, then didn't start. It will start and run for a few seconds if I pour some gas in the intake.
pmb1224 is offline  
Old 03-14-2019, 08:41 PM
  #2  
MBworld Guru
 
Rudeney's Avatar
 
Join Date: Dec 2009
Location: Birmingham, AL
Posts: 9,838
Thanked 716 Times in 668 Posts
CURRENT: 2011 SL550, 2010 ML350, FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
What's the pressure on the fuel rail after turning the key to position 2? Should be around 55psi. If it's good, but then drops after cranking, it could be a bad crankshaft position sensor.
Rudeney is offline  
Old 03-15-2019, 05:32 PM
  #3  
Newbie
Thread Starter
 
Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
SL500
1999 SL500 will not start

Originally Posted by Rudeney View Post
What's the pressure on the fuel rail after turning the key to position 2? Should be around 55psi. If it's good, but then drops after cranking, it could be a bad crankshaft position sensor.
Got 0 pressure when turning the key on position 2 and cranking it over. Even got a second fuel pressure gauge to make sure the first was not bad. Thanks for your input. I assumed I was getting fuel because a little fuel came from the valve on the fuel rail and naively didn't suspect fuel pressure problems because of that.
pmb1224 is offline  
Old 03-15-2019, 08:09 PM
  #4  
MBworld Guru
 
Rudeney's Avatar
 
Join Date: Dec 2009
Location: Birmingham, AL
Posts: 9,838
Thanked 716 Times in 668 Posts
CURRENT: 2011 SL550, 2010 ML350, FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
I just noticed - you said 1999 SL550? That's an R129. You should probably check that forum. It could be a fuse or wiring issue.
Rudeney is offline  
Old 03-16-2019, 12:13 PM
  #5  
Newbie
Thread Starter
 
Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
SL500
Rodney,

Thanks! I didn't know about the R129 designator. As you can probably tell this is my first Mercedes. I've found this to be a little more complicated and costly than other cars. I've also noticed that after 15 years or so, or after 50K miles, maintenance goes way up.

Originally, there seemed to be fuel when I pressed the schrader valve on the fuel rail, but I don't get any now. I've changed the fuel fiilter and the relays all click when the key is on. Looks like it's the fuel pump since I got no pressure reading.I didn't suspect the fuel pump at first because I could hear it buzzing when the key was on.
Thanks again for your help,

Pete
pmb1224 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 1999 SL500 will not start.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: