Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

A/C and heating problem in 2009 E63 AMG wagon

 
Old 05-11-2019, 09:54 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2012
Location: Chicago suburbs
Posts: 33
Likes: 0
Received 2 Likes on 2 Posts
1990 300E 2016 BMW 340i 2009 E63 AMG Wagon:)
A/C and heating problem in 2009 E63 AMG wagon

Hello forum members !
So a while back I have purchased a 2009 AMG wagon. Car has been great so far, I have been using it as a weekend car here in Chicago area. Iíve tried to find some info on my problem but havenít gotten much luck so I thought that I will start a new thread, that maybe would help someone in the future. My problem is that the a/c would work while driving. When I would stop the car and engine sits at idle, air conditioning will shut off after short while and it wouldnít blow more cold air until I would resume driving again. Also on occasion, heating wouldnít blow hot air either, in order for it to work I would have to turn climate control unit completely off than turn it back on. When I do this it will blow warm air again. If any of the knowledgeable forum members would chime in I would really appreciate it. I am fairly handy and can work on the car to some extent, but with a/c itís not exactly familiar. I have the heater valve ( the one that sits by the windshield, but havenít got to replacing it just yet. Sorry for any and all mistakes, since I am not a native speaker. Good day to everyone!
Rafichicago is offline  
Old 05-14-2019, 04:32 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Jul 2012
Location: Chicago suburbs
Posts: 33
Likes: 0
Received 2 Likes on 2 Posts
1990 300E 2016 BMW 340i 2009 E63 AMG Wagon:)
So nobody has any clue what that might be ? This canít be so complicated 😉
Rafichicago is offline  
Old 05-14-2019, 04:48 PM
  #3  
MBWorld Fanatic!
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,621
Received 133 Likes on 114 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
mine does this at times also. sometimes the A/C comes on super cold within 2 seconds of engine start....other times it'll take 5 minutes. i've had my A/C inspected and all check out ok. generally for me this only occurs when its real hot outside and is random.
hachiroku is offline  
Old 05-14-2019, 05:59 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Jul 2012
Location: Chicago suburbs
Posts: 33
Likes: 0
Received 2 Likes on 2 Posts
1990 300E 2016 BMW 340i 2009 E63 AMG Wagon:)
My ac does it every time I stop letís say at the traffic lights or just get stuck in a traffic.
Rafichicago is offline  
Old 05-14-2019, 06:02 PM
  #5  
MBWorld Fanatic!
 
Hulk's Avatar
 
Join Date: Dec 2011
Location: Florida
Posts: 4,556
Received 94 Likes on 82 Posts
A Merc
You guys need to check your expansion valves and evaporator
unfortunately you need to remove the whole dash to check those however if you need to top off the ac here and there more likely than not
look at my thread, it’s not easy
Hulk is offline  
Old 05-14-2019, 11:45 PM
  #6  
Junior Member
Thread Starter
 
Join Date: Jul 2012
Location: Chicago suburbs
Posts: 33
Likes: 0
Received 2 Likes on 2 Posts
1990 300E 2016 BMW 340i 2009 E63 AMG Wagon:)
Thereís refrigerant in the system. It doesnít have a leak. What it does do it stops cooling once engin is idling.
Rafichicago is offline  
Old 05-15-2019, 08:57 AM
  #7  
MBWorld Fanatic!
 
Hulk's Avatar
 
Join Date: Dec 2011
Location: Florida
Posts: 4,556
Received 94 Likes on 82 Posts
A Merc
Then it’s very well possible that it’s the expansion valve or if you are lucky the the refrigeration regulator but that works together with the expansion valve
Hulk is offline  
Old 05-16-2019, 07:26 AM
  #8  
MBWorld Fanatic!
 
Join Date: Dec 2008
Posts: 2,124
Received 17 Likes on 13 Posts
shrimp boat
Originally Posted by Rafichicago View Post
Thereís refrigerant in the system. It doesnít have a leak. What it does do it stops cooling once engin is idling.
Did you recently fill the Freon? Im 90% sure that you have too much Freon in your system. The easy fix is to let off some of the pressure on the high pressure side. If you have the ac gauge hooked them up and see what happens when the system is on.
Forrest Gump 9 is offline  
Old 05-16-2019, 08:35 AM
  #9  
Junior Member
Thread Starter
 
Join Date: Jul 2012
Location: Chicago suburbs
Posts: 33
Likes: 0
Received 2 Likes on 2 Posts
1990 300E 2016 BMW 340i 2009 E63 AMG Wagon:)
Originally Posted by Forrest Gump 9 View Post
Did you recently fill the Freon? Im 90% sure that you have too much Freon in your system. The easy fix is to let off some of the pressure on the high pressure side. If you have the ac gauge hooked them up and see what happens when the system is on.

Thanks for replying. My wife is working at Mercedes dealer. Tech checked it and it seems to be the right amount of refrigerant in the system. For some reason he said that compressor should be replaced but I find this odd since it is working properly when driving. Weird... I donít have problem putting new one in. I just donít want to throw random parts on the car without fully diagnosing the issue.
Rafichicago is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: A/C and heating problem in 2009 E63 AMG wagon


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: