Go Back  MBWorld.org Forums > Mercedes-Benz AMG Vehicles > E55 AMG, E63 AMG, E43AMG (W210, W211, W212,W213) > W212 AMG
Who’s had code P2610 ECM / PCM  Interval engine off timer ????? >

Who’s had code P2610 ECM / PCM Interval engine off timer ?????

Notices
W212 AMG Discuss the W212 AMG's such as the E63
Sponsored by:
Sponsored by:

Who’s had code P2610 ECM / PCM Interval engine off timer ?????

 
Old 04-12-2019, 11:41 PM
  #1  
Super Member
Thread Starter
 
Join Date: May 2010
Location: Chicago
Posts: 718
Liked 29 Times in 27 Posts
2015 E63 AMG S
Who’s had code P2610 ECM / PCM Interval engine off timer ?????

Just had this code P2610 ECM / PCM Interval engine off timer pop up as “pending code” which came under just normal driving on my bone stock 2015 E63S with 30k miles on her.

I cleared the code with my ODB2 device and car is totally fine....anyone seen this code before and know what it is / what causes it????


jvakos is offline  
Old 04-12-2019, 11:57 PM
  #2  
MBWorld Fanatic!
 
PeterUbers's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 8,536
Likes: 0
Liked 450 Times in 389 Posts
2014 E63S, 2014 Acura MDX, 2008 Infiniti G35x
Originally Posted by jvakos View Post
Just had this code P2610 ECM / PCM Interval engine off timer pop up as “pending code” which came under just normal driving on my bone stock 2015 E63S with 30k miles on her.

I cleared the code with my ODB2 device and car is totally fine....anyone seen this code before and know what it is / what causes it????

hows your battery?
PeterUbers is offline  
Old 04-14-2019, 03:42 AM
  #3  
MBWorld Fanatic!
 
PeterUbers's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 8,536
Likes: 0
Liked 450 Times in 389 Posts
2014 E63S, 2014 Acura MDX, 2008 Infiniti G35x
PeterUbers is offline  
Old 04-14-2019, 10:26 AM
  #4  
Super Member
Thread Starter
 
Join Date: May 2010
Location: Chicago
Posts: 718
Liked 29 Times in 27 Posts
2015 E63 AMG S
peter thanks. Battery seems good but the car has been sitting and only driven like 1 time every 4 weeks while i wait for this chicsgo winter to pass (apparently not done yet with today snow!!). I cleared the code and all seems fine. I forgot to mention that I did do a battery pull the day before to reset the trans adaptations so maybe that’s what caused it.
jvakos is offline  
Old 04-14-2019, 01:37 PM
  #5  
MBWorld Fanatic!
 
PeterUbers's Avatar
 
Join Date: Jun 2004
Location: Chicago, IL
Posts: 8,536
Likes: 0
Liked 450 Times in 389 Posts
2014 E63S, 2014 Acura MDX, 2008 Infiniti G35x
I bet it's the battery pull


dude ... wtf.... blizzard again!????? This is ridiculous i hate our weather!!! I was gunna do a quick mow of the lawn to mow up leaves and debris!!!!
PeterUbers is offline  
Old 04-14-2019, 02:33 PM
  #6  
Super Member
Thread Starter
 
Join Date: May 2010
Location: Chicago
Posts: 718
Liked 29 Times in 27 Posts
2015 E63 AMG S
Originally Posted by PeterUbers View Post
I bet it's the battery pull


dude ... wtf.... blizzard again!????? This is ridiculous i hate our weather!!! I was gunna do a quick mow of the lawn to mow up leaves and debris!!!!
i know man it’s NUTS!! 60 yesterday and now blizzard today and having to shovel this mess!!

Glad I got the 63 out yesterday to have some fun while the roads were clear! Dare I say this has to be the very last snow for us?????
jvakos is offline  
Old 04-15-2019, 08:38 AM
  #7  
Senior Member
 
Join Date: Feb 2017
Posts: 265
Liked 25 Times in 21 Posts
2014 E63 AMG wagon
Originally Posted by jvakos View Post
i know man it’s NUTS!! 60 yesterday and now blizzard today and having to shovel this mess!!

Glad I got the 63 out yesterday to have some fun while the roads were clear! Dare I say this has to be the very last snow for us?????
Fu*k the shovel. I'm just north of Chicago in Milwaukee, we got 4" of wet snow. Unreal! E is sitting pretty in the Garage as I just put summers on last week.
Savage212 is offline  
The following users liked this post: Savage212
jvakos (04-15-2019)
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Who’s had code P2610 ECM / PCM Interval engine off timer ?????


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: