Trackday problem - MBWorld.org Forums

Log In 


C63 AMG (W204) Discuss the C63 AMG

Sponsored by : Kleemann USA
Click Here

Trackday problem

Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 09-10-2012, 04:10 AM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
Trackday problem

I have a 2012 MY C63 Coupe. Pretty standard car without performance pack for example.

Took it on track at the weekend - not really pushing that hard as far as I am concerned and it lasted maximum 3 laps each session before refusing to accelerate or change gear. Half a lap at slow speed and it recovered but not properly.

Now after reading forums I avoided 'M' and used both S and S+ but it made no difference.

Can anybody suggest what is causing this and what maybe can be upgraded / replaced ? I dont want to take it on track every week but a couple of times a year so prefer this not to happen !
dtriggs is offline   Reply With Quote
Old 09-10-2012, 05:55 AM   #2
MBWorld Fanatic!
 
Even Money's Avatar
 
Join Date: Jul 2009
Location: PNW
Posts: 1,750
Drives: '15 VW GTI
Thanks: 0
Thanked 0 Times in 0 Posts
It's normal. Very difficult to repeatedly lap this car and not have it overheat, and go into limp mode. You would need to upgrade your oil coolers, diff coolers, etc.
Even Money is offline   Reply With Quote
Old 09-10-2012, 06:10 AM   #3
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
That seems a little weak from MB's side. It's an AMG - surely it can do a bit better than that ? How do the journalists manage to lap them power sliding round corner after corner ? Or do they just do 2 laps, then in ?

D
dtriggs is offline   Reply With Quote
Old 09-10-2012, 08:12 AM   #4
MBWorld Fanatic!
 
gthal's Avatar
 
Join Date: Sep 2011
Posts: 1,296
Drives: 2012 C63 coupe
Thanks: 0
Thanked 0 Times in 0 Posts
Yes... Well known issue. Shame on MB.
gthal is offline   Reply With Quote
Old 09-10-2012, 08:27 AM   #5
Member
 
Join Date: May 2012
Posts: 161
Drives: C63 amg
Thanks: 0
Thanked 0 Times in 0 Posts
The pre 2012 C63 doesn't have this issue.
Z63amg is offline   Reply With Quote
Old 09-10-2012, 08:35 AM   #6
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
What is different pre-2012 ? Surely the transmission is more resilient ?
dtriggs is offline   Reply With Quote
Old 09-10-2012, 09:29 AM   #7
MBWorld Fanatic!
 
Join Date: Jan 2009
Posts: 4,370
Drives: C63 AMG
Thanked 7 Times in 6 Posts
I had no problems lapping. We would only go out for about 10mims at a time though.

I think you guys are running it too hard in high ambient temps.
Merc63 is offline   Reply With Quote
Old 09-10-2012, 09:31 AM   #8
Member
 
Join Date: May 2012
Posts: 161
Drives: C63 amg
Thanks: 0
Thanked 0 Times in 0 Posts
The transmission is different. I had an MB tech who said the new tranny will have more issues with more mileage racked on it as well. He said that a lot of people who traded in their preface lift for new ones are complaining about track performances.
Z63amg is offline   Reply With Quote
Old 09-10-2012, 09:33 AM   #9
Super Member
 
Join Date: Jan 2008
Posts: 856
Drives: your mom
Thanks: 0
Thanked 0 Times in 0 Posts
It suffers from heat soak - Any big motor does. High Ambient temperature doesn't help either.

A well ventilated hood - plus a upgraded coolers are just part of the solution.
USCGTO is offline   Reply With Quote
Old 09-10-2012, 09:46 AM   #10
MBWorld Fanatic!
 
gthal's Avatar
 
Join Date: Sep 2011
Posts: 1,296
Drives: 2012 C63 coupe
Thanks: 0
Thanked 0 Times in 0 Posts
My issue wasn't transmission related. The engine got too hot and went into limp mode. Oil temp was too high. This would be an issue pre facelift as this was not due to anything changed with the facelift. On cooler days or shorter sessions, this likely would be no issue.
gthal is offline   Reply With Quote
Old 09-10-2012, 09:50 AM   #11
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
But outside temp was no more than 24-25 deg c on Saturday where I was so cannot see ambient temperature as an issue.

D
dtriggs is offline   Reply With Quote
Old 09-10-2012, 10:12 AM   #12
MBWorld Fanatic!
 
Join Date: May 2010
Location: Ottawa, Ontario, Canada
Posts: 7,623
Drives: 2010 C63 AMG, 2009 ISF , 2002 L-Tuned IS300, 2011 ML350
Thanked 8 Times in 8 Posts
This is probably why we have to stop every 2 laps at the AMG events... still not acceptable for this type of cars. My friend SLS (1stamg) doesn't have that problem at the track from what I heard.
Roswell is offline   Reply With Quote
Old 09-10-2012, 10:44 AM   #13
Super Member
 
Join Date: Jan 2008
Posts: 856
Drives: your mom
Thanks: 0
Thanked 0 Times in 0 Posts
I wont be surprised if the AMG academy routine was designed in that fashion...
USCGTO is offline   Reply With Quote
Old 09-10-2012, 10:55 AM   #14
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
Got to be honest, I am not really in the mood to just accept 'they all do that sir' as an excuse.
dtriggs is offline   Reply With Quote
Old 09-10-2012, 10:55 AM   #15
Super Member
 
w202mylove's Avatar
 
Join Date: Dec 2009
Location: netherlands
Posts: 609
Drives: Carlsson CM60 EX:C36AMG'96
Thanks: 0
Thanked 0 Times in 0 Posts
so let me get this straight, sls doesn't have this and the c63 bs right? do the pre face lift c63's have this problem or not? obviously this problem is a huge shame on amg srry
w202mylove is offline   Reply With Quote
Old 09-10-2012, 11:41 AM   #16
MBWorld Fanatic!
 
Dads C63's Avatar
 
Join Date: Sep 2008
Location: Central Florida
Posts: 2,169
Drives: 2014 Audi RS7
Thanks: 0
Thanked 0 Times in 0 Posts
When you track the car try removing the front grill frirst. Thats the simplest.

If you are going to be a track rat then replace the front bumper with a more open style like the Revozport or others with a larger opening.

The BS oil and tranny coolers are larger and easily replace the stock coolers as well. I just replaced both the tranny and oil coolers and they are significantly larger.

Heat IS the enemy. not sure about the new 2012 models but the heat issues can be resolved in the earlier 2008-2011 models. Good luck and be safe!
Dads C63 is offline   Reply With Quote
Old 09-10-2012, 02:05 PM   #17
Member
 
Join Date: Feb 2012
Posts: 98
Drives: 2011 Range Rover Sport SC
Thanks: 0
Thanked 0 Times in 0 Posts
Hmmm, so that leads me to two quick questions then. One, are the oil and tranny coolers from the BS a straight bolt-on in the C63 (non BS)? IE, no cutting, welding or body-work required to drop them in?

And two....any likely sources besides MB to order the Black Series oil and tranny coolers?

Anybody have any part numbers that I could get? Given the extent I expect to be tracking this car, I'd imagine that will be one of the first things I try to get done.



Thanks,



Patrick
Patrick B is offline   Reply With Quote
Old 09-11-2012, 05:21 AM   #18
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
When describing my problem with the car I said 'limp mode' but in reality all that happened was it stuck at high revs in a lowish gear and would change. I have now talked with a friend in California who has a C63 and on the road had this problem. The dealer did a software reboot and although it already had the latest gearbox software it apparently has made a difference.

I will talk to my dealer today.
dtriggs is offline   Reply With Quote
Old 09-11-2012, 07:38 AM   #19
MBWorld Fanatic!
 
Join Date: May 2007
Location: NA
Posts: 1,663
Drives: 2014 E63S
Thanked 9 Times in 3 Posts
Quote:
Originally Posted by dtriggs View Post
Got to be honest, I am not really in the mood to just accept 'they all do that sir' as an excuse.
You are right. This is unacceptable. Someone who cares enough honestly should do something about it and contact MB Corporate. It is simply not right to advertise a "performance car" sliding around tracks, and in reality it can't go more than 3 laps at a time. If there is a fix (like coolers) MB should pay for it.

Everytime I see this topic pop up I can't believe the track guys just let it be. Someone who truly cares enough should fight this with MB, hopefully that's you. If you need any email addresses, PM me.
rory breaker is offline   Reply With Quote
Old 09-11-2012, 07:41 AM   #20
Junior Member
Thread Starter
 
Join Date: Sep 2012
Location: Surrey, UK
Posts: 32
Drives: C63 AMG Coupe
Thanks: 0
Thanked 0 Times in 0 Posts
Well, I will do what I can and report back. Not in my nature to let things lie so we will see where i get to.

D
dtriggs is offline   Reply With Quote
Old 09-11-2012, 09:35 PM   #21
MBWorld Fanatic!
 
gthal's Avatar
 
Join Date: Sep 2011
Posts: 1,296
Drives: 2012 C63 coupe
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by rory breaker View Post
You are right. This is unacceptable. Someone who cares enough honestly should do something about it and contact MB Corporate. It is simply not right to advertise a "performance car" sliding around tracks, and in reality it can't go more than 3 laps at a time. If there is a fix (like coolers) MB should pay for it.

Everytime I see this topic pop up I can't believe the track guys just let it be. Someone who truly cares enough should fight this with MB, hopefully that's you. If you need any email addresses, PM me.
Some of us just got track cars
gthal is offline   Reply With Quote
Old 09-11-2012, 09:36 PM   #22
MBWorld Fanatic!
 
gthal's Avatar
 
Join Date: Sep 2011
Posts: 1,296
Drives: 2012 C63 coupe
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by dtriggs View Post
When describing my problem with the car I said 'limp mode' but in reality all that happened was it stuck at high revs in a lowish gear and would change. I have now talked with a friend in California who has a C63 and on the road had this problem. The dealer did a software reboot and although it already had the latest gearbox software it apparently has made a difference.

I will talk to my dealer today.
This is what is happening to all of us... or some variation.
gthal is offline   Reply With Quote
Old 09-11-2012, 11:03 PM   #23
MBWorld Fanatic!
 
BerBer63's Avatar
 
Join Date: Aug 2008
Location: Los Angeles
Posts: 2,189
Drives: 2009 C63
Thanked 0 Times in 0 Posts
This has never happened to me after 4-5 sessions per day - 20-25 minutes long (~10 laps). Never use manual mode, only S mode.

Sounds like trans overheated and typical software MCT problem, not pre-2012. Very sad.... DCT, PDK, Manual or nothing here on out.

Last edited by BerBer63; 09-11-2012 at 11:08 PM.
BerBer63 is offline   Reply With Quote
Old 09-11-2012, 11:06 PM   #24
MBWorld Fanatic!
 
Even Money's Avatar
 
Join Date: Jul 2009
Location: PNW
Posts: 1,750
Drives: '15 VW GTI
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by BerBer63 View Post
This has never happened to me after 4-5 sessions per day - 20-25 minutes long (~10 laps). Never use manual mode, only S mode.

Sounds like MCT problem, not pre-2012. Very sad.... DCT, PDK, Manual or nothing
the black series has MCT, no issues AFAIK
Even Money is offline   Reply With Quote
Old 09-12-2012, 01:20 AM   #25
Member
 
Join Date: Mar 2012
Location: Toronto, Canada
Posts: 155
Drives: 2012 C63 PP, 2012 X3
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by rory breaker View Post
You are right. This is unacceptable. Someone who cares enough honestly should do something about it and contact MB Corporate. It is simply not right to advertise a "performance car" sliding around tracks, and in reality it can't go more than 3 laps at a time. If there is a fix (like coolers) MB should pay for it.

Everytime I see this topic pop up I can't believe the track guys just let it be. Someone who truly cares enough should fight this with MB, hopefully that's you. If you need any email addresses, PM me.

I agree. This car is advertised as a car you can take to the track. Please send me any e-mail addresses you think can work.

On a related note, I went in to complain about the heat again and was told it is "normal" and the SA said that I should not put down I took the car to Mosport as it could void the warranty. That is one of the most absurd things I have ever heard. SAs at BMW used to encourage track driving and even invited me to track days.

This is Mercedes Benz Downtown in Toronto, Canada.
DiscoZ is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Airmatic problem, car leaning to one side rbengry GL Class (X164) 2 06-02-2016 11:47 AM
E320 cdi odb I I code p0670 rickf2757 Diesel Forum 14 12-09-2015 07:01 PM
C220CDI pre-facelift won't start in the morning 6thSense C-Class (W203) 3 09-09-2015 04:33 PM
Not signal in Ignition Coil #1 Jancker E-Class (W210) 1 09-08-2015 06:30 PM
c240 driver door lock woes FLYNAVY C-Class (W203) 1 09-07-2015 11:27 AM


Tags
amg, benz, c63, cooler, day, describe, gearbox, home, issue, issues, limp, mercedes, oil, problems, sls, software, track


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -4. The time now is 01:30 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.